.NET

Reply
Mentor
415 Posts
0 Kudos
Registered: ‎09-23-2004
Post 1 of 5

Layer Manager Not Updated

180 Views, 4 Replies
07-17-2012 01:32 PM

What would cause a layer manager to NOT be updated after code has been run to freeze or thaw layers in a viewport?  After I run my program, the viewports will show the layers I want thawed and will hide the layers I want frozen, but when you look at the layer manager, it would show all layers are on and thawed. 

If you save the drawing, close it and re-open it, the layer manager now seems fine and matches the viewports as to what is thawed and what is frozen.

I would appreciate any info on what would cause this.  Also, I can post my code if interested.

Valued Mentor
411 Posts
29 Kudos
Registered: ‎01-27-2010
Post 2 of 5

Re: Layer Manager Not Updated

07-17-2012 02:25 PM in reply to: mgorecki

hi

can you past your code ?

 

Have you commit your transaction  ?

 

 

Valued Mentor
341 Posts
53 Kudos
Registered: ‎05-12-2009
Post 3 of 5

Re: Layer Manager Not Updated

07-17-2012 05:11 PM in reply to: AubelecBE

Try adding a new layer and see what happens

http://www.theswamp.org/index.php?topic=42239.0

You can also find your answers @ TheSwamp
Mentor
415 Posts
0 Kudos
Registered: ‎09-23-2004
Post 4 of 5

Re: Layer Manager Not Updated

07-18-2012 08:12 AM in reply to: jeff
Mentor
415 Posts
0 Kudos
Registered: ‎09-23-2004
Post 5 of 5

Re: Layer Manager Not Updated

07-20-2012 02:59 PM in reply to: mgorecki

Ok, just installed the Service Pack 2 for AutoCad 2010.  That fixed the Layer Manager freeze/thaw issue.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are you interested in helping shape the future of the Autodesk Community? To participate in this brief usability study, please click here. Your time and input is greatly appreciated!