.NET

Reply
Active Member
everts
Posts: 7
Registered: ‎08-30-2007
Message 1 of 3 (184 Views)

Hatch pattern scale problem

184 Views, 2 Replies
08-30-2007 08:11 AM
The following is a part of my code that draw a Polyline with a hatch style, but, I am having some troubles with the pattern scale value. In the code, I put 5 in the pattern scale, but, when I see the properties in LandDesktop, I see the value I wrote (5), but the hatch appears to have another value instead, I mean, if I write manually the value (5), the hatch's appearance change radically. My apologies for my bad english. Thanks in advance!

...
myHatch.SetHatchPattern(HatchPatternType.PreDefined, "AR-SAND");
myHatch.ColorIndex = 2;
myHatch.PatternScale = 5;
...
Contributor
ghethco
Posts: 12
Registered: ‎06-17-2012
Message 2 of 3 (107 Views)

Re: Hatch pattern scale problem

07-17-2012 06:02 AM in reply to: everts
I am seeing the same problem. Anyone know why? Gary
ADN Support Specialist
Virupaksha.aithal
Posts: 101
Registered: ‎06-15-2011
Message 3 of 3 (93 Views)

Re: Hatch pattern scale problem

07-30-2012 02:05 AM in reply to: ghethco

Hi

 

Try setting “SetHatchPattern” after setting “PatternScale” like

 

myHatch.ColorIndex = 2;

myHatch.PatternScale = 5;

myHatch.SetHatchPattern(HatchPatternType.PreDefined, "AR-SAND");



Virupaksha Aithal KM
Developer Technical Services
Autodesk Developer Network

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.