.NET

.NET

Reply
Mentor
mzakiralam
Posts: 231
Registered: ‎11-09-2012
Message 1 of 5 (398 Views)

Complilation Error during Build the Project Setup

398 Views, 4 Replies
03-04-2013 09:09 AM

Hi ,

 

I am trying to deploy my DLL and during compilation , I got the below error.

 

------ Build started: Project: Practice, Configuration: Debug x86 ------

vbc : warning BC40010: Possible problem detected while building assembly 'Practice': Referenced assembly 'mscorlib.dll' targets a different processor

vbc : warning BC40010: Possible problem detected while building assembly 'Practice': Referenced assembly 'System.Data.dll' targets a different processor

Practice -> C:\VBProject\Practice\Practice\bin\x86\Debug\Practice.dll

------ Starting pre-build validation for project 'mySetup' ------

WARNING: Unable to find dependency 'ACMNUPARSER' (Signature='(null)' Version='18.1.0.0') of assembly 'AcCui.dll'

WARNING: Unable to find dependency 'MANAGEDMC3' (Signature='(null)' Version='4.11.0.0') of assembly 'AdWindows.dll'

------ Pre-build validation for project 'mySetup' completed ------

------ Build started: Project: mySetup, Configuration: Debug ------

Building file 'C:\VBProject\Practice\mySetup\Debug\mySetup.msi'...

ERROR: File 'AcTcMgd.dll' targeting 'AMD64' is not compatible with the project's target platform 'x86'

WARNING: File 'AcTcMgd.dll' targeting 'x64' is not compatible with the project's target platform 'x86'

Build process cancelled

========== Build: 1 succeeded or up-to-date, 1 failed, 0 skipped ==========

 

Can anybody help me in this regard? I am using Visual Studio 2010 and AutoCAD 2011. Windows 7 32-bit Operating System. Target CPU: x86. Target Framework: 3.5.

 

My registry settings is below:

 

HKEY_LOCAL_MACHINE\Software\Autodesk\AutoCAD\R18.2\ACAD-A001:409\Applications\Practice

Capture.JPG

 

 

HKEY_CURRENT_USER\Software\Autodesk\AutoCAD\R18.2\ACAD-A001:409\Applications\Practice

Capture.JPG

 

Regards

Zakir

ADN Support Specialist
Balaji_Ram
Posts: 746
Registered: ‎03-21-2011
Message 2 of 5 (325 Views)

Re: Complilation Error during Build the Project Setup

03-18-2013 03:35 AM in reply to: mzakiralam

Hi Zakir,

 

Sorry for the delay.

 

Have you tried netloading the dll into AutoCAD 2011 ?

Does it load ok and can you run the commands correctly ?

 

But, remember to set the .Net framework version to 3.5 for AutoCAD 2011.

 

Also, I see a few error messages indicating a mismatch in platform.

Have you tried building your project with "Any CPU" configuration ?

 

 

 



Balaji
Developer Technical Services
Autodesk Developer Network

*Expert Elite*
_gile
Posts: 2,125
Registered: ‎04-29-2006
Message 3 of 5 (317 Views)

Re : Complilation Error during Build the Project Setup

03-18-2013 05:17 AM in reply to: mzakiralam

Hi,

 

If I do not misunderstand, you're  trying to build a MSI.

If so, you have to exclude all AutoCAD dependencies in your setup project.

 

ExcludeDependencies.png

Gilles Chanteau
Mentor
mzakiralam
Posts: 231
Registered: ‎11-09-2012
Message 4 of 5 (306 Views)

Re: Complilation Error during Build the Project Setup

03-18-2013 07:00 AM in reply to: Balaji_Ram

Hi Balaji,

 

Thanks for your kind response. I have solved this issue. There was mismatching of platform. now this is working fine.

 

Regards

Zakir

Mentor
mzakiralam
Posts: 231
Registered: ‎11-09-2012
Message 5 of 5 (305 Views)

Re : Complilation Error during Build the Project Setup

03-18-2013 07:00 AM in reply to: _gile

Hi _gile,

 

Thanks for your hints.

 

Regards

zakir

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.