.NET

Reply
Contributor
phreakie
Posts: 13
Registered: ‎02-27-2002
Message 1 of 3 (85 Views)

Cant debug ACAD2006 in VB.NET

85 Views, 2 Replies
07-21-2005 08:56 AM
Hello

I am trying to create a managed application for AutoCAD. I have ACAD 2006 and VB.NET 2003 and Object ARX 2006. I downloaded the Labs for VB.NET for the .NET API and I can't get past Lab 2. I created a new project in VB.NET 2003 using the "AutoCAD Managed VB Project Application".

I followed exactly what they say in Lab 2. When I hit F5 to debug it, it starts acad.exe and the aqua-colored splash screen for ACAD2006 rolls down like it usually does. Then the splash screen seems to abruptly stop (it disappears, acad.exe stops running) and Visual Studio stops debugging as returns to its previous state. I don't get any error messages at all.

I have no problems with AutoCAD at all when I run it independently. Why is this happening? I am new to .NET so please be kind. :smileyhappy:
*Albert Szilvasy
Message 2 of 3 (85 Views)

Re: Cant debug ACAD2006 in VB.NET

07-21-2005 09:36 AM in reply to: phreakie
I suspect that you have .NET 2.0 beta installed on your machine. AutoCAD
will detect the latest runtime (2.0 in this case) and use it. However, VS
2003 can't debug applications running on .NET 2.0.

You must use VS2005 Beta to debug applications running on .NET 2.0. (MS has
some betas available for free on their website). Alternatively, you can
force AutoCAD to use .NET 1.1 instead on the latest .NET framework installed
on the machine. Open acad.exe.config and follow the instructions there.

Albert

wrote in message news:4907773@discussion.autodesk.com...
Hello

I am trying to create a managed application for AutoCAD. I have ACAD 2006
and VB.NET 2003 and Object ARX 2006. I downloaded the Labs for VB.NET for
the .NET API and I can't get past Lab 2. I created a new project in VB.NET
2003 using the "AutoCAD Managed VB Project Application".

I followed exactly what they say in Lab 2. When I hit F5 to debug it, it
starts acad.exe and the aqua-colored splash screen for ACAD2006 rolls down
like it usually does. Then the splash screen seems to abruptly stop (it
disappears, acad.exe stops running) and Visual Studio stops debugging as
returns to its previous state. I don't get any error messages at all.

I have no problems with AutoCAD at all when I run it independently. Why is
this happening? I am new to .NET so please be kind. :smileyhappy:
Contributor
phreakie
Posts: 13
Registered: ‎02-27-2002
Message 3 of 3 (85 Views)

Re: Cant debug ACAD2006 in VB.NET

07-21-2005 09:57 AM in reply to: phreakie
Yes you are correct, I have the .NET Framework ver 2 installed, as well as VS2005 Beta. I prefer using .NET ver 1.1 (since everyone at my company already has it installed, but not ver. 2.0).

I made the change in acad.exe.config and it worked!! Thanks Albert!
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.