.NET

Reply
Active Contributor
46 Posts
0 Kudos
Registered: ‎06-18-2003
Post 11 of 21

Re: 2011 Type Libraries Breaks 2010

05-07-2010 12:52 PM in reply to: dhorger
Got it! I was trying to load the COM elements instead of the dll's directly. Loading the dll's worked! Thanks, Norman!
*Tony Tanzillo
Post 12 of 21

Re: 2011 Type Libraries Breaks 2010

05-07-2010 03:53 PM in reply to: dhorger
Where did you get the SDK for 2011?

The SDK on the download page is for AutoCAD 2011.

--
http://www.caddzone.com

AcadXTabs: MDI Document Tabs for AutoCAD
Supporting AutoCAD 2000 through 2011

http://www.acadxtabs.com

Email: string.Format("{0}@{1}.com", "tonyt", "caddzone");

wrote in message news:6387769@discussion.autodesk.com...
Thanks for all your help, Norman. I downloaded the SDK for 2010 and added the
acax18enu.tlb and axdb18enu.tlb , but they still point to the AutoCAD 2011
dll's. I'm giving up for now and uninstalling 2011 so I can get back to work.

Thank you everyone for your help!
Active Contributor
46 Posts
0 Kudos
Registered: ‎06-18-2003
Post 13 of 21

Re: 2011 Type Libraries Breaks 2010

05-07-2010 03:56 PM in reply to: dhorger
Here it is: http://usa.autodesk.com/adsk/servlet/item?siteID=123112&id=785550

You select which product to download for at the bottom of the page.
Valued Contributor
62 Posts
0 Kudos
Registered: ‎11-21-2006
Post 14 of 21

Re: 2011 Type Libraries Breaks 2010

07-26-2010 09:25 PM in reply to: norman.yuan

Thought I would add that I followed these directions with success.:smileyvery-happy:

Active Contributor
28 Posts
0 Kudos
Registered: ‎05-31-2007
Post 15 of 21

Re: 2011 Type Libraries Breaks 2010

08-24-2010 01:29 PM in reply to: norman.yuan

What happens when sheet sets get thrown into the mix? I've got AutoCAD 2010 and 2011 installed on the machine, and i've downloaded both the 2010 and 2011 SDK's. When I add a reference to "acsmcomponents18.tlb" in the 2010 SDK, it automatically adds a reference to Autodesk.AutoCAD.Interop.Common due to dependancies, however for some reason it insists on referencing the 2011 version "C:\Windows\assembly\GAC_MSIL\Autodesk.AutoCAD.Interop.Common\18.1.0.0...".  If i try to remove this reference and instead reference Autodesk.AutoCAD.Interop.Common from the 2010 SDK, I get compiler errors like this:

 

The project currently contains references to more than one version of Autodesk.AutoCAD.Interop.Common, a direct reference to version 18.0.0.0 and an indirect reference (through 'ACSMCOMPONENTS18Lib.IAcSmSheetSet.Sync') to version 18.1.0.0. Change the direct reference to use version 18.1.0.0 (or higher) of Autodesk.AutoCAD.Interop.Common.

 I'm hesitant that if i change the direct reference to the version in the 2011 SDK, the application will no longer run on AutoCAD 2011. Any ideas on how I could get this work on both 2010 and 2011 without compiling different versions (for both 32-bit and 64-bit!). Is this just some problem with the sheet set COM API?

 

Thanks,

 

-Chris

Valued Mentor
305 Posts
2 Kudos
Registered: ‎01-26-2005
Post 16 of 21

Re: 2011 Type Libraries Breaks 2010

08-24-2010 01:46 PM in reply to: chrisshoemaker4224

Did you try removing the reference to AXDBLib from your project?

 

I have a project that uses AcSmComponents18 and I was able

to remove the reference to AXDBLib and compile and run it

without errors.



AcadXTabs for AutoCAD
Supporting AutoCAD 2000-2011


Active Contributor
28 Posts
0 Kudos
Registered: ‎05-31-2007
Post 17 of 21

Re: 2011 Type Libraries Breaks 2010

08-24-2010 01:55 PM in reply to: caddzone

I would....unfortunately i'm making use of a method that requires a loaded AcadDatabase(ACSMCOMPONENTS18Lib.AcSmSheetSetClass.Sync(Autodesk.AutoCAD.Interop.Common.AcadDatabase) so even if i eliminated all other other code using ObectDBX i'd still need to keep the reference.

 

-Chris

Valued Mentor
372 Posts
13 Kudos
Registered: ‎01-20-2010
Post 18 of 21

Re: 2011 Type Libraries Breaks 2010

08-24-2010 02:57 PM in reply to: norman.yuan

It is supposed to be fixed with the update 1 for 2011

 

 

You can also find your answers @ TheSwamp
Active Contributor
28 Posts
0 Kudos
Registered: ‎05-31-2007
Post 19 of 21

Re: 2011 Type Libraries Breaks 2010

08-24-2010 02:59 PM in reply to: Jeffrey_H

What specifically is supposed to be fixed? I guess I still don't completely understand the problem....

 

Thanks everyone btw.

Valued Mentor
372 Posts
13 Kudos
Registered: ‎01-20-2010
Post 20 of 21

Re: 2011 Type Libraries Breaks 2010

08-24-2010 03:11 PM in reply to: chrisshoemaker4224

Quote from ADN

 

Unfortunately, the AutoCAD 2011 installer does not install the AutoCAD 2010 version (18.0.0.0) of the Autodesk.AutoCAD.Interop.dll. This has already been logged and is supposed to be remedied in the oncoming Update 1 for AutoCAD 2011.

 

 

You can also find your answers @ TheSwamp
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are you interested in helping shape the future of the Autodesk Community? To participate in this brief usability study, please click here. Your time and input is greatly appreciated!