Navisworks General Discussion

Navisworks General Discussion

Reply
Valued Mentor
Patrick_Aps_9121
Posts: 418
Registered: ‎02-19-2010
Message 1 of 15 (4,665 Views)
Accepted Solution

File Association

4665 Views, 14 Replies
02-03-2011 06:18 AM

So I've installed Simulate 2011, which includes Freedom 2011 on a brand new Win7 32-bits.

I want to have the following:

-> If I dubbleclick on an NWF file, I want Simualte to start and open the file

-> If I dubbleclick on an NWD file, I want Freedom to start and open the file.

 

Whatever I try to do (Select -> Shift +RightMouse menu -> Open With -> Brouwse to

C:\Program Files\Autodesk\Navisworks Freedom 2011\Roamer.exe)

 

Navisworks seems to be the only program I know which is not handling file association right..

 

Does anyone already have a solution,

possible a solution that can be included in my network deployment of Simulate ?

Because I do not want all people that have Simulate always using the network licences...

Product Support
lee.mullin
Posts: 479
Registered: ‎10-02-2007
Message 2 of 15 (4,643 Views)

Re: File Association

02-04-2011 02:09 AM in reply to: Patrick_Aps_9121

You'd need to change it on the Windows File Associations

 

Control Panel\All Control Panel Items\Default Programs\Set Associations

 

Select the NWD association and Browse to "C:\Program Files\Autodesk\Navisworks Freedom 2011\roamer.exe" (or wherever Freedom is installed) and this will set NWD's to be opened by Freedom by default.


Lee Mullin
Product Support Specialist
Global Services
Autodesk Ltd.


Valued Mentor
Patrick_Aps_9121
Posts: 418
Registered: ‎02-19-2010
Message 3 of 15 (4,640 Views)

Re: File Association

02-04-2011 02:37 AM in reply to: Patrick_Aps_9121

I sure hope it would help, but also there, there is no possibility to choose between a "Navisworks Freedom" and a "Navisworks Simulate": there is only a "Navisworks Autodesk LTD. Listed.

Brouwsing to the right C:\Program Files\Autodesk\Navisworks Freedom 2011\roamer.exe DOES NOT change a thing.

 

See the attachec JPG

 

Did you actually get it working?

Then it could have something to do with the fact that I'm using the Deployment Wizard to deploy Simulate 2011.

Product Support
lee.mullin
Posts: 479
Registered: ‎10-02-2007
Message 4 of 15 (4,635 Views)

Re: File Association

02-04-2011 05:26 AM in reply to: Patrick_Aps_9121

I have since tried it and it doesn't work, scouring a few other forums this seems to be a Windows 7 oddity.

 

Anyway you can change the value on the Registry Key

 

HKEY_CLASSES_ROOT\nwd\shell\open\command

 

to

 

C:\Program Files\Autodesk\Navisworks Freedom 2011\roamer.exe "%1" (or equivalent if Freedom is installed elsewhere)

 

And this should resolve the issue

 

WARNING: Modifying your registry can seriously damage your Windows installation if you make a mistake. This process is only advised as a last resort and you follow it at your own risk. Before undertaking any work on your registry, it is ALWAYS recommended to back up your registry first. If you are unsure, seek assistance from your system administrator. Autodesk cannot accept any responsibility for loss of data incurred whilst editing the Windows Registry.


Lee Mullin
Product Support Specialist
Global Services
Autodesk Ltd.


Valued Mentor
Patrick_Aps_9121
Posts: 418
Registered: ‎02-19-2010
Message 5 of 15 (4,627 Views)

Re: File Association

02-04-2011 05:44 AM in reply to: lee.mullin

Not quite a Windows 7 oddity,

because we already had this problem with Win XP computers and different versions of "roamer.exe"

If you have a Jetstream 5, an Review 2009 and a Simulate 2011 installed on the same Win XP machine, there was no normal way to select the file association.

 

Now I will be implementing a reg-import after the deployment.

Thanks for your support.

New Member
jdr1102
Posts: 1
Registered: ‎05-05-2011
Message 6 of 15 (4,277 Views)

Re: File Association

05-05-2011 03:25 PM in reply to: Patrick_Aps_9121

The registry change didn't work for me.  I am runing windows 7 (x64) and just will not allow me to pick "roamer.exe" and set it as a default.  Not in the control panel or properties.

 

Any other ideas?

Alumni
john.lipp
Posts: 359
Registered: ‎08-28-2009
Message 7 of 15 (4,260 Views)

Re: File Association

05-06-2011 10:05 AM in reply to: Patrick_Aps_9121

Hi jdr1102,


I believe the issue has to do with both applications using the roamer.exe file name. I’ve found a simple workaround:


1. Browse to the Freedom 2011 program folder:

 - C:\Program Files\Autodesk\Navisworks Freedom 2011

2. Right-click on “roamer.exe” and copy.   

3. Right-click and select paste in the folder.  You should now have a “roamer – Copy.exe” file located in the folder.  If you like you can rename it to whatever you want.

4. Right-click on an NWD file, and select Open with.

5. Click the Browse button and browse to the copy of the roamer.exe file you created that has a different file name and click ok.


In my testing, when you double click an NWD, it will open in Freedom.


Best regards,

autodesk_logo_signature.png

John Lipp
Product Support Specialist
Autodesk Product Support

Valued Mentor
Patrick_Aps_9121
Posts: 418
Registered: ‎02-19-2010
Message 8 of 15 (4,248 Views)

Re: File Association

05-08-2011 10:37 PM in reply to: john.lipp

So what you saying is, acutally, that development shoud rename

- roamer to Freedom.exe

- roamer to Simulate.exe

- roamer to Manage.exe

during the compilation of that version or

when they ship the corresponding product...

 

Contributor
greggbehmer
Posts: 22
Registered: ‎11-02-2009
Message 9 of 15 (4,089 Views)

Re: File Association

08-19-2011 05:42 PM in reply to: john.lipp

John,

 

I copied the roamer.exe file as you described and I am getting the correct association to Manage because the icons of my .nwf, .nwc, and .nwd files all have the Navisworks icon.  However, when I double click on that I get a Windows error "Navisworks has stopped working" and it won't open.  However, I can open NavisWorks and then open the file without a problem.  Any ideas?  I have windows vista ultimate on 64-bit OS.

Alumni
john.lipp
Posts: 359
Registered: ‎08-28-2009
Message 10 of 15 (4,078 Views)

Re: File Association

08-20-2011 06:46 PM in reply to: greggbehmer

Hi greggbehmer


I found that if you try to run a copy of roamer.exe from the 2012 versions, it fails to open.  I’m not seeing the error message you are seeing, but the process of the copy of roamer starts in the task manager and then quits without ever opening.

Here is an article on how to setup your “open with” list:

 - http://msdn.microsoft.com/en-us/library/bb166549(v=vs.80).aspx

Warning! Problems caused by improperly editing the Windows Registry could render your computer operating system unusable. Microsoft provides a wealth of critical information that you need to know about the registry in the Microsoft Knowledge Base.

 

Use the Microsoft Registry Editor only at your own risk and only after backing up the registry as well as the system.dat and user.dat files as outlined for your operating system in the Microsoft Knowledge Base and in the related Autodesk solution, http://usa.autodesk.com/getdoc/id=TS66513. Additional information about the registry is also contained in the Help topics in the Microsoft Registry Editor.



Using the information from the article above, I created some keys for the different versions of Navisworks under the key: HKEY_CLASSES_ROOT\Applications

1. Open Regedit

2. Browse to HKEY_CLASSES_ROOT\Applications


3. Right click it and select New > Key


4. Name the key “NAVMAN2012.exe”


5. Right click the newly created key, and select New > Key


6. Enter the key name “shell”


7. Right click the newly created key, and select New > Key


8. Enter the key name “open”


9. Right click the newly created key, and select New > Key


10. Enter the key name “command”


11. In the (Default) key of the command key, enter the following:

C:\Program Files\Autodesk\Navisworks Manage 2012\roamer.exe "%1"

Here is what it looks like in Regedit after creating keys for Freedom 2012 and Manage 2012:
sc1.png


You can repeat the above for the other versions of Navisworks. For example, use NAVFREE2012.exe in step 4, and the following path in step 10:

C:\Program Files\Autodesk\Navisworks Freedom 2012\roamer.exe "%1"



Or if you have a previous 2011 version of Simulate installed:

Use NAVSIM2011.exe in step 4, and the following path in step 10:

C:\Program Files\Autodesk\Navisworks Simulate 2011\roamer.exe "%1"




Now that the keys for the application versions are created, you can add an OpenWithList key to your .nwd, .nwf., .nwc extensions:

1. In Regedit, browse to the key HKEY_CLASSES_ROOT\.nwd


2. Right-click it and select New > Key


3. Name the key OpenWithList


4. Right-click the “OpenWithList” key and select New > Key


5. Enter the name NAVMAN2012.exe

6. Repeat steps 4 and 5 to add the other application versions that you created in the Applications key
sc2.png


You can repeat the above for the HKEY_CLASSES_ROOT\.nwc, and HKEY_CLASSES_ROOT\.nwf keys.

 

Now, when you right-click an NWD and select “Open with”, you’ll see the Manage and Freedom Icons.  If you want to set one to default when you double click a file, click the choose default program, select one from the Recommended Programs list, and with the “”Always use the select program” box marked, click OK.


Best regards,



John Lipp
Support Specialist
Product Support
Autodesk, Inc.

Announcements
Have API Questions?
New Dedicated Forum for Navisworks API

Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.