Navisworks API

Navisworks API

Reply
Active Member
potapczuk
Posts: 7
Registered: ‎05-02-2011
Message 1 of 7 (464 Views)

Error with reference for the Navis 2013 DLL

464 Views, 6 Replies
05-21-2012 12:39 PM

Hi,

 

I have a plugin already running with the Navis Manager 2012, now I need to migrate it to Navis 2013. So for this I changed my DLLs from my Navis 2012 installation to Navis 2013.

 

I alerady did this when migrating from 2011 to 2012, but with 2013 is not working, when I compile my project it loses the references to the DLLs, and I could not find out why.

 

DLLs referenced in project

C:\Program Files\Autodesk\Navisworks Manage 2013\Autodesk.Navisworks.Api.dll

C:\Program Files\Autodesk\Navisworks Manage 2013\Autodesk.Navisworks.ComApi.dll

C:\Program Files\Autodesk\Navisworks Manage 2013\Autodesk.Navisworks.Interop.ComApi.dll

 

Error

Error    1    The type or namespace name 'Autodesk' could not be found (are you missing a using directive or an assembly reference?)

 

Reference in code

using Autodesk.Navisworks.Api;

 

ADN Support Specialist
xiaodong.liang
Posts: 1,271
Registered: ‎06-12-2011
Message 2 of 7 (458 Views)

Re: Error with reference for the Navis 2013 DLL

05-21-2012 09:05 PM in reply to: potapczuk

I assume you have re-added the references from the path of Navisworks 2013. It is a bit hard to address. have you tried with the SDK samples? Or could you try to create a simplest project, with the steps of API help guide to see if it works?



Xiaodong Liang
Developer Technical Services
Autodesk Developer Network

Active Member
BBoretzky
Posts: 7
Registered: ‎09-02-2011
Message 3 of 7 (425 Views)

Re: Error with reference for the Navis 2013 DLL

07-06-2012 01:39 PM in reply to: potapczuk

I am having the same error, no matter where I try and add the references from it will not recognize them.

Contributor
zhangle
Posts: 19
Registered: ‎07-05-2009
Message 4 of 7 (422 Views)

Re: Error with reference for the Navis 2013 DLL

07-06-2012 01:43 PM in reply to: potapczuk

Are you sure the file address shown is the right one? In my default installation, it is 

C:\Program Files\Autodesk\Navisworks Manage 2013\api\net\bin\x86\Autodesk.Navisworks.Api.dll

Active Member
BBoretzky
Posts: 7
Registered: ‎09-02-2011
Message 5 of 7 (420 Views)

Re: Error with reference for the Navis 2013 DLL

07-06-2012 01:46 PM in reply to: zhangle

Yes, I add the reference from that location you described and the reference will add but will have the yellow exclamation point and will not build.  I can add 2012 dlls, no problem.  Also I tried to start a brand new project and tried to add this reference as well and still does the same thing.

Active Member
BBoretzky
Posts: 7
Registered: ‎09-02-2011
Message 6 of 7 (415 Views)

Re: Error with reference for the Navis 2013 DLL

07-06-2012 02:50 PM in reply to: potapczuk

More information, It seems that the references aren't showing up only in Visual Studio 2008, in 2010 they are adding fine.  Thanks.

ADN Support Specialist
xiaodong.liang
Posts: 1,271
Registered: ‎06-12-2011
Message 7 of 7 (374 Views)

Re: Error with reference for the Navis 2013 DLL

08-15-2012 11:59 PM in reply to: BBoretzky

Hi, 

 

I may not have got the whole picture of this question. It sounds like the issue that is related with the Runtime version. 2013 API dlls are v4.0.30319. While the toppest version of VS2008 is 3.5.



Xiaodong Liang
Developer Technical Services
Autodesk Developer Network

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.