MapGuide Enterprise Wishes

MapGuide Enterprise Wishes

Reply
*Giovanni
Message 1 of 4 (1,898 Views)

ip pubblic on mapguide

1898 Views, 3 Replies
07-23-2009 06:04 AM
Hello
I' have a problem

I have installed MapGuide 6.5 on server IIS and windos server 2003.
On my lan everything it's ok.
I don't have a hostname for my site web but only a pubblic ip, my router is
setting to resolve on my server with private IP

The problem is: the mapguide server not responding if i setting the url of
map server whitout hostname, but only with IP pubblic or IP private

tanks very much
Employee
dswilson
Posts: 730
Registered: ‎09-14-2006
Message 2 of 4 (1,898 Views)

Re: ip pubblic on mapguide

07-24-2009 04:17 PM in reply to: *Giovanni
This should probably be under the MapGuide thread as Wishes is for requesting future enhancements and this particular category is for MapGuide Enterprise.

I'm guessing your router/firewall is redirecting the ip address and the mapguide server is behind the firewall? If it is did you configure it to the private ip address? Can you access it internally using the private address?

Dave


Dave Wilson
SQA Analyst
AEC IM
Autodesk, Inc.

*Giovanni
Message 3 of 4 (1,898 Views)

Re: ip pubblic on mapguide

07-27-2009 06:09 AM in reply to: *Giovanni
The firewall redirect the request from internet to server where is mapguide
server,
and also if request come from intranet
of course if i configure mapguide server by private ip address
but i want work whitout host name, but it's no possible, because if i
configure mapguide server by pubblic ip address, mapguide server non work..

thanks
Giovanni



ha scritto nel messaggio news:6224805@discussion.autodesk.com...
This should probably be under the MapGuide thread as Wishes is for
requesting future enhancements and this particular category is for MapGuide
Enterprise.

I'm guessing your router/firewall is redirecting the ip address and the
mapguide server is behind the firewall? If it is did you configure it to the
private ip address? Can you access it internally using the private address?

Dave
Employee
dswilson
Posts: 730
Registered: ‎09-14-2006
Message 4 of 4 (1,898 Views)

Re: ip pubblic on mapguide

07-31-2009 03:03 PM in reply to: *Giovanni
I might be mistaken here, but in your mwf's when you are authoring the layers you have to specify the path to the mapagent. I think if you use the internal IP address for the URL then the internal access should work without the host name involved. When the external request comes in the public IP will get redirected to the internal IP at the firewall so it should resolve.

Give that a try and let me know if that works,
Regards,
Dave


Dave Wilson
SQA Analyst
AEC IM
Autodesk, Inc.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.