Inventor Publisher

Inventor Publisher

Reply
New Member
massluca
Posts: 1
Registered: ‎12-02-2011
Message 1 of 4 (380 Views)

Inventor Publisher 2012 Failed to load assembly

380 Views, 3 Replies
12-18-2011 12:54 PM

I have created a project in inventor 2012, now i won't make some  in publisher, but when i make insert and i select the .iam file publisher say me that the content center part not found but if i go in the directory the part is in it.

Sorry for my bad english but i'm italian.

Employee
kumarra
Posts: 52
Registered: ‎10-15-2008
Message 2 of 4 (371 Views)

Re: Inventor Publisher 2012 Failed to load assembly

12-19-2011 06:55 AM in reply to: massluca

Hi,

 

In the insert dialog when you select the assembly notice that you now have an "Options" button that becomes active. Select that and you will see a new dialog. In this dialog you will be able to browse to the Inventor ipj file. Once you do this and then insert publisher will resolve the assembly.

 

In the Publisher help file look under Import CAD data - Insert Inventor data - Insert Options - Project file. There is a video that will demo this. Hope this helps.

Thanks,
Rajkumar
Valued Contributor
ing.frison
Posts: 62
Registered: ‎09-16-2011
Message 3 of 4 (354 Views)

Re: Inventor Publisher 2012 Failed to load assembly

12-22-2011 03:08 AM in reply to: massluca

Dear Rajkumar,

 

I am experiencing exactly the same problem as Luca.

 

I followed of course the instructions you gave regarding the inv JPJ file, but nothis different happened.

 

My invPublisher is 2012 x64 SP2, and the "Content Center Files" path (which is perfectly working from inventor) is set to a network path of the type "\\SERVER-NAME\Dir1\Dir2\ccFiles" (Luca had them locally in his example).

 

Nevertheless I have tested the invPub Insert command also mapping the "\\SERVER-NAME\..." network path to a local drive like "J:\Dir1\Dir2\ccFiles" but still I get the same error message (failed to load assembly ... due to problem with child files -> File ... not found).

 

Any idea?

 

Thanks in advance,

Massimo

Massimo Frison
CAD R&D // IT Admin · AVA-Huep GmbH u. Co. KG · www.ava-huep.de
Valued Contributor
ing.frison
Posts: 62
Registered: ‎09-16-2011
Message 4 of 4 (348 Views)

Re: Inventor Publisher 2012 Failed to load assembly

12-22-2011 04:39 AM in reply to: ing.frison

...I did some more accurate investigation: it looks like invPub cannot handle assemblies generated with Inventor Professional (in my case piping assemblies):

 

One assembly with Content Center on the network was insterted by invPub correctly. The same assembly with one simple AIP piping run gives the following error when trying to be inserted in invPub:

 

Insert file failed.
    Unknown error.

More complicated AIP assemblies give the other error ("failed to load assembly ... due to problem with child files"). Of course all these assemblies are perfectly fine within Inventor.

Massimo Frison
CAD R&D // IT Admin · AVA-Huep GmbH u. Co. KG · www.ava-huep.de
Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.