Inventor Publisher

Inventor Publisher

Reply
Active Contributor
46 Posts
0 Kudos
Registered: ‎10-19-2010
Post 1 of 5

Failure to update components

302 Views, 4 Replies
11-14-2011 08:19 AM

I have just changed some components in an assembly. I tried to update a Publisher file which has the assembly in it. The update fails with a dialog "Update - Failed to open: <file.iam>".

 

Any ideas

 

I have Inventor 2012 sp2 and Publisher 2012 sp2.

 

I have a zip file of the files in question but it is too large to attach but could be emailed.

 

Regards

Victor Pringle

Active Contributor
46 Posts
0 Kudos
Registered: ‎10-19-2010
Post 2 of 5

Re: Failure to update components

11-19-2011 12:20 PM in reply to: VictorBDEngineer

This problem is preventing me from completing my project. Any help would be appreciated. I do not know how to get around it.

 

Regards

Victor

Active Contributor
40 Posts
5 Kudos
Registered: ‎03-29-2007
Post 3 of 5

Re: Failure to update components

02-29-2012 08:44 AM in reply to: VictorBDEngineer

I'm having a similar issue. I had to move some of my part files from one folder to another. I opened the assembly in Inventor to make sure all the files were found. I had no issues so I saved the file which should have saved the updated file paths. When I go into Publisher and select Update Components I get an error message that says "failed to load assembly due to the problem with child files." Then it lists all the part files that I moved and there previous locations. I would have thought that if I updated the file in Inventor, Publisher wouldn't have any issues. See attached image for the error message. Anyone got any ideas on how to fix this? I'm mid way thru a storyboard and I would hate to have to start over.

Employee
189 Posts
21 Kudos
Registered: ‎02-03-2012
Post 4 of 5

Re: Failure to update components

03-01-2012 10:54 AM in reply to: rich-s

Hi Rich -

 

I've had our team look into this, and we have been unable to reproduce the problem thus far. If you're willing to share your CAD data, and the IPB file you're working with I'd be more than happy to have our development team take a look at it to see where the issue is for you.

 

You can email me directly at timera.hart@autodesk.com.

 

Thanks,

 

Timera Hart

Autodesk

Active Contributor
40 Posts
5 Kudos
Registered: ‎03-29-2007
Post 5 of 5

Re: Failure to update components

03-01-2012 01:52 PM in reply to: TimeraAutodesk

Timera,

 

I was able to get everything working again but closing both Inventor & Publisher. I then opened assembly in Inventor and resaved the file again. I then opened my publication in Publisher and everything displayed correctly. I did not have to tell it to Check File Status.

 

Rich

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are you interested in helping shape the future of the Autodesk Community? To participate in this brief usability study, please click here. Your time and input is greatly appreciated!