Inventor General Discussion

Inventor General Discussion

Reply
Distinguished Contributor
146 Posts
14 Kudos
Registered: ‎12-16-2011
Post 1 of 14

Style library error

1999 Views, 13 Replies
01-24-2013 05:18 AM

I am not very Style Library manager savvy.  

 

I created one material, Aluminm 50-52, last year in IV 2012.  When we switched to 2013 later last year, I don't remember having any issues.

We just switched to a new server 2 weeks into this year, and I am getting this error:

The following style definitions in template P:\Autodesk\Templates\MANITOU IPT TEMPLATE 01032013.ipt differs from the definitions in the style library; the style library definitions will be used.

Color:Aluminum - Flat, Material:Aluminum-5052-H32

If the style definitions in the style library are intended for the new document, update the template with the new style definitions.  Id the style definitions in the template are intended for the new document, remove these stylres from your style library ising teh Style Library Manager." 

 

Yesterday, the error only had a color conflict, and said nothing about material.

 

Our design libraries are on the new server, this error pops up on both CAD machines.

 

I tried saving & purging the styles yesterday, via the Manage tab in IV.  i am still getting the error. What do I do next?

Mentor
151 Posts
17 Kudos
Registered: ‎09-10-2012
Post 2 of 14

Re: Style library error

01-24-2013 07:55 AM in reply to: eveylynne

The basics of it is there are local styles (saved in documents or templates) and styles in your style library (a global set of styles saved in a set of documents on your C drive, most likely C:\Users\Public\Documents\Autodesk\Inventor 2011\Design Data)

 

Try opening your template file.  If you right click on the colour Aluminum - Flat, Material:Aluminum-5052-H32 within the Styles & Standards editor and click 'Update Style'.  Now save the changes to your template file and there should no longer be a conflict.

 

I hope that helps

Wayne Helley
Inventor 2013 Certified Professional

Autodesk Inventor Professional 2013
Windows 7 Enterprise, 64-bit
Mentor
151 Posts
17 Kudos
Registered: ‎09-10-2012
Post 3 of 14

Re: Style library error

01-24-2013 08:00 AM in reply to: waynehelley

Also just to clarify...

 

when you 'save' styles, you are overwritting the styles in your style library with styles from your currently open document.

 

when you 'update' styles your are overwritting styles in your currently open document with syles saved in your style library.

 

when you 'purge' styles, you are deleting unused styles from your currently open document, but these styles may still exist in your style library

Wayne Helley
Inventor 2013 Certified Professional

Autodesk Inventor Professional 2013
Windows 7 Enterprise, 64-bit
Distinguished Contributor
146 Posts
14 Kudos
Registered: ‎12-16-2011
Post 4 of 14

Re: Style library error

01-24-2013 10:05 AM in reply to: waynehelley

Only "lighting" is showing up under the Style & Standard Editor.  There's an option to Import, toward the bottom of the menu, asking for .styxml file extension. 
I know the location of the design data on the server, but that file extension doesn't exist there.  I havnen't found that extension anywhere.
What am I missing?

*Pro
1,997 Posts
285 Kudos
Registered: ‎09-15-2003
Post 5 of 14

Re: Style library error

01-24-2013 04:32 PM in reply to: eveylynne

You're missing the fact that Inventor 2013 took the Materials and Colo(u)rs out of the Styles library and put them in Material and Appearance libraries.  These have the file exension .adsklib, and reside in several places.  The Inventor libraries are located in the Design Data\Materials folder.  The Autodesk libraries are located in \Program Files (x86)\Common Files\Autodesk Shared\Materials\2013\.  You can create your own and put them wherever you like.

 

Hope that gets you pointed in the right direction.

Sam B
Inventor 2012 Certified Professional

Please click "Accept as Solution" if this response answers your question.
-------------------------------------------------------------------------------------
Inventor Professional 2013 SP1.1 Update 1
Windows XP Pro 32-bit, SP3
HP EliteBook 8730w; 4 GB RAM; Core™ 2 Duo T9400 2.53 GHz; Quadro FX2700M
SpaceExplorer/SpaceNavigator NB, driver 3.7.18
still waiting for a foreshortened radius dimensioning tool in Drawing Manager

Distinguished Contributor
146 Posts
14 Kudos
Registered: ‎12-16-2011
Post 6 of 14

Re: Style library error

01-25-2013 05:52 AM in reply to: sbixler

I'm still stuck.  My design data file path is (Everything should be on the server, nothing local.):

 

P:\Autodesk\Test Migrate Design Data

If I try to import an .adsklib extension into the Style and Standard Editor, I get the error, "Cannot open xml file:\\SBS2011\UserShares\Parts\Autodesk\Test Migrate Design Data\Materials\InventorMaterialLibrary.adsklib"


I've attached a screen shot of my Editor, just to show that I only have access to lighting.  My project's file paths for librarys point at .adsklib files.

*Pro
1,997 Posts
285 Kudos
Registered: ‎09-15-2003
Post 7 of 14

Re: Style library error

01-25-2013 07:16 AM in reply to: eveylynne

Read my reply again-- the Materials and Colors were removed from the Styles.  You can't edit them or do anything with them in the Style Editor.  You have to use the Material browser and the Appearance browser to edit.  The fun part is that the user interface has been completely reinvented from scratch, even though we're all used to the other one.  It is not intuitive at all.

 

However, the fundamentals are still the same-- editing happens in a file, then is saved to a library.  Materials and Appearances selected from a library are copied into the file.  You can still use the Save Styles, Update Styles and Purge Styles tools to work with Materials and Appearances, though you need to specify which M&A library you're working with

Sam B
Inventor 2012 Certified Professional

Please click "Accept as Solution" if this response answers your question.
-------------------------------------------------------------------------------------
Inventor Professional 2013 SP1.1 Update 1
Windows XP Pro 32-bit, SP3
HP EliteBook 8730w; 4 GB RAM; Core™ 2 Duo T9400 2.53 GHz; Quadro FX2700M
SpaceExplorer/SpaceNavigator NB, driver 3.7.18
still waiting for a foreshortened radius dimensioning tool in Drawing Manager.

Distinguished Contributor
146 Posts
14 Kudos
Registered: ‎12-16-2011
Post 8 of 14

Re: Style library error

01-25-2013 08:23 AM in reply to: sbixler

I did read and reread your response.
I don't understand the material interface goodness (,2012 or 2013).  I am getting an error that tells me to "remove these styles from your style library ising the Style Library Manager," which I took to be the Styles Editor under the Manage tab.

 

I see the Appearance Browser, the Material Browser, & the Material Editor.   I don't see Save Styles, Update Styles, or Purge Styles tools.  I don't understand why I am getting the error I am getting, or how to fix it, or why a new server triggered it.  I have a grand total of one custom material, but I need all CAD pc's to use it.

I'm afraid I am still confused.

*Pro
1,997 Posts
285 Kudos
Registered: ‎09-15-2003
Post 9 of 14

Re: Style library error

01-25-2013 09:55 AM in reply to: eveylynne

Well, I'll have another try.

 

The Save Styles, Update Styles and Purge Styles tools are the ones you're used to from previous versions on the Manage tab.  They now work with the M&A libraries, too.  Just be sure that you have selected the correct M&A library.

 

The error you're receiving indicates that your template and the M&A library material & appearance don't match, and you say that you've got a new server.  Is the path to the Design Data folder on the server the same as it was with the old server?  Do you have a custom M&A library from when you transitioned from 2012 to 2013?

Sam B
Inventor 2012 Certified Professional

Please click "Accept as Solution" if this response answers your question.
-------------------------------------------------------------------------------------
Inventor Professional 2013 SP1.1 Update 1
Windows XP Pro 32-bit, SP3
HP EliteBook 8730w; 4 GB RAM; Core™ 2 Duo T9400 2.53 GHz; Quadro FX2700M
SpaceExplorer/SpaceNavigator NB, driver 3.7.18
still waiting for a foreshortened radius dimensioning tool in Drawing Manager

Contributor
23 Posts
0 Kudos
Registered: ‎06-04-2012
Post 10 of 14

Re: Style library error

01-30-2013 07:56 AM in reply to: eveylynne

I am having the same problem, however I've never made any custom material styles or anything.  This is very frustrating.

Inventor 2013
Windows XP
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are you interested in helping shape the future of the Autodesk Community? To participate in this brief usability study, please click here. Your time and input is greatly appreciated!