Inventor General Discussion

Inventor General Discussion

Reply
Active Contributor
drspringer
Posts: 37
Registered: ‎06-09-2009
Message 1 of 12 (949 Views)

Stop Undo file size message.

949 Views, 11 Replies
11-05-2012 08:24 PM

I am trying to render animations and I am still getting the "Undo file size exceeded" message in the middle of my animation. I have tried every option I could find to get it to stop but it keeps happening. Some of the animations take over an hour and I don't want to sit in front of the computer waiting to click ok to increase the file size.

 

I've maxed out the size in the settings at 4096K but it still gives me the message at 2048 and 3072.

 

Any suggestions?

Valued Contributor
Daniel248
Posts: 51
Registered: ‎04-15-2011
Message 2 of 12 (901 Views)

Re: Stop Undo file size message.

11-08-2012 07:26 AM in reply to: drspringer

Well? Nobody knows? I would like to see someone from Autodesk answering this, too

Active Contributor
drspringer
Posts: 37
Registered: ‎06-09-2009
Message 3 of 12 (892 Views)

Re: Stop Undo file size message.

11-08-2012 07:51 AM in reply to: drspringer

It seems to me that during an animation sequence, the undo command is really unnecessary. Maybe if there was a way to turn it off during the animation process, that would solve the problem.

 

For now, when I have a large animation to do (7-8 seconds @ 16 fps) I exit the file, re-open it and go into the animation environment and render the section I need. Then repeat the process. It can take up to ten minutes waiting for Inventor to dump the memory and exit the model after a long animation. Very tedious.

Valued Contributor
Daniel248
Posts: 51
Registered: ‎04-15-2011
Message 4 of 12 (873 Views)

Re: Stop Undo file size message.

11-09-2012 03:39 AM in reply to: drspringer

My 'small' animation is nearly 3 minutes @ 25 fps, produced as a still frame sequence, with Preview only (no render).

I've disabled the Undo file size message, as there is absolutely no point in Inventor stopping to ask for permission to increase the undo file size - in fact, there shouldn't be any undo when rendering - what is there to undo? Still, the message pops up and animation stops. I think I may just have to spend some time and write a little script using WMI (or similar) to detect and dismiss this annoying popup blighter. 

Active Member
Wayne_O
Posts: 6
Registered: ‎08-02-2006
Message 5 of 12 (822 Views)

Re: Stop Undo file size message.

12-03-2012 09:29 AM in reply to: Daniel248

I would really love it if someone could tell me how to solve this problem. I did an animation last year of our new product that our sales dept. loves and now they want me to make some changes. It's now 67 sec long and takes more then 5 hrs to run at 15 fps. I wouldn't mind if I could turn it on at the end of the day but having to baby-sit the thing for that kind of time is a waste of time. I tried disabling the prompt but it still comes up 3 time in that 5 hrs. I was told that Showcase also does animations but I don't have the time to invest in learning another software right now.

Active Contributor
drspringer
Posts: 37
Registered: ‎06-09-2009
Message 6 of 12 (815 Views)

Re: Stop Undo file size message.

12-03-2012 09:49 AM in reply to: drspringer

I still haven't found a consistent way do it it in either 11 or 12 but it seems to have stopped in 2013. I did a bunch of animations last week without the usual "run two animations, exit, restart and run some more" pattern and I never got the undo message. None of them were over 9 seconds but that didn't stop that message in previous versions. And it seems to handle the memory better without as much bogging down.

 

Can you break up the animation and splice it together later? My animations are set up that way for a customer that makes presentations. I don't know what they use but there are free video splicing programs on the web. I havent used them but it might be worth a look.

Active Member
Wayne_O
Posts: 6
Registered: ‎08-02-2006
Message 7 of 12 (811 Views)

Re: Stop Undo file size message.

12-03-2012 10:08 AM in reply to: drspringer

The original animation was done in IV2012 but I'm now using 2013 and am still running into the prompt. I think I'll look into making it in sections as you suggested. They love my animation but don't want me to spent much time on it so I'm not sure how far I'll get. I would also like to narrate over it if possible. Animating is a great tool for me to make my argument for new product or concepts. It seems to help broaden the imagination.

 

Thanks

*Pro
jletcher
Posts: 1,946
Registered: ‎05-18-2011
Message 8 of 12 (791 Views)

Re: Stop Undo file size message.

12-03-2012 12:22 PM in reply to: drspringer

Try this on your C drive make a folder called Inventor Undo then go into Inventor Application Options under the file tab you will see the undo mapping change it to your new location....

 

After I did this I never had a problem with the undo file.

 

So now when ever I set up Inventor for clients this is the 1st thing I do.


Please mark this response as "Accept as Solution" if it answers your question.

James Letcher
2012 Factory Design Suite ( will not load 2013)
What happen to my Inventor :-(
Active Member
Wayne_O
Posts: 6
Registered: ‎08-02-2006
Message 9 of 12 (755 Views)

Re: Stop Undo file size message.

12-05-2012 08:14 AM in reply to: drspringer

Thank you for the input, unfortunately it didn't work for me. I tried two time, the second time I placed the undo file at the top level of my C drive and still got the interruption. I did however have some success by maximizing the undo file size in my options. The only reason I didn't try that earlier is that in IV2011 or 12 when I tried that my software once shut down would not start up again. I had to go into the registry and change the value from there. Not something I like doing. I think I'll do as drspringer suggested and find a video editor to clip and paste and keep the animations smaller. Thank again for your input.

Active Member
Wayne_O
Posts: 6
Registered: ‎08-02-2006
Message 10 of 12 (748 Views)

Re: Stop Undo file size message.

12-05-2012 08:22 AM in reply to: Wayne_O

I just noticed that in the original post by drspringer he said that he was still getting the message after maxing out his file size so maybe by doing what you had suggested allowed me to get the maximum file size without the interruption.

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.