Inventor General Discussion

Inventor General Discussion

Reply
Active Contributor
drspringer
Posts: 38
Registered: ‎06-09-2009
Message 1 of 4 (433 Views)
Accepted Solution

Step translation issues

433 Views, 3 Replies
10-15-2012 08:44 AM

I am trying to export step files from Inventor 2012 into Surfcam. Any files that were created in Inventor translate over as solids. Files that I have imported from step files, recognized features, modified and exported again come into Surfcam as Nurb surfaces. I also tried using Inventor 2013 with the same results.

 

I've never experienced this problem with earlier versions of Inventor. Is there something I'm doing wrong?

 

I have attached one of the files that is giving me trouble.

Call off the dogs, as I expected, it was a surfcam user issue. No matter how many times I asked if the files were being imported correctly I was told it was my problem. Sure enough, I got a call this morning from my customer, he found a checkbox on the import page to import solids. (Insert forehead slap here!)

 

Thanks for looking, sorry for the trouble.

*Expert Elite*
JDMather
Posts: 28,246
Registered: ‎04-20-2006
Message 2 of 4 (413 Views)

Re: Step translation issues

10-15-2012 11:34 AM in reply to: drspringer

drspringer wrote:

... Any files that were created in Inventor translate over as solids.

... Files that I have imported .....exported again come into Surfcam as Nurb surfaces


 

Just to make sure -

Your problem is you want the exported files to open in Surfcam as solids?
Are you running Quality Check on the initial import before running Feature Recognition (I never accept the prompt to run FR, I always open the file first and then run FR)?
What Options are you setting on the export?

 

Edit: I see from the Translation Report that you are running Quality Check.  When  do you run FR. 

Can you attach the original STEP file for this part here?

 

What happens if you Suppress the Thread feature before export (it won't be translated anyhow)?

Please mark this response as "Accept as Solution" if it answers your question.
-----------------------------------------------------------------------------------------
Autodesk Inventor 2015 Certified Professional
Autodesk AutoCAD 2013 Certified Professional
Certified SolidWorks Professional
Inventor Professional 2015-SP1 64-bit
http://www.autodesk.com/edcommunity
http://home.pct.edu/~jmather/content/DSG322/inventor_surface_tutorials.htm
Active Contributor
drspringer
Posts: 38
Registered: ‎06-09-2009
Message 3 of 4 (390 Views)

Re: Step translation issues

10-15-2012 02:28 PM in reply to: JDMather

That is the problem, yes.

 

I do the feature fecognition the same way. Import first and then FR.

 

I tried supressing the thread feature but it made no difference. I also tried every option (all three) for the step translation with the same results.

 

The original step file is attached. It is the simplest of the files that I am trying to translate.

 

 

Active Contributor
drspringer
Posts: 38
Registered: ‎06-09-2009
Message 4 of 4 (348 Views)

Re: Step translation issues

10-22-2012 12:54 PM in reply to: drspringer

Call off the dogs, as I expected, it was a surfcam user issue. No matter how many times I asked if the files were being imported correctly I was told it was my problem. Sure enough, I got a call this morning from my customer, he found a checkbox on the import page to import solids. (Insert forehead slap here!)

 

Thanks for looking, sorry for the trouble.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.