Inventor General Discussion

Inventor General Discussion

Reply
Contributor
18 Posts
2 Kudos
Registered: ‎06-04-2009
Post 1 of 4

Shared sketch visibility problems

314 Views, 3 Replies
08-29-2011 01:20 PM

Has anyone else noticed this problem?  Say you are in an assembly.  One or several parts in the assembly contain a shared sketch (visibility is turned off).  Turn off the visibilty of the part in the assembly.  Now turn the visibility of the part back on, and the shared sketches visiblity has been turned on.  This seems to be a bug.

*Expert Elite*
1,097 Posts
267 Kudos
Registered: ‎09-03-2008
Post 2 of 4

Re: Shared sketch visibility problems

08-29-2011 04:29 PM in reply to: tims79

Check the visibility state of the sketches in the part files.  To do this, open one of the parts in its own window.  Don't just double-click the part in the assembly, because this will just open the part within the context of the assembly.  Instead, right-click the part and select Open, or use the Open command and browse to the part.

 

If the sketches are visible in the part file itself, then you will see the behavior you have described.  To keep the sketches invisible even when you toggle the visibility of the part in the assembly, you need to make sure the sketches are invisible in the part file.  So, turn off the sketch visibility and save the part.  This behavior is the same for work features as well (work planes, axes, and points).

 

Try this and post back with your results.

 

-cwhetten

Contributor
18 Posts
2 Kudos
Registered: ‎06-04-2009
Post 3 of 4

Re: Shared sketch visibility problems

09-01-2011 04:00 AM in reply to: cwhetten

Ok, I see how it works now.

Employee
11 Posts
0 Kudos
Registered: ‎05-23-2011
Post 4 of 4

Re: Shared sketch visibility problems

09-05-2011 01:49 AM in reply to: tims79

An additional message, it may help control visibility.

View tab-->Object visibility drop-down menu. You can check/un-check the object to control the visibility without change components. For example, if you did not want to see the sketch, you can uncheck the 2d/3d sketches, and then they are all invisible.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post