Inventor General Discussion

Inventor General Discussion

Reply
Distinguished Mentor
swhite
Posts: 531
Registered: ‎11-08-2012
Message 11 of 21 (344 Views)

Re: Shaded with edges (not hidden)

05-01-2013 08:42 AM in reply to: JamieVJohnson2

I am using a NVIDIA card (Quadro 600) but only get that bleed thru effect when I have some of my parts set to transparency, such as expanded metal. My settings are set for performance, and even so the jaggies aint that bad.

Bleed thru.PNG

Steven White
Lee C. Moore, Inc.
www.lcm-wci.com
Inventor 2011
Intel Dual Xeon E31225 @ 3.1 GHz CPU
16 GB RAM
NVIDIA Quadro 600 GPU
Windows 7 - 64 Bit
Mentor
JamieVJohnson2
Posts: 167
Registered: ‎08-26-2010
Message 12 of 21 (342 Views)

Re: Shaded with edges (not hidden)

05-01-2013 08:59 AM in reply to: sam_m

new graphics system...I'm sure of it.  Didn't have any of these problems in 2011, 12, or 13.

 

Multi-core graphics...  When I opened these files they barely bled into another core (4 core i7) ran as much as 30percent (1 core plus 1/5 of a second core).  When zooming in and out there was a threshold that would cause this effect, but that threshold was not absolute, it would change a little (one middle button roll click in or out would cause the shadows to appear or disappear).  During scroll wheel zooming, the CPU level would stay down around 15% never using second core when turning on shadows.

 

intelligent drawing order... likely the biggest culprit.  The order is placing shadows before surface occlusion, during certain levels of zoom detail.  Not too intelligent, shadows are expensive processing, unless all shadows are processed only once (old ACAD 3D engine process where ray tracing is calculated once and reused regardless of angle, and stored as a data file).  If shadows are processed that way, then they could be reused faster, accept they forgot to call down the occlusion feature to weed out which shadows are shown at certain zoomed in detail levels. I'm assuming shadows were calculated at several sizes.  Zoomed way out (little shadow calcs), zoom way in (detailed shadow calcs), are the obvious levels.  This would explain why the issue is predominant when zoomed in. It is possible that the second level is the only one with the error.

 

This is causing all shadows to be displayed at the close detail levels making it difficult to understand the outer surfaces.  Since I am accustomed to working in old 3D wireframe, I can survive, but I'm sure I'm the only one of my staff that can.

jvj
Mentor
JamieVJohnson2
Posts: 167
Registered: ‎08-26-2010
Message 13 of 21 (341 Views)

Re: Shaded with edges (not hidden)

05-01-2013 09:00 AM in reply to: swhite
Your image is not using ambient shadows. so you don't have the problem at all, here.
jvj
Distinguished Mentor
swhite
Posts: 531
Registered: ‎11-08-2012
Message 14 of 21 (335 Views)

Re: Shaded with edges (not hidden)

05-01-2013 09:25 AM in reply to: JamieVJohnson2

With Ambient Shadows.

 

Steven White
Lee C. Moore, Inc.
www.lcm-wci.com
Inventor 2011
Intel Dual Xeon E31225 @ 3.1 GHz CPU
16 GB RAM
NVIDIA Quadro 600 GPU
Windows 7 - 64 Bit
Mentor
JamieVJohnson2
Posts: 167
Registered: ‎08-26-2010
Message 15 of 21 (327 Views)

Re: Shaded with edges (not hidden)

05-01-2013 09:45 AM in reply to: swhite
Being transparent parts, I'd expect the view I see.

Question, if you zoom way in to a detailed part say a bolt, do ambient shadows display through NON transparent parts?
jvj
Distinguished Mentor
swhite
Posts: 531
Registered: ‎11-08-2012
Message 16 of 21 (318 Views)

Re: Shaded with edges (not hidden)

05-01-2013 10:51 AM in reply to: JamieVJohnson2

Actually when i zoom in everything displays correctly.

Steven White
Lee C. Moore, Inc.
www.lcm-wci.com
Inventor 2011
Intel Dual Xeon E31225 @ 3.1 GHz CPU
16 GB RAM
NVIDIA Quadro 600 GPU
Windows 7 - 64 Bit
Mentor
JamieVJohnson2
Posts: 167
Registered: ‎08-26-2010
Message 17 of 21 (298 Views)

Re: Shaded with edges (not hidden)

05-09-2013 09:26 AM in reply to: swhite

Unfortunately update 1 does not address this issue.  Nor did it address the issue of the scrambling display.  I'd think that the graphics performance of the program is way more important than the small bugs they fixed.

jvj
Mentor
JamieVJohnson2
Posts: 167
Registered: ‎08-26-2010
Message 18 of 21 (297 Views)

Re: Shaded with edges (not hidden)

05-09-2013 09:32 AM in reply to: JamieVJohnson2

BTW it doesn't matter if I'm using quality, performance, or compatibility mode.

jvj
Mentor
JamieVJohnson2
Posts: 167
Registered: ‎08-26-2010
Message 19 of 21 (258 Views)

Re: Shaded with edges (not hidden)

05-28-2013 03:32 PM in reply to: JamieVJohnson2

Fair warning, if you get this type display, first thing you should do is save any unsaved work in Inventor.  Just pressing the windows restore down button can potentially crash Inventor at this point.

jvj
Mentor
JamieVJohnson2
Posts: 167
Registered: ‎08-26-2010
Message 20 of 21 (231 Views)

Re: Shaded with edges (not hidden)

06-06-2013 04:15 PM in reply to: JamieVJohnson2

For the scrambled screen issue, remove these registry keys:

 

[HKEY_CURRENT_USER\Software\Autodesk\Inventor\RegistryVersion18.0\System\Preferences\Display]

"OGSSupport"=dword:00000002
"OGSMultiSampLevel"=dword:00000002
"OGSFallbackLevel"=dword:00000000

 

Thou has slain the Jabberwocky... Well at least one of them.

 

Later,

jvj
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.