Inventor General Discussion

Inventor General Discussion

Reply
Contributor
lriemer
Posts: 12
Registered: ‎12-09-2013
Message 1 of 10 (357 Views)

Select Sketch Features not working consistently

357 Views, 9 Replies
12-18-2013 07:49 AM
Hello, I am having an issue with the "select sketch features" selection filter. Specifically, it does not seem to work within the edit-in-place environment. If I am sketching on a part that has been opened discretely, selection functions normally. However, if I am editing within an assembly and I attempt to work in a sketch, face selection takes priority over selecting dimensions or sketch features despite the sketch features filter being active. I have not always had this problem, and it began approximately a month ago. I can't think of anything I might have changed to cause this, but I'm wondering if there's an option somewhere that I accidentally toggled. Any ideas on what could be causing this?
Inventor 2015 SP1
Windows 7
Product Support
innovatenate
Posts: 1,112
Registered: ‎11-22-2011
Message 2 of 10 (330 Views)

Re: Select Sketch Features not working consistently

12-19-2013 10:34 AM in reply to: lriemer

Do you have service pack 1 for Inventor 2014 installed?

 

http://usa.autodesk.com/adsk/servlet/ps/dl/item?siteID=123112&id=22322619&linkID=9242019

 

Also, do you have Update 1 for Inventor 2014 installed?

http://usa.autodesk.com/adsk/servlet/ps/dl/item?siteID=123112&id=22436654&linkID=9242019

 

I tried to replicate the workflow:

1. Edit a part located in an assembly

2. Edit a sketch in the part (I note that the selection filter automatically updates to "select sketch features")

3. Next, I select and modify sketch figures and dimension in the sketch. 

 

I am having a hard time replicating any problems with face selection as you mentioned. Perhaps you could post a screenshot or a video of the difficulties?

 

Thanks,

 

 



Nathan Chandler


Contributor
lriemer
Posts: 12
Registered: ‎12-09-2013
Message 3 of 10 (314 Views)

Re: Select Sketch Features not working consistently

12-23-2013 08:28 AM in reply to: innovatenate
I have SP1 installed, but I don't believe Update 1 has been applied. I will try applying that update. The problem has been intermittent. The filter will function fine for a while, then will suddenly stop working. This generally continues until inventor is restarted. I attempted to screenshot this, but the cursor did not show up in the screenshot so it wasn't particularly useful. I will look into capturing this on video.
Inventor 2015 SP1
Windows 7
Member
g.v.rooy
Posts: 3
Registered: ‎03-09-2004
Message 4 of 10 (252 Views)

Re: Select Sketch Features not working consistently

01-30-2014 02:03 AM in reply to: lriemer

Same problem over here.

 

Servicepack 1 and update 1+2 are installed.

 

Someone another solution ?

*Expert Elite*
JDMather
Posts: 28,228
Registered: ‎04-20-2006
Message 5 of 10 (245 Views)

Re: Select Sketch Features not working consistently

01-30-2014 03:28 AM in reply to: g.v.rooy

Can you assembly here that exhibits this behavior.

Please mark this response as "Accept as Solution" if it answers your question.
-----------------------------------------------------------------------------------------
Autodesk Inventor 2015 Certified Professional
Autodesk AutoCAD 2013 Certified Professional
Certified SolidWorks Professional
Inventor Professional 2015-SP1 64-bit
http://www.autodesk.com/edcommunity
http://home.pct.edu/~jmather/content/DSG322/inventor_surface_tutorials.htm
Member
g.v.rooy
Posts: 3
Registered: ‎03-09-2004
Message 6 of 10 (238 Views)

Re: Select Sketch Features not working consistently

01-30-2014 04:25 AM in reply to: lriemer

Hello,

 

Is doesn't matter which assembly it occurs when editing a part in an assembly.

When I open the part, instead of editing in an assembly, then I can select the dimensions.

*Expert Elite*
JDMather
Posts: 28,228
Registered: ‎04-20-2006
Message 7 of 10 (231 Views)

Re: Select Sketch Features not working consistently

01-30-2014 05:53 AM in reply to: g.v.rooy

Can you attach an assembly here that exhibits this behavior on your machine and include screen captures that illustrate the problem so that others can try to reproduce exactly the same steps?

Please mark this response as "Accept as Solution" if it answers your question.
-----------------------------------------------------------------------------------------
Autodesk Inventor 2015 Certified Professional
Autodesk AutoCAD 2013 Certified Professional
Certified SolidWorks Professional
Inventor Professional 2015-SP1 64-bit
http://www.autodesk.com/edcommunity
http://home.pct.edu/~jmather/content/DSG322/inventor_surface_tutorials.htm
Contributor
lriemer
Posts: 12
Registered: ‎12-09-2013
Message 8 of 10 (227 Views)

Re: Select Sketch Features not working consistently

01-30-2014 06:35 AM in reply to: JDMather
I have had trouble replicating the issue even on an assembly and part where it has previously happened. It has been occurring much less the past few weeks despite the fact that I have done nothing to fix it, so I'm having difficulty working out what might be triggering it. I have some video capture software installed now, so I will attempt to record it if I am able next time it occurs.
Inventor 2015 SP1
Windows 7
*Expert Elite*
JDMather
Posts: 28,228
Registered: ‎04-20-2006
Message 9 of 10 (222 Views)

Re: Select Sketch Features not working consistently

01-30-2014 07:11 AM in reply to: lriemer

lriemer wrote:
 I have some video capture software installed now, so I will attempt to record it if I am able next time it occurs.

This one?

https://chronicle.autodesk.com/

Please mark this response as "Accept as Solution" if it answers your question.
-----------------------------------------------------------------------------------------
Autodesk Inventor 2015 Certified Professional
Autodesk AutoCAD 2013 Certified Professional
Certified SolidWorks Professional
Inventor Professional 2015-SP1 64-bit
http://www.autodesk.com/edcommunity
http://home.pct.edu/~jmather/content/DSG322/inventor_surface_tutorials.htm
Contributor
lriemer
Posts: 12
Registered: ‎12-09-2013
Message 10 of 10 (218 Views)

Re: Select Sketch Features not working consistently

01-30-2014 07:14 AM in reply to: JDMather
No, but that looks like a much better option. I'll get that set up.
Inventor 2015 SP1
Windows 7
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.