Inventor General Discussion

Inventor General Discussion

Reply
Active Contributor
nickhowe
Posts: 36
Registered: ‎02-28-2012
Message 1 of 12 (941 Views)
Accepted Solution

"Fixed" placed components with one constraint

941 Views, 11 Replies
07-05-2012 03:48 AM

Why can I not constrain placed objects with three constraints? Anything I place constrains with one constraint then is virtually fixed (without being) and cannot even be moved to allow for further constraining.

 

Any ideas?

 

Thanks

 

Nick

Thanks Stephen

 

It looks that way! No reasons for why it doesn't move manually?

 

Cheers

 

Nick

Active Contributor
nickhowe
Posts: 36
Registered: ‎02-28-2012
Message 2 of 12 (936 Views)

Re: "Fixed" placed components with one constraint

07-05-2012 03:54 AM in reply to: nickhowe

....in addition, this only applies to one assembly alone. Is this a setting for this assembly or is it cpossibly corrupted?

*Expert Elite*
mcgyvr
Posts: 6,944
Registered: ‎12-01-2004
Message 3 of 12 (929 Views)

Re: "Fixed" placed components with one constraint

07-05-2012 05:53 AM in reply to: nickhowe

any grounded parts?

any imported parts?

Did you find this reply helpful ? If so please use the Accept as Solution or Kudos button below.

-------------------------------------------------------------------------------------
2015 Product Design Suite Ultimate
Windows 7 64 bit
Core i7 4820k processor (OC'd to 4.4Ghz), Nvidia GTX 770, 16G RAM


Valued Mentor
stephengibson76
Posts: 1,101
Registered: ‎08-01-2006
Message 4 of 12 (924 Views)

Re: "Fixed" placed components with one constraint

07-05-2012 06:15 AM in reply to: nickhowe

does it move if you put another constraint on it, sometimes you cant drag components.  Also try view, degrees of freedom

Stephen Gibson



View stephen gibson's profile on LinkedIn


Active Contributor
nickhowe
Posts: 36
Registered: ‎02-28-2012
Message 5 of 12 (921 Views)

Re: "Fixed" placed components with one constraint

07-05-2012 06:28 AM in reply to: mcgyvr

No grounded parts or imprts just a placed assembly that "grounds" on the first constraint.

 

..........................................

 

Since then I have found that i can still add constraints. I can't physically move it after the first constraint but can move it via the addition of other constraints!

 

Thanks for the help, think i'll just file this under weird!

Active Contributor
nickhowe
Posts: 36
Registered: ‎02-28-2012
Message 6 of 12 (912 Views)

Re: "Fixed" placed components with one constraint

07-05-2012 07:34 AM in reply to: nickhowe

Thanks Stephen

 

It looks that way! No reasons for why it doesn't move manually?

 

Cheers

 

Nick

*Expert Elite*
mrattray
Posts: 2,502
Registered: ‎09-13-2011
Message 7 of 12 (899 Views)

Re: "Fixed" placed components with one constraint

07-05-2012 08:27 AM in reply to: nickhowe

I've had that happen to me before. It's like certain parts/assemblies piss Inventor off. Usually I find sick mates or featues in the problem component. I find that using the move command instead of just dragging works fine.

Mike (not Matt) Rattray

Contributor
benemt
Posts: 17
Registered: ‎07-14-2011
Message 8 of 12 (832 Views)

Re: "Fixed" placed components with one constraint

09-25-2012 07:55 AM in reply to: nickhowe

I am having this same problem with a certain assembly.  It has many parts that have already been fully or partially constrained.  Everything that has at least one constraint on it appears fixed even if it had been "movable" earlier.  I can't post the file as it is proprietary but wanted to check and see if this was ever truly solved.

 

Thanks.

*Expert Elite*
mrattray
Posts: 2,502
Registered: ‎09-13-2011
Message 9 of 12 (810 Views)

Re: "Fixed" placed components with one constraint

09-25-2012 09:49 AM in reply to: benemt

Are there sick mates anywhere in the assembly? Are there any sick features on the parts in question? Are any of the parts in interference with each other?

Mike (not Matt) Rattray

Contributor
benemt
Posts: 17
Registered: ‎07-14-2011
Message 10 of 12 (797 Views)

Re: "Fixed" placed components with one constraint

09-25-2012 10:34 AM in reply to: mrattray

No, no, and no it seems.  The parts move normally if they have no constraints but as soon as you add one constraint (even if its to a part that previously had no constraints as well), the parts are "fixed."  I can still add more constraints and get it to align somewhere else that way though. 

 

I have "Updated" the whole assembly and tried "Rebuild All" and still have the same problem.  This is the first time this is happening with this assembly as I have been working with it for about a week.  I don't know what has changed.

 

Using Inventor 2012.

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.