Inventor General Discussion

Inventor General Discussion

Reply
New Member
ANDREWLEED6659
Posts: 2
Registered: ‎05-19-2008
Message 11 of 19 (597 Views)

Re: "A cyclical constraint dependancy was detected" error message

06-19-2012 10:53 PM in reply to: Desam

I have had this issue when using Inventor 2013. A Customer Support Case has been running for weeks .........

 

Until a solution is found, I can't afford to use version 2013.....

 

Andrew

Product Support
VinodBalasubramanian
Posts: 670
Registered: ‎09-30-2007
Message 12 of 19 (596 Views)

Re: "A cyclical constraint dependancy was detected" error message

06-19-2012 10:56 PM in reply to: ANDREWLEED6659

Thanks Andrew. Currently we are actively looking into this issue and will be addressing it as soon as possible. I will keep you all posted with an update soon.



Vinod Balasubramanian
Active Contributor
martin.vanecek
Posts: 26
Registered: ‎02-01-2010
Message 13 of 19 (540 Views)

Re: "A cyclical constraint dependancy was detected" error message

07-23-2012 02:29 AM in reply to: ANDREWLEED6659

Hello

We have the same problem, one of our VIP customers.

The estimate of the time when the fix?

We need, to communicate to the customer.

Thanks for info

Board Manager
ChrisMitchell01
Posts: 454
Registered: ‎09-16-2005
Message 14 of 19 (532 Views)

Re: "A cyclical constraint dependancy was detected" error message

07-23-2012 08:38 PM in reply to: martin.vanecek

A fix for this will be released in an "Update2" in early August. If you want to get access to that specific fix (as well as various others), before then, there is also an SP1 beta project underway now, which contains the fix. If you haven't received an invite yet, then let me know offline & I'll provide access.

 

Thanks,
Chris

chrisDOTmitchellATautodeskDOTcom



Chris Mitchell
Inventor Customer Engagement Team
Autodesk, Inc.

Active Member
longoriaos
Posts: 6
Registered: ‎02-23-2011
Message 15 of 19 (432 Views)

Re: "A cyclical constraint dependancy was detected" error message

12-13-2012 12:30 PM in reply to: Desam

I have the same problem when crreating a part from an assembliy, so far it work by breaking the link .

 

Rigth click on the part name then select break the link

Contributor
Desam
Posts: 16
Registered: ‎04-19-2008
Message 16 of 19 (420 Views)

Re: "A cyclical constraint dependancy was detected" error message

12-13-2012 03:27 PM in reply to: longoriaos

Hi,

 

You might want to try SP1.1 as this fixes the problem for me.

 

regards,

 

Hugh

Active Contributor
ic198
Posts: 78
Registered: ‎01-29-2013
Message 17 of 19 (343 Views)

Re: "A cyclical constraint dependancy was detected" error message

04-03-2013 06:35 PM in reply to: Desam

I'm still finding this problem in SP1.1- is anyone else?

Member
WinsAuto1
Posts: 5
Registered: ‎06-02-2014
Message 18 of 19 (117 Views)

Re: "A cyclical constraint dependancy was detected" error message

06-02-2014 07:28 AM in reply to: VinodBalasubramanian

Has this error been resolved.  I currently am operating Inventor 2014 and the program is totally locked up, with the cyclical error message.  How do I get out of the program to even move ahead?

Board Manager
ChrisMitchell01
Posts: 454
Registered: ‎09-16-2005
Message 19 of 19 (111 Views)

Re: "A cyclical constraint dependancy was detected" error message

06-02-2014 12:21 PM in reply to: WinsAuto1

Which version of 2014 are you using ? Some fixes related to this were released in SP1.1; that has since been updated to SP2.

 

Can you provide any example files ?

 

Thanks

Chris



Chris Mitchell
Inventor Customer Engagement Team
Autodesk, Inc.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.