Inventor General Discussion

Inventor General Discussion

Reply
Contributor
16 Posts
0 Kudos
Registered: ‎04-19-2008
Post 1 of 19

"A cyclical constraint dependancy was detected" error message

1596 Views, 18 Replies
04-26-2012 06:32 PM

Hi,

 

Am getting this error "A cyclical constraint dependancy was detected" when attempting to rebuild derived parts with any skeleton base project I work on in Inventor 2013.  Skeleton part rebuilds fine with no errors shown but part will not rebuild.  Error message does not allow me to chase down any problems either.  Just have to abandon 2013 and go back to 2012.  Am not very happy.

Is any one else experiencing this?

 

Files too large to add to post (less than 3mb but larger than 1.5mb posting attachment limit)  am happy to send/upload to any one interested

 

regards.

 

Hugh Ralton

DSAM Drafting

 

Windows 7 64bit

Product Design Suite Premium 2013 (Inventor 2013)

 

 

*Pro
1,997 Posts
285 Kudos
Registered: ‎09-15-2003
Post 2 of 19

Re: "A cyclical constraint dependancy was detected" error message

04-27-2012 04:05 AM in reply to: Desam

Pull the End of Part marker on each part all the way to the top (making the part invisible), then save and zip.  That may make them small enough to be attached here.

Contributor
16 Posts
0 Kudos
Registered: ‎04-19-2008
Post 3 of 19

Re: "A cyclical constraint dependancy was detected" error message

04-27-2012 04:50 PM in reply to: sbixler

Hi Sam,

 

Have tried that but still too big.  Have tried to reduce skeleton size but unfortunately this temporarily clears error.  Am not able to reproduce error on small scale yet either.  I have submitted files to autodesk and am thinking that others will also see this error independantly in the future and hoping that it will be dealt with then.  Am plodding along back in 2012 for the forseable future. 

 

Thankyou for your reply.

 

Hugh

Active Member
10 Posts
0 Kudos
Registered: ‎10-31-2009
Post 4 of 19

Re: "A cyclical constraint dependancy was detected" error message

05-17-2012 12:43 AM in reply to: Desam

I am having exactly the same problem after upgrading to 2013. I created this 'shed' in 2012 and it all worked sweet! upgrade to 2013, and I have LOTS of problematic parts.

 

I have attached 3 parts.

 

1. 'SITE LAYOUT.ipt' is the skeleton. no problems with this file (that i know of - many other parts built off this and work ok. and EVERYTHING worked in 2012)

 

2. Panel 'P1.ipt' is the prime example of the issue. mod the skeleton, update P1 and you get the '"A cyclical constraint dependancy was detected" error message. Interesting considering I haven't added any sketch geometry, it all comes from the skeleton. I cannot do anything (that i know of) to fix it other than completely rebuild it and repair all broken constraints. times this by the number of busted parts = fun for me.

 

3. 'BLAST ROOF PANEL.ipt' is a different issue but is VERY common in 2013 for me. again tweak the skeleton, update the part and extrusion 2 throws up an error. fix it by editing extrusion 1 and returning. do this every time I tweak the skeleton times by the number of problematic parts = more fun for me.

 

Very frustrating. Please help.

Contributor
16 Posts
0 Kudos
Registered: ‎04-19-2008
Post 5 of 19

Re: "A cyclical constraint dependancy was detected" error message

05-17-2012 01:31 AM in reply to: ifsi

Hi,

 

Am sorry  to hear you are having the same problem but not surprised unfortunately.  Back to 2012 for you too I suppose?  Another person I work with has also had exactly the same problem.  We have both submitted a support request to autodesk and got this response

 

"

Thanks for your reminder. I have checked with our developers. They are planning to fix this as a part of service pack for Inventor. I will let you know the dates as soon as i have an update from our development team.

 

Do let me know, if you have any concern. I would give a call to discuss further.

 

Looking forward to your updates.




Best regards,
Vinod Kumar Balasubramanian
Autodesk Support Team"

 

Over to you Autodesk

 

regards

 

Hugh

Product Support
681 Posts
36 Kudos
Registered: ‎09-30-2007
Post 6 of 19

Re: "A cyclical constraint dependancy was detected" error message

05-17-2012 04:45 PM in reply to: Desam
Thanks Hugh. We have received a few reports so far on this. I am working with our developers to find out any workaround, if possible. Currently this issue is work in progress and will keep you all posted with an update soon.


Vinod Balasubramanian
Employee
47 Posts
0 Kudos
Registered: ‎06-18-2007
Post 7 of 19

Re: "A cyclical constraint dependancy was detected" error message

05-18-2012 05:32 PM in reply to: Desam

We have this problem fixed in an internal build.

 

Thank you for bringing it to our attention.

 

John Hahn-Francini

Autodesk Inventor developer

Active Member
10 Posts
0 Kudos
Registered: ‎10-31-2009
Post 8 of 19

Re: "A cyclical constraint dependancy was detected" error message

05-27-2012 08:33 PM in reply to: john.hahn-francini

That is great!

 

Any chance we can get that as a hot-fix?

Employee
47 Posts
0 Kudos
Registered: ‎06-18-2007
Post 9 of 19

Re: "A cyclical constraint dependancy was detected" error message

05-29-2012 07:41 AM in reply to: Desam

Our customer service team is looking into the best way to deliver the fix. They are very well aware that this problem is causing customers a lot of grief.

 

John Hahn-Francini

Autodesk developer

Active Member
9 Posts
0 Kudos
Registered: ‎05-06-2009
Post 10 of 19

Re: "A cyclical constraint dependancy was detected" error message

06-19-2012 10:26 PM in reply to: Desam

Bump - Any progress on delivering a fix for this issue?

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are you interested in helping shape the future of the Autodesk Community? To participate in this brief usability study, please click here. Your time and input is greatly appreciated!