Inventor General Discussion

Inventor General Discussion

Reply
Valued Mentor
jeanchile
Posts: 726
Registered: ‎11-10-2009
Message 1 of 9 (420 Views)

Projected Sketch Geometry Not Updating?!?!?

420 Views, 8 Replies
01-07-2013 01:47 PM

Hello all,

 

We just upgraded from 2011 to 2013 and we are having SERIOUS problems with our projected sketch geometry in parts not updating. We have only done this about 1.1 million times over the past four years and now every one of our skeleton models we touch is failing to update and causing a whole mess of delays.

 

Please tell me there is a simple setting that we missed or something! I looked through the Application options for sketching and didn't see anything.

 

Please help us! We are dying!:smileyfrustrated:

Inventor Professional 2013 (SP-2.3), Product Design Suite Ultimate
Desktop: Intel Core i7 3.4GHz, 16.0 GB RAM, Windows 7 Ultimate SP-1, 64-bit OS, (2) GeForce GTX 580 (331.81), Space Pilot Pro (3.16.1)
Laptop: Intel Core i7 3.9GHz, 16.0 GB RAM, Windows 7 Pro SP-1, 64-bit OS, GeForce GTX 780 (331.81), SpaceNavigator (3.17.7)
Distinguished Contributor
rajeshindi
Posts: 141
Registered: ‎12-07-2009
Message 2 of 9 (400 Views)

Re: Projected Sketch Geometry Not Updating?!?!?

01-07-2013 05:30 PM in reply to: jeanchile

Hi,

I have similar issue in one of my drawings.  (Only one though)

Because I was unable to share the sketch, I created new plane and projected the sketch.

And used the projected sketch to model few rollers.  Everything works fine till this stage.  Saved my assembly.

Reopen the model it says assembly requires updating and then it says error.  Now if I redefine the sketch again with the new plane created, everything seems to be ok.

Save the drawing and if you reopen the problem is the same.

Weired but I dont know why.

I use INV 2013.  All updates are installed.

Hope any one has solution..............

Thanks.

Employee
benyang.he
Posts: 18
Registered: ‎05-04-2009
Message 3 of 9 (388 Views)

Re: Projected Sketch Geometry Not Updating?!?!?

01-07-2013 06:31 PM in reply to: jeanchile

Hi,

 

I tried it on R2013 but couldn't reproduce it, so I'd like to know whether this is a general issue or just datasets specific issue on your side. Would you please attach a dataset for investigating?

 

 

Thanks,

Webber

Valued Mentor
jeanchile
Posts: 726
Registered: ‎11-10-2009
Message 4 of 9 (362 Views)

Re: Projected Sketch Geometry Not Updating?!?!?

01-07-2013 10:34 PM in reply to: benyang.he

Okay so here's one example but we are having this happen all over the place and we can't figure out what is causing it. This picture is an example of some skeleton geometry we are using with Frame Generator. If I make the change shown in the "before" sketch:

Before.png

 

I get incorrect results, like this "after" picture:

After.png

 

It doesn't have to be this specific change, we are encountering this type of situation on a lot of different part files (new & migrated) and in a lot of different types of changes. Some simple dimensional changes, some more complex, but either way it's killing us. We paid for a parametric modeller so that things would automatically update with a parameter change and it's not happening. I can't figure out if it's a setting somewhere that's not right, user error, or what but I can say my workflow for these types of items hasn't changed in 4 years and it's only become a problem after the upgrade.

 

I appreciate any help you kind people can offer.

Inventor Professional 2013 (SP-2.3), Product Design Suite Ultimate
Desktop: Intel Core i7 3.4GHz, 16.0 GB RAM, Windows 7 Ultimate SP-1, 64-bit OS, (2) GeForce GTX 580 (331.81), Space Pilot Pro (3.16.1)
Laptop: Intel Core i7 3.9GHz, 16.0 GB RAM, Windows 7 Pro SP-1, 64-bit OS, GeForce GTX 780 (331.81), SpaceNavigator (3.17.7)
*Pro
sbixler
Posts: 1,894
Registered: ‎09-15-2003
Message 5 of 9 (343 Views)

Re: Projected Sketch Geometry Not Updating?!?!?

01-08-2013 04:45 AM in reply to: jeanchile

Can't imagine what's going on at your place.  I can move the center leg in your file and the projected ones move as expected...  I haven't seen any issues in this area at all with 2013, either migrated or new files.  I know this isn't particularly helpful, but it appears to be something specific to your environment.

Valued Mentor
jeanchile
Posts: 726
Registered: ‎11-10-2009
Message 6 of 9 (328 Views)

Re: Projected Sketch Geometry Not Updating?!?!?

01-08-2013 08:13 AM in reply to: sbixler

That is helpful actually because it removes one more variable. It also supports my idea (hope?) that it's either a setting or user error or something like that.

 

If you get a chance can you maybe post a screenshot of your Application Options' Sketch tab like Webber did? Maybe after comparing all of these I can find something different.

Inventor Professional 2013 (SP-2.3), Product Design Suite Ultimate
Desktop: Intel Core i7 3.4GHz, 16.0 GB RAM, Windows 7 Ultimate SP-1, 64-bit OS, (2) GeForce GTX 580 (331.81), Space Pilot Pro (3.16.1)
Laptop: Intel Core i7 3.9GHz, 16.0 GB RAM, Windows 7 Pro SP-1, 64-bit OS, GeForce GTX 780 (331.81), SpaceNavigator (3.17.7)
*Expert Elite*
blair
Posts: 4,145
Registered: ‎11-13-2006
Message 7 of 9 (321 Views)

Re: Projected Sketch Geometry Not Updating?!?!?

01-08-2013 08:52 AM in reply to: jeanchile

try this one as well

Did you find this reply helpful ? If so please use the Accept as Solution or Kudos button below.

IV2015 SP1 PDSU / Sim Mech 2015 r1 /
Win7-64
EVGA X79 - Classified, iCore7 3930k 32Gb Quad-Channel
950Gb (2 x 500Gb Sata III SSD RAID0 Adaptec 6805E Controller)
Nvidia GTX-690 Classified - 340.52
SpacePilot Pro 3.17.7, 6.17., 4.11
Employee
benyang.he
Posts: 18
Registered: ‎05-04-2009
Message 8 of 9 (300 Views)

Re: Projected Sketch Geometry Not Updating?!?!?

01-08-2013 04:49 PM in reply to: jeanchile

I used your dataset and followed the steps as shown in the image but could't reproduce it on my two machines on R2013. I'm not sure what happens on your side. You may try to import the XML provided by Blair and let us know whether it fix your issue.

 

Thanks,

Webber

Valued Mentor
jeanchile
Posts: 726
Registered: ‎11-10-2009
Message 9 of 9 (271 Views)

Re: Projected Sketch Geometry Not Updating?!?!?

01-16-2013 08:15 AM in reply to: benyang.he

Okay, so after playing around with this over the last couple of weeks we still have been able to isolate the issues but we have had some success in reducing the occurrences somehow. It doesn't appear to be happening as often as it was in the beginning of using 2013 but it still happens from time to time (I had it happen again yesterday).

 

We used a completely new application options XML and, while that appeared promising in the beginning, it has not provided a compete solution at this point.

 

We have noticed that is is somehow related to points not updating. This might sound weird but sometimes the lines move but the endpoints do not. Like the image I posted above, the bottom point moves, and the line moves, but the top point (and the top of the line) does not move and I end up with a skewed line when it should be straight.

 

Yesterday I had a line move completely but it left one of its endpoints behind and my basic extrusion failed. It wasn't until I deleted the stray endpoints that it worked again. One of the points moved and the entire line moved/updated like it should, I just ended up with a point at the "old" endpoint that I had to delete for some reason.

 

I wish I had more information but this is proving difficult to isolate and reproduce consistently. Any more help that can be offered would be helpful.

Inventor Professional 2013 (SP-2.3), Product Design Suite Ultimate
Desktop: Intel Core i7 3.4GHz, 16.0 GB RAM, Windows 7 Ultimate SP-1, 64-bit OS, (2) GeForce GTX 580 (331.81), Space Pilot Pro (3.16.1)
Laptop: Intel Core i7 3.9GHz, 16.0 GB RAM, Windows 7 Pro SP-1, 64-bit OS, GeForce GTX 780 (331.81), SpaceNavigator (3.17.7)
Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.