Inventor General Discussion

Inventor General Discussion

Reply
Contributor
a5100274
Posts: 20
Registered: ‎11-07-2008
Message 1 of 7 (128 Views)

Problem with camera animation

128 Views, 6 Replies
01-13-2009 09:31 AM
Hi,

I'm trying to make an animation for work, by animating a camera along a path. Should be simple enough, except it rotates through 180 degrees, which I don't want it to do. Any help would be great,

Thanks

Andy
Inventor 2009
Contributor
a5100274
Posts: 20
Registered: ‎11-07-2008
Message 2 of 7 (128 Views)

Re: Problem with camera animation

01-14-2009 12:31 AM in reply to: a5100274
any ideas???
Contributor
markus.lahtinen
Posts: 21
Registered: ‎11-20-2003
Message 3 of 7 (128 Views)

Re: Problem with camera animation

01-14-2009 10:18 AM in reply to: a5100274
Hi, I was happy to see your post because
I strugled with the same problem but cuoldnt exactly understand what causes it.
I found out that when camera and targer paths are not coliear ( or gets wery close eachother)
it flips camera like in your video.
I simply gave up after not finding help to it .

markus
*Expert Elite*
Mark_Flayler
Posts: 1,477
Registered: ‎07-30-2007
Message 4 of 7 (128 Views)

Re: Problem with camera animation

01-14-2009 10:25 AM in reply to: a5100274
Can you post your dataset? If it is too large you can contact me on my blog and I can give you instructions to my ftp site. I have some time today and tomarrow I can look at it.


Mark Flayler

Application Engineer - Manufacturing Solutions Division

Blog: www.rand.com/imaginit/manufacturingBlog

Partner Certified, Inventor Certified Expert

Instructor - ATC

AIP 2009 SP1 Bonus Tools

Dell m4300, Core 2 Duo T8300, 4 GB Ram/3GB switch

Quadro FX 360M; Driver 6.14.11.7575

Windows XP SP3, Zune Theme
Mark Flayler - Senior Application Engineer
IMAGINiT's Manufacturing Solutions Blog:
http://blogs.rand.com/manufacturing/
*MarcoA
Message 5 of 7 (128 Views)

Re: Problem with camera animation

01-15-2009 12:54 AM in reply to: a5100274
a5100274 ha scritto:
> Hi, I'm trying to make an animation for work, by animating a camera
> along a path. Should be simple enough, except it rotates through 180
> degrees, which I don't want it to do. Any help would be great, Thanks
> Andy Inventor 2009

I'm ignorant about camera animation in Inventor, but I wonder if it
could have something to do with the direction of the local z axis of the
curve (where x is tangent and y is directed towards the centre of
curvature)...


--
AIS 11 SP4
Pentium 4 3 GHz - 2 GB RAM
NVIDIA Quadro 330 6.14.10.9136
Contributor
markus.lahtinen
Posts: 21
Registered: ‎11-20-2003
Message 6 of 7 (128 Views)

Re: Problem with camera animation

01-18-2009 12:57 PM in reply to: a5100274
Hi Mark
Thanks for your response.Attached my unsuccesfull testing of camera motion.
I just couldnt figure out why camera rotates as it does.
Im eager to hear how to correct my workflow.

Markus
IV2009sp1
Contributor
Brenda.Chen
Posts: 23
Registered: ‎11-25-2008
Message 7 of 7 (128 Views)

Re: Problem with camera animation

01-20-2009 02:04 AM in reply to: a5100274
Hi Andy,

Thanks for your feedback.

This is a known issue. In studio, camera vector is defined using the direction of axis Y. Therefore, in a camera path animation, camera will rotate if its vetctor is parallel to axis Y.

Regards,
Brenda Chen-Autodesk
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are You Going To Be @ AU 2014? Feel free to drop by our AU topic post and share your plans, plug a class that you're teaching, or simply check out who else from the community might be in attendance. Ohh and don't forgot to stop by the Autodesk Help | Learn | Collaborate booths in the Exhibit Hall and meet our community team if you get a chance!