Inventor General Discussion

*Crain, Ron
Message 1 of 5 (76 Views)

Parts list won't update The sequel

76 Views, 4 Replies
11-03-2002 11:01 PM
I didn't want this to get lost inside JGH's thread since it's a bit

JGH said he wasn't using an IPN for his drawing or his parts list - but I

I have an assembly - It had M5x20 screws in it. This assembly has an iam,
ipn, idw. I modified the iparts in the iam - clicking the table and
selected a new length for the screws (30mm). iam looks fine. I opened the
IPN and made sure it appeared fine - everything was OK.

I then opened the IDW and the item row for the screws weren't not only not
updated, but it was missing all together! I did a "compare", nothing. I did
an update, nothing.

I then decided to try to delete the screws and insert new ones. - Updated
the IPN, re-opened the IDW and still the row for the screw was missing!

I placed a new parts list from the assembly view (not the ipn view) and it
correctly listed the screws. I then tried placing a new parts list from the
IPN view - Screws are missing!!

I then deleted all the parts lists in this drawing and proceeded to delete
all the balloons (has anyone noticed if you RMB a balloon and hit "D" for
delete that it doesn't delete?).

Saved and re-opened the idw - place a new parts list from the IPN view - The
screws appear!

Definite bug! Thank gawd there's a workaround.
*Bilton, John
Message 2 of 5 (76 Views)

Re: Parts list won't update The sequel

11-03-2002 11:14 PM in reply to: *Crain, Ron
I'm glad someone else is seeing this problem. It only occurs on drawings that are migrated from
5.3, if you start from scratch everything is fine and dandy. If the files have been migrated
through Beta first then shipping build, it appears to work (I can't prove this to be true, I am only
going on what someone else has discovered).

John Bilton
"It seemed like a good idea at the time..."
*Crain, Ron
Message 3 of 5 (76 Views)


11-03-2002 11:33 PM in reply to: *Crain, Ron
In this case, the assembly file and parts were the only things migrated (and
the dwg template). The IPN and assembly drawing were created in R6.
Active Contributor
Posts: 33
Registered: ‎12-03-2003
Message 4 of 5 (76 Views)


11-03-2002 11:37 PM in reply to: *Crain, Ron
Ron, I talked with Autodesk about this issue, It is definitely a bug in Rel 6. They wrote me friday, this is their response:
Erik Kurek
Avatech NSC

I have received word from Autodesk about the BOM not updating from an update ipn file. This is definitely a logged defect and apparently the in
an early release of SP-1 for IV6 which has not been released to the general public has fixed the problem so the solution will be out barring some
product stopping issue.

In the meantime I am going to close this ticket as being resolved
sorry I couldn't give you better answer, but at least the issue is fixed.

Erik J. Kurek
Mechanical Products Support Specialist
Avatech Solutions - National Support Center
(800) 808-7645 Fax: (402) 451-8007

Also, if you have to fixed it right now, I have found that if you delete the balloons and BOM and start from scratch,
the BOM will update. Hope this helps.
*Bilton, John
Message 5 of 5 (76 Views)


11-03-2002 11:58 PM in reply to: *Crain, Ron
Excellent news, I will have a very happy customer in the near future.

John Bilton
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Are You Going To Be @ AU 2014? Feel free to drop by our AU topic post and share your plans, plug a class that you're teaching, or simply check out who else from the community might be in attendance. Ohh and don't forgot to stop by the Autodesk Help | Learn | Collaborate booths in the Exhibit Hall and meet our community team if you get a chance!