Inventor General Discussion

Inventor General Discussion

Reply
Distinguished Contributor
KF090
Posts: 134
Registered: ‎04-27-2010
Message 1 of 6 (531 Views)

Memory usage according to the 'Memory Usage Meter'...

531 Views, 5 Replies
08-10-2011 08:38 AM

After working on multiple files (a few ipt's and an iam), I closed all the files but the MUM still was in the yellow.  I gave it a few minutes and it didn't not drop at all.

 

Why does Inventor sometimes NOT release the memory it had been using well after all files are closed?

 

I had to completely shutdown Inventor in order to gain access to that memory again.

*Expert Elite*
mcgyvr
Posts: 7,248
Registered: ‎12-01-2004
Message 2 of 6 (519 Views)

Re: Memory usage according to the 'Memory Usage Meter'...

08-10-2011 09:35 AM in reply to: KF090

Its actually done that way on purpose. Inventor is supposed to keep stuff in memory to allow you to open it quicker the next time. Its sometimes good and other times is a silly function. Closing and reopening Inventor will clear that as you have found.

Did you find this reply helpful ? If so please use the Accept as Solution or Kudos button below.

-------------------------------------------------------------------------------------
2015 Product Design Suite Ultimate
Windows 7 64 bit
Core i7 4820k processor (OC'd to 4.4Ghz), Nvidia GTX 770, 16G RAM


Valued Mentor
RayFeiler
Posts: 402
Registered: ‎10-07-2008
Message 3 of 6 (513 Views)

Re: Memory usage according to the 'Memory Usage Meter'...

08-10-2011 09:46 AM in reply to: KF090

Also some of it has to do with undo file size.

Product Design Suite Ultimate 2014 64-Bit

Sometimes you just need a good old reboot.
Distinguished Contributor
KF090
Posts: 134
Registered: ‎04-27-2010
Message 4 of 6 (498 Views)

Re: Memory usage according to the 'Memory Usage Meter'...

08-10-2011 12:44 PM in reply to: mcgyvr

Is there anyone to change a setting so that is does not cache any files?

 

 

Employee
johnsonshiue
Posts: 2,345
Registered: ‎04-30-2008
Message 5 of 6 (493 Views)

Re: Memory usage according to the 'Memory Usage Meter'...

08-10-2011 01:08 PM in reply to: KF090

Hi! If you want to turn off the file caching activity behind the scene, there are two ways to do that. Please keep in mind, without caching, next time you open the same file will take the same time as you open it first time.

 

On Inventor, go to Application Options -> File -> uncheck "Enable Quick File Open" option at the bottom.

 

On Win7 or Vista, you may consider turning off a service called Superfetch.You will be turning off a default Windows function. Please search for relevent information on the web and understand clearly the consequence of turning off the option before you proceed.

 

Thanks!

 



Johnson Shiue (johnson.shiue@autodesk.com)
Senior Principal SQA Engineer, Inventor
Mechanical Design
Autodesk, Inc.

Active Contributor
icreator3d
Posts: 28
Registered: ‎05-23-2006
Message 6 of 6 (387 Views)

Re: Memory usage according to the 'Memory Usage Meter'...

01-26-2012 03:41 PM in reply to: johnsonshiue

Hi, This is a little after the fact, but I'm having the same issue and unchecking "Enable Quick File Open" didn't fix the problem.  I use XP and Inventor 2012.  When I close files the memory drops a little bit, but most of it stays cached. 

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.