Inventor General Discussion

Inventor General Discussion

Reply
Mentor
trumpy81
Posts: 317
Registered: ‎10-22-2006
Message 11 of 41 (2,398 Views)

Re: Knurled Appearance doesn't show in 2013 Pro

04-10-2012 09:08 PM in reply to: ChrisMitchell01

Thanks Chris!! I don't know how I missed scaling in the image edit dialog but obviously I did. Perhaps I messed with it but also had some other setting set incorrectly and then dismissed it as a possible solution.

 

So now at least I have success with a custom appearance, but how about the native Knurled 45 appearance?

 

It's not working for me either which is what led to making the custom appearance to begin with. I guess I was frustrated at that point so i started looking for answers in the wrong place.

 

I really need to tape a mirror to the screen, so I can see the problem more clearly ... lol

 

Thanks again.

Regards
Andy M
-------------------------------------------------------------------------------------------
Autodesk Inventor 2013 Pro SP1.1, Win7 Pro - 64Bit - SP1, Intel i7 960 @ 3.333 GHz
Asus X58 Sabertooth, Corsair 12Gig DDR3, AMD Radeon HD6970, Samsung 830 Series 256G SSD, 2x 3TB Seagate, 2x 2TB Hitachi,
1x 1TB Samsung, 4 x 2TB Seagate in Netgear ReadyNAS NV+, Dual Asus VE278Q Monitors
Board Manager
ChrisMitchell01
Posts: 398
Registered: ‎09-16-2005
Message 12 of 41 (2,375 Views)

Re: Knurled Appearance doesn't show in 2013 Pro

04-11-2012 10:00 AM in reply to: trumpy81

Hi Andy,

 

Yes, during the migration of your appearances, Metas-Steel (Knurled) is migrated to Knurled 45. For a part of this size the same scaling issue exists as I previously mentioned, which is why it wasn't showing up properly. If you do a similar scaling change for a custom image for Knurled 45 you will be able to get the appearance you're looking for.


The issue with Knurled 45 is also logged.

 

Back to the issue with Ray Tracing performance, you can either switch it off for Realistic mode for the whole application, or you can continue to work with the default of honouring Document Settings & edit your default template so so that Ray Tracing is disabled there.

 

Sorry for the inconvenience,

Chris



Chris Mitchell
Inventor Customer Engagement Team
Autodesk, Inc.

Mentor
trumpy81
Posts: 317
Registered: ‎10-22-2006
Message 13 of 41 (2,361 Views)

Re: Knurled Appearance doesn't show in 2013 Pro

04-11-2012 12:50 PM in reply to: ChrisMitchell01

Chris, Knurled 45 is not migrated, it was installed when 2013 Pro was installed. I have 2013 installed in a VM where it could not have imported anything.

Anyhow the settings for Knurled 45 are:

Metal
Type - Stainless Steel
Finish - Polished

Relief Pattern
Type - Knurl
Amount - 0.80
Scale - 1.40

These are the default settings, nothing has been touched by me only the basic options have been selected in 'Options'. Set display units are English (in, lbmass, psi) and native units in this installation are imperial.

When it is applied to a part, using the 'Adjust' mini-toolbar there is no option for scaling as there is for my custom knurl appearance.

Just thought you should know.

BTW, my custom knurls are looking fantastic ... I'm a very happy chappy right now :smileyhappy:

Thanks for the help getting it sorted, I really do appreciate that.

Regards
Andy M
-------------------------------------------------------------------------------------------
Autodesk Inventor 2013 Pro SP1.1, Win7 Pro - 64Bit - SP1, Intel i7 960 @ 3.333 GHz
Asus X58 Sabertooth, Corsair 12Gig DDR3, AMD Radeon HD6970, Samsung 830 Series 256G SSD, 2x 3TB Seagate, 2x 2TB Hitachi,
1x 1TB Samsung, 4 x 2TB Seagate in Netgear ReadyNAS NV+, Dual Asus VE278Q Monitors
Valued Contributor
jberns
Posts: 85
Registered: ‎03-02-2010
Message 14 of 41 (2,168 Views)

Re: Knurled Appearance doesn't show in 2013 Pro

09-13-2012 09:54 AM in reply to: ChrisMitchell01

Chris,

 

Why does a thread feature appear correctly without requiring Ray Tracing, yet a knurl texture requires Ray Tracing? Aren't they both just bitmaps?

 

Regards,

 

Jerry Berns

-----------------------------------------------------------------------------------------
Autodesk Certified Instructor
Autodesk Inventor 2014 Certified Professional
Autodesk AutoCAD 2013 Certified Professional
Mentor
trumpy81
Posts: 317
Registered: ‎10-22-2006
Message 15 of 41 (2,159 Views)

Re: Knurled Appearance doesn't show in 2013 Pro

09-13-2012 11:10 AM in reply to: jberns

Jerry, I'm not Chris, But I'll try to answer your question. Chris can correct me if I'm wrong.

 

You are correct to assume that they are both bitmaps, but the knurl should also use a bump map to give the impression of the raised pattern. If you look at any thread in Inventor it appears flat, because it actually is, there is no bump map associated with it.

 

You can display a knurl in 2013 without ray tracing but first you have to create one from scratch in the appearance editor using a bitmap as a pattern relief.

 

I have created my own brass colored knurl and it displays correctly for me at least but the standard Knurled 45 does not.

Regards
Andy M
-------------------------------------------------------------------------------------------
Autodesk Inventor 2013 Pro SP1.1, Win7 Pro - 64Bit - SP1, Intel i7 960 @ 3.333 GHz
Asus X58 Sabertooth, Corsair 12Gig DDR3, AMD Radeon HD6970, Samsung 830 Series 256G SSD, 2x 3TB Seagate, 2x 2TB Hitachi,
1x 1TB Samsung, 4 x 2TB Seagate in Netgear ReadyNAS NV+, Dual Asus VE278Q Monitors
Valued Contributor
jberns
Posts: 85
Registered: ‎03-02-2010
Message 16 of 41 (2,149 Views)

Re: Knurled Appearance doesn't show in 2013 Pro

09-13-2012 11:57 AM in reply to: trumpy81
Andy, I had selected the Reply button on Chris' post, but I guess the system instead replied to the last post. Sorry about that. Thanks for the explanation. I have demonstrated the knurl texture for several years. Yesterday when I tried to show the texture in an Inventor 2013 class I was surprised to find it not working. It would seem the simple process of displaying a knurled face has become more difficult in Inventor 2013. Best regards, Jerry Berns
-----------------------------------------------------------------------------------------
Autodesk Certified Instructor
Autodesk Inventor 2014 Certified Professional
Autodesk AutoCAD 2013 Certified Professional
Mentor
trumpy81
Posts: 317
Registered: ‎10-22-2006
Message 17 of 41 (2,141 Views)

Re: Knurled Appearance doesn't show in 2013 Pro

09-13-2012 12:26 PM in reply to: jberns

Jerry, I have found the problem with the Knurled 45 appearance.

 

When it is first installed the appearance will have the parameters that I typed in my reply, the one directly above your question.

 

You will notice that there is no image mentioned because, as installed, the Knurled 45 appearance doesn't use one and that's the problem.

 

Relief Pattern
Type - Knurl      <---- Change the type to Custom Image
Amount - 0.80
Scale - 1.40

 

After changing to custom image, select C:\Users\Public\Documents\Autodesk\Inventor 2013\Textures\surfaces\knurl_3.bmp then click the triangle to the right of the image to edit the bitmap settings.

 

In the scale panel, set the 'sample size' to be 0.20 in (you can't use any other units here except inches.)

 

Close the image editor and click on the apply button.

 

If the knurl appears too big or too small, go back and edit the sample size again. 0.20 should be ok for parts 1" or less in size.

 

Don't forget to add the appearance back to the library, otherwise it will only exist in the document you edited it in.

 

HTH

Regards
Andy M
-------------------------------------------------------------------------------------------
Autodesk Inventor 2013 Pro SP1.1, Win7 Pro - 64Bit - SP1, Intel i7 960 @ 3.333 GHz
Asus X58 Sabertooth, Corsair 12Gig DDR3, AMD Radeon HD6970, Samsung 830 Series 256G SSD, 2x 3TB Seagate, 2x 2TB Hitachi,
1x 1TB Samsung, 4 x 2TB Seagate in Netgear ReadyNAS NV+, Dual Asus VE278Q Monitors
Valued Contributor
ChrisVandeVoorde
Posts: 52
Registered: ‎01-05-2011
Message 18 of 41 (2,092 Views)

Re: Knurled Appearance doesn't show in 2013 Pro

09-28-2012 02:32 AM in reply to: trumpy81

Will this be solved in the SP1 fix?

 

I have this problem since we work with SP1 (2013 & the beta were ok).

I don't want to change anything. we have ton's of parts in Inventor with knurled surfaces, if I open and old file (IV 2011 it turns out to be yellow) if i then press update styles everything used to become ok (using 2013 without SP1). Now the knurled is totaly messed up.

 

I'm pissed because we need to manualy update the styles of all our parts, now we would need to do even more work? Not good ....

 

please solve this in the better SP1!

 

for now I believe the best thing to do for me is to remove SP1 :smileysad: (even if it fixes a few crashes)

 

 

Board Manager
ChrisMitchell01
Posts: 398
Registered: ‎09-16-2005
Message 19 of 41 (2,080 Views)

Re: Knurled Appearance doesn't show in 2013 Pro

09-28-2012 11:58 AM in reply to: ChrisVandeVoorde

Chris,

 

Do you have any extra info about this ? Did you remove the SP1 version ? Did that fix the problem ?

 

Are you able to share one of these problem parts & also your material/appearance library that contains the knurl definition ?

 

Thanks,

Chris



Chris Mitchell
Inventor Customer Engagement Team
Autodesk, Inc.

Valued Contributor
ChrisVandeVoorde
Posts: 52
Registered: ‎01-05-2011
Message 20 of 41 (2,053 Views)

Re: Knurled Appearance doesn't show in 2013 Pro

10-01-2012 12:07 AM in reply to: ChrisMitchell01

Hi Chris (btw cool name :-))

 

I have removed SP1 and now the problem is over. The problem only arrived once I went to SP1 (I also worked for a month with SP1 beta but no problem there). Now I work without a SP.

 

 

Since 2013 I have problems opening a old part that is saved in 2011 format. Once I open a part it asks me to transform it to the appearances library, I say yes and then it converts my custom colours to a yellow welded like thing:

wrong textures.JPG

 

To fix this in IV2013 & IV 2013BetaSP1  I just need to update my styles & purge the once thate aren't used and then my part is all fine. When I did the same in IV2013SP1 it was also okay. Only with parts that had a knurled surface the knurled would show up incorrectly.

 

I have attached 2 parts, one without a knurled surface and the other with it (still saved as an IV2011 file)

 

What actually would help me the most is that I just don't need to press update & purge. It just need to be include in the command of converting things to the appearances. In addition to that the knurled error (mm>inch) should be solved.

 

Hope this helps

 

 

Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.