Inventor General Discussion

Reply
Distinguished Contributor
lis_wang
Posts: 459
Registered: ‎11-26-2003
Message 1 of 10 (248 Views)
Accepted Solution

Inventor studio

248 Views, 9 Replies
04-27-2012 07:57 AM

I create a engine assembly and used "Drive Constrain" to rotate the crank shaft. The animation shows the crank shaft turns continuously in one direction. However, when I animate the constrain in Inventor Studio, the crank shaft turned in two different directions (see the vide file attached).

 

May I know why the crank shaft turns different direction?

 

Thanks  

Make sure the planes used for the angle constraint share the same axis.

I used the assembly origin YZ and the DLM-006 YZ planes for the angle constraint and it worked fine in Studio.

*Expert Elite*
JDMather
Posts: 27,586
Registered: ‎04-20-2006
Message 2 of 10 (242 Views)

Re: Inventor studio

04-27-2012 08:15 AM in reply to: lis_wang

Which of the 3 Angle Constraint types did you use?
Can you use Dynamic Simulation and Publish to Studio instead?

Please mark this response as "Accept as Solution" if it answers your question.
-----------------------------------------------------------------------------------------
Autodesk Inventor 2014 Certified Professional
Autodesk AutoCAD 2013 Certified Professional
Certified SolidWorks Professional
Inventor Professional 2015-SP1 64-bit
http://www.autodesk.com/edcommunity
http://home.pct.edu/~jmather/content/DSG322/inventor_surface_tutorials.htm
Distinguished Contributor
lis_wang
Posts: 459
Registered: ‎11-26-2003
Message 3 of 10 (218 Views)

Re: Inventor studio

04-28-2012 12:43 AM in reply to: JDMather

Not matter I used Directed Angle or Undirected Angle, it is still the same. I created a animation by using "Drive Constrain"  and the crank shaft shows only one direction. Please see the file attahced.

Distinguished Contributor
lis_wang
Posts: 459
Registered: ‎11-26-2003
Message 4 of 10 (188 Views)

Re: Inventor studio

05-01-2012 05:58 AM in reply to: lis_wang

Any reply?

*Expert Elite*
JDMather
Posts: 27,586
Registered: ‎04-20-2006
Message 5 of 10 (181 Views)

Re: Inventor studio

05-01-2012 06:32 AM in reply to: lis_wang

Attach your assembly here.

Please mark this response as "Accept as Solution" if it answers your question.
-----------------------------------------------------------------------------------------
Autodesk Inventor 2014 Certified Professional
Autodesk AutoCAD 2013 Certified Professional
Certified SolidWorks Professional
Inventor Professional 2015-SP1 64-bit
http://www.autodesk.com/edcommunity
http://home.pct.edu/~jmather/content/DSG322/inventor_surface_tutorials.htm
Distinguished Contributor
lis_wang
Posts: 459
Registered: ‎11-26-2003
Message 6 of 10 (172 Views)

Re: Inventor studio

05-01-2012 07:01 AM in reply to: JDMather

As the file is too big, so I zipped into 3 files. This is the 1st zip file.

Distinguished Contributor
lis_wang
Posts: 459
Registered: ‎11-26-2003
Message 7 of 10 (171 Views)

Re: Inventor studio

05-01-2012 07:02 AM in reply to: lis_wang

This is the 2nd one

Distinguished Contributor
lis_wang
Posts: 459
Registered: ‎11-26-2003
Message 8 of 10 (169 Views)

Re: Inventor studio

05-01-2012 07:04 AM in reply to: lis_wang

This is the last one. Please unzip the 3 zipped files into one folder.

*Expert Elite*
JDMather
Posts: 27,586
Registered: ‎04-20-2006
Message 9 of 10 (164 Views)

Re: Inventor studio

05-01-2012 07:25 AM in reply to: lis_wang

Make sure the planes used for the angle constraint share the same axis.

I used the assembly origin YZ and the DLM-006 YZ planes for the angle constraint and it worked fine in Studio.

Please mark this response as "Accept as Solution" if it answers your question.
-----------------------------------------------------------------------------------------
Autodesk Inventor 2014 Certified Professional
Autodesk AutoCAD 2013 Certified Professional
Certified SolidWorks Professional
Inventor Professional 2015-SP1 64-bit
http://www.autodesk.com/edcommunity
http://home.pct.edu/~jmather/content/DSG322/inventor_surface_tutorials.htm
Distinguished Contributor
lis_wang
Posts: 459
Registered: ‎11-26-2003
Message 10 of 10 (142 Views)

Re: Inventor studio

05-01-2012 06:36 PM in reply to: JDMather

Thanks. It solves my preoblem.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.