Inventor General Discussion

Inventor General Discussion

Reply
Active Member
7 Posts
0 Kudos
Registered: ‎10-16-2012
Post 1 of 2

Inventor freeze when Macros should load or run?

164 Views, 1 Replies
10-16-2012 11:45 PM

Hi all

Working with inventor pro 2012, whenever I try to run a macro, the program freezes.  It happens when I press the tools/macros buttonand it can take 30 sec or more before the macros dialog release and active or I can try to run windows job list which seems to release the jam too.It also happens when I try to run my macro with shortcut key or customized button. It freezes before the macro even loads and it is very frustrating. If I open the macros editor and run the macro from there (run sub) then there is no delay at all!    

Does anybody else have the same and if so do you have a solution?

Thanks

Alon

Autodesk Inventor 2012 SP1 64-bit, win 7 

Active Member
7 Posts
0 Kudos
Registered: ‎10-16-2012
Post 2 of 2

Re: Inventor freeze when Macros should load or run?

10-18-2012 11:32 PM in reply to: ravivalon

still looking for an answer...

 

I’ve erased all macros from all modules. Right now there is not a single thing written in the vba default. I’ve tried to run the macro dialog with no file open (to prevent any relations to any project ipj) and it still happens. In other words, a clean new Inventor session with no vba to work with and all I do is press the tools-macros button – and it freezes!

There is nothing to load for god sake. The only way to intervene is to launch job list!

It is really frustrating because my macros kick **** but if inventor freezes before loading or running them, then what’s the point.

 

I would really appreciate some clever Autodesk wiz to spring in action now. 

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are you interested in helping shape the future of the Autodesk Community? To participate in this brief usability study, please click here. Your time and input is greatly appreciated!