Inventor General Discussion

Inventor General Discussion

Reply
Member
Bothar
Posts: 5
Registered: ‎09-26-2010
Message 1 of 4 (281 Views)

Inventor DWG BMP embedding replication

281 Views, 3 Replies
06-06-2013 01:54 AM

Good day, 

I hope you can help me.

 

We have Inventor DWG templates that I have created based on our AutoCAD DWG templates. We chose the INV DWG route to simplify template creation. However, our logo has a gradient hatch with the 'O', something which Inventor cannot handle.

So we now modify the logo only, changing the 'O' to an embedded bitmap image. The same goes for the ISO logo.

 

After doing this, I noticed the drawings were increasing in size, at a much higher rate than detail I was addding to the drawings. If I go to Tools > Links, i see that the bitmaps are being replicated, over and over (seems like after every save, or every time the drawing is opened). The count can hit around 45 embeddings!

 

The problem is that the logo randomly drops off (on screen and after printing) due to there being too many embeddings, and I cannot save the Inventor DWG to an AutoCAD DWG any longer (clients request editable DWGs).

 

Question : How do I stop the embedding replications? Or at least purge them out...

 

Attached : Drawing with all views deleted. Notice file size of 8mb. Normal size around 1.4mb from template file.

 

DWG Link : http://goo.gl/JdYQT

2013-06-06 10-29-23 AM.jpg

Member
Bothar
Posts: 5
Registered: ‎09-26-2010
Message 2 of 4 (280 Views)

Re: Inventor DWG BMP embedding replication

06-06-2013 01:58 AM in reply to: Bothar
This applies to Inventor 2012 SP2 and Inventor 2014
Member
drobbie
Posts: 5
Registered: ‎12-10-2007
Message 3 of 4 (163 Views)

Re: Inventor DWG BMP embedding replication

12-27-2013 11:22 AM in reply to: Bothar

So has anyone replied got an answer on this?

Has anyone submitted a tech support request to Autodesk? I know of several companies that have this issue.

Valued Contributor
RyanBotha
Posts: 98
Registered: ‎01-15-2007
Message 4 of 4 (136 Views)

Re: Inventor DWG BMP embedding replication

01-05-2014 09:45 PM in reply to: drobbie

Hello.

 

The way I resolved this was using iLogic within the drawing. Create 2 seperate rules, running OLE ON first, deleting unwanted OLE objects that now appear in the browser window, then running OLE OFF.

 

Beware that the drawing still requires at least one reference to the image, so it will crash if you delete that one. To find out which one it is, apply some trial and error...

 

‘RULE OLE ON

Dim oDoc As Inventor.DrawingDocument

oDoc = ThisDrawing.Document

 

Dim oRefOleFileDes As ReferencedOLEFileDescriptor

For Each oRefOleFileDes in oDoc.ReferencedOLEFileDescriptors

      oRefOleFileDes.Visible = True

        oRefOleFileDes.BrowserVisible = True

Next

 

‘RULE OLE OFF

Dim oDoc As Inventor.DrawingDocument

oDoc = ThisDrawing.Document

 

Dim oRefOleFileDes As ReferencedOLEFileDescriptor

For Each oRefOleFileDes in oDoc.ReferencedOLEFileDescriptors

      'oRefOleFileDes.Visible = True

        oRefOleFileDes.BrowserVisible = False

Next

 

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.