Inventor General Discussion

Inventor General Discussion

Reply
Contributor
henrik.andersen
Posts: 17
Registered: ‎03-07-2007
Message 11 of 12 (441 Views)

Re: Inventor 2013 Non-Responsive for long periods of time

10-29-2012 12:00 AM in reply to: johnsonshiue

1. When Inventor behaves slowly, does creating a line in a simple sketch takes a long time? 

- No, this works fine. 

2. After it happens, does rebooting or restarting Inventor help?

- No, 

3. Does uninstalling the service pack and reinstalling it help?

- Have not tried it. But i hade the same problem before installing SP 1.1 

4. If you start a different Inventor release like R2012 or earlier and close it and then restart R2013, does it help?

- No. does nt make any differance. 

 

I have found out that Inventor behaves differently depeding how i start and how I select the project. When I closed Inventor and then started by double click on my part-file I got the result that Invetor started the Copy Loop with the InventorMaterialLibrary file instead of my own. 

C:\Users\HEAN\AppData\Local\Temp\MaterialLibraries_PID_2bb0\InventorMaterialLibrary(221).adsklib

 

And I have tried to create and recreate my own library files but when this didn't work I tried a copy of Inventors own material library file. So i do not think I am confusing the program. It is confused from the start.

 

Contributor
henrik.andersen
Posts: 17
Registered: ‎03-07-2007
Message 12 of 12 (437 Views)

Re: Inventor 2013 Non-Responsive for long periods of time

10-29-2012 12:30 AM in reply to: henrik.andersen

I have now tried to narrowing it down and accually get the same result without creating a custom library file. It was just that the performance imrpoved when I deleted my own project.

 

Do this to replicate the problem

  1. downloaded sampel files from from http://images.autodesk.com/adsk/files/autodesk_inventor_2013_samples.exe 
  2. select "C:\Users\Public\Documents\Autodesk\Inventor 2013\Samples\Samples.ipj" 
  3. Crete a new part
  4. Start Process Monitor and by selecting Include when right clicking on inventor.exe
    - Process monitor downloaded from http://live.sysinternals.com/Procmon.exe  
  5. Select Derive from [3d Model]>[Create]
  6. select "C:\Users\Public\Documents\Autodesk\Inventor 2013\Samples\Models\Assemblies\Engine MKII\Engine MKII.iam" 
  7. Inventor will then go into not-responing-mode and if you examine you tempfolder you will find multiple copies of C:\Users\%username%\AppData\Local\Temp\MaterialLibraries_PID_2bb0\InventorMaterialLibrary(???).adsklib 
  8. Go to your  C:\Users\Public\Documents\Autodesk\Inventor 2013\Design Data\Materials-folder
  9. Rename  \InventorMaterialLibrary.adsklib and you will find that the program directly returns from non-responsive-mode and displays the Derived Assembly dialog.

This has now been verified on different machines with differenct OS and with SP0/SP1/SP1.1

 
 
Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.