Inventor General Discussion

Inventor General Discussion

Reply
Board Manager
ChrisMitchell01
Posts: 447
Registered: ‎09-16-2005
Message 31 of 63 (1,464 Views)

Re: Inventor 2013 extremley slow in IDW's

06-20-2012 04:11 PM in reply to: jorgen

Jørgen,

 

Are you able to share an example of this drawing with us for further investigation ?

 

You can email me at chrisDOTmitchellATautodeskDOTcom & then I can provide you with a mechanism to get the data to us, assuming it's too large for email.

 

Thanks,
Chris



Chris Mitchell
Inventor Customer Engagement Team
Autodesk, Inc.

Valued Mentor
rhasell
Posts: 330
Registered: ‎05-23-2007
Message 32 of 63 (1,464 Views)

Re: Inventor 2013 extremely slow in IDW's

06-20-2012 04:33 PM in reply to: ChrisMitchell01

Hi all.

 

Chris has spent some time trying to debug my problem and came with some suggestions, as he could not reproduce my problem.

 

Needless to say, I still have the problem, I have just learnt to work around it, by restarting Inventor often, sometimes after working with one drawing at a time.

 

These did make a noticeable difference, I can work for a little longer than usual

- Set the system swap file to a fixed size, in my case 18gig

- Set the Inventor Undo to 2 gig, I set mine to 4gig

- Re-install/repair c++ and dotnet, this I have not done, as I am scared of destroying windows.

 

Hopefully Autodesk will find the problem, and release a patch soon.

 


Reg
Autodesk PDS Ultimate 2015 SP 1 Build 203
Intel Core i7 (950@3.07GHz)/Win7x64 (Home) - 12GB Ram
Nvidia GeForce GTX 560 Ti
 
Please Give Kudo's / accept as a solution if it solves your problem.
Valued Contributor
DVDM
Posts: 112
Registered: ‎09-24-2009
Message 33 of 63 (1,444 Views)

Re: Inventor 2013 extremley slow in IDW's

06-21-2012 09:43 PM in reply to: ChrisMitchell01

Run the application from the link below:

http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx

I've used it many times to try and troubleshoot mysterious slowdowns and lockups. It allows you see what your computer is doing while Inventor just shows 100% processor activity and ever increasing ram usage, but nothing else.

 

By applying a filter for the inventor.exe processes, or various other processes, you're better able to track down what the issue is.

 

For example, I once had a mysterious slowdown of AutoCAD and Inventor, and with the help of process monitor was able to determine that it was the windows feature Offline Files that was causing it. I disabled offline files, restarted, and all was well again.

 

You can wait for a service pack, but unless you've determined what the issue is (which is likely on your side if someone else can't reproduce it), it will never get fixed.

 

Employee
johnsonshiue
Posts: 2,335
Registered: ‎04-30-2008
Message 34 of 63 (1,427 Views)

Re: Inventor 2013 extremely slow in IDW's

06-22-2012 01:44 PM in reply to: rhasell

Reg,

 

Chris forwarded this issue to me along with the files you shared with him. I am able to reproduce the behavior you are seeing. So far I have not been able to pinpoint exactly where the problem is.

I do notice the assembly the drawing is referencing needs an update. After updating the assembly and saving all the files shown in the save dialog, I see the perofrmance seems to be better. Could you confirm that?

Thanks!

 



Johnson Shiue (johnson.shiue@autodesk.com)
Senior Principal SQA Engineer, Inventor
Mechanical Design
Autodesk, Inc.

Active Member
jorgen
Posts: 8
Registered: ‎11-04-2010
Message 35 of 63 (1,407 Views)

Re: Inventor 2013 extremely slow in IDW's

06-24-2012 11:21 PM in reply to: johnsonshiue

Hi, I¨ve received e-mail from Chris regarding this. When using Bitmap allways, the performance is better. I allways makes sure the files are up to date, but the packngo you received might not have been. 

 

As mentioned in e-mail, I will use the bitmap mode, making sure all is up to date and hopefully we will see a service patch for this in the future. 

 

Thanks for your efforts.

Jørgen

-------------------------------------------------------
Autodesk Product Design Suite Premium 2013

Xeon E5450, 16GB, Win8 x64, Intel SSD 520, GTX9800
+
ASUS G75VW
i7-3610QM,16GB, Win8 x64, SSD, GTX670 3GB.
Valued Mentor
rhasell
Posts: 330
Registered: ‎05-23-2007
Message 36 of 63 (1,383 Views)

Re: Inventor 2013 extremely slow in IDW's

06-25-2012 10:36 PM in reply to: johnsonshiue

Hi Johnson

 

Regarding your post, Thanks, it's hard to say, as I am continually updating and refreshing as the build continues.

 

I have made a change which has all but eliminated the slow down.

 

I changed the Graphics setting to "Compatibility"

 

Guess what it works, The overall performance has dropped off, but its a small price to pay for stability.

 

At this stage I have not experienced the dreaded performance drop off, only time will tell.  Making this setting has it's own set of display issues, Views disappearing temporarily, leaders and balloons look really strange while placing them, but after placement, they look fine.

 

The overall modeling side has had a slight performance knock as well, but not much.

 

I tried the Performance monitor the other day, works well, but to diagnose the information and to see what is acceptable errors becomes quite tricky, I did notice a few file not found and path errors regarding dotNET and the registry?

 


Reg
Autodesk PDS Ultimate 2015 SP 1 Build 203
Intel Core i7 (950@3.07GHz)/Win7x64 (Home) - 12GB Ram
Nvidia GeForce GTX 560 Ti
 
Please Give Kudo's / accept as a solution if it solves your problem.
Valued Mentor
rhasell
Posts: 330
Registered: ‎05-23-2007
Message 37 of 63 (1,357 Views)

Re: Inventor 2013 extremely slow in IDW's

06-26-2012 07:32 PM in reply to: rhasell

Quick Update....

 

Did about 30 drawings this morning.

 

Still working yay!


Reg
Autodesk PDS Ultimate 2015 SP 1 Build 203
Intel Core i7 (950@3.07GHz)/Win7x64 (Home) - 12GB Ram
Nvidia GeForce GTX 560 Ti
 
Please Give Kudo's / accept as a solution if it solves your problem.
Board Manager
ChrisMitchell01
Posts: 447
Registered: ‎09-16-2005
Message 38 of 63 (1,356 Views)

Re: Inventor 2013 extremely slow in IDW's

06-26-2012 08:54 PM in reply to: rhasell

Hi Reg,


Thanks for confirming your findings; by coincidence we also noted that for certain drawings, (yours included), we are seeing better performance in the Compatibility mode, (Tools, App Options, Hardware tab for anyone else reading this).

 

We are investigating why this is the case, (since using that option essentially reverts the graphics engine to what it was a couple of releases ago), & will post an update once any definite conclusions are drawn.

 

Many Thanks,

Chris 



Chris Mitchell
Inventor Customer Engagement Team
Autodesk, Inc.

Contributor
ToreM82
Posts: 19
Registered: ‎08-22-2011
Message 39 of 63 (1,345 Views)

Re: Inventor 2013 extremely slow in IDW's

06-27-2012 12:46 AM in reply to: ChrisMitchell01

I have the same issues as discribed, but also have problems in presentation files(ipn).

 

I'll be watching this hoping for a solution!

 

PC:

Intel Xeon 2.4GHz

6GB ram

Win7 64

Nvidia quadro FX1800

Board Manager
ChrisMitchell01
Posts: 447
Registered: ‎09-16-2005
Message 40 of 63 (1,310 Views)

Re: Inventor 2013 extremely slow in IDW's

06-27-2012 11:55 AM in reply to: ToreM82

ToreM82

 

When you say you have the same problems,  can you please confirm :

 

  • Compatibility mode improves general drawing performance for you

Or

 

  • Using Bitmap mode for shaded views improves performance

What problems do you have with IPN's ? Performance or otherwise ? Are you able to share any examples ?

 

Thanks,
Chris



Chris Mitchell
Inventor Customer Engagement Team
Autodesk, Inc.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.