Inventor General Discussion

Inventor General Discussion

Reply
*Expert Elite*
karthur1
Posts: 4,198
Registered: ‎04-27-2005
Message 1 of 13 (576 Views)

Inv 2013 uses 100% CPU

576 Views, 12 Replies
05-03-2013 09:25 AM

I have an older machine that we are trying to run Inventor 2013 on.  It gets really sluggish after using it for a while.  .  With the Windows Task Manager running, when I open an empty idw sheet, Inventor uses 100% CPU just by moving the mouse around on the screen.  Of course, when I stop moving it goes back down to like 2%.

 

This machine is running XP (4GB ram).  I am running with the \3GB switch active. Processor is a Pentium4 (3Ghz). Under Control panel, System Settings>Advanced tab, I have disabled all the Windows Visual effects. Also set the virtual memory to 4Gb.

 

I have tried it changing the Inventor "Software Graphics" in Tools >App options checked and unchecked and it does the same thing.

 

The video card is a ATI Radeon X300 (128MB) with the latest driver.  The card is not the greatest (by a long shot).... I know, but we are only trying to do really simple stuff on this.

 

Any ideas on why Inventor takes so much processor just with the mouse movement?

 

Thanks

 

 

 

*Expert Elite*
mrattray
Posts: 2,481
Registered: ‎09-13-2011
Message 2 of 13 (570 Views)

Re: Inv 2013 uses 100% CPU

05-03-2013 09:55 AM in reply to: karthur1

Did it run OK with older versions of Inventor?
Does it do this with any other software?
Is windows fully updated?
Is the mouse driver up to date? (might as well check all drivers)
What shape is the hard disk in? I had a colleague who was having terrible performance on his older machine. I took a look and noticed he had <1MB (yes, MB) of free space. Cleaning up his HD helped considerably.
You could also try setting free space allocation to be managed by Windows instead of a fixed size. I generally recommend people do so, anyways. I think AutoDesk recommends it somewhere, too.

Mike (not Matt) Rattray

*Expert Elite*
karthur1
Posts: 4,198
Registered: ‎04-27-2005
Message 3 of 13 (561 Views)

Re: Inv 2013 uses 100% CPU

05-03-2013 10:13 AM in reply to: mrattray

It ran "OK with inv 2010 on it.  But this is worse.  Sometimes I have to stop what I am doing and let it "catch up".  Really annoying.

 

Doesnt do it with any other software.  With Autocad, the usage goes up to around 15% when moving the mouse around.

 

Plenty of HD space.. over 100GB free.

 

I will check the mouse driver and let windows manage the memory.

 

Thanks

Active Contributor
LorenJ
Posts: 35
Registered: ‎01-27-2009
Message 4 of 13 (537 Views)

Re: Inv 2013 uses 100% CPU

05-03-2013 01:11 PM in reply to: karthur1
Hi,

I'm not a hardware guru, but I've seen some impressive results lately from relatively inexpensive upgrades.

1) Video card performance has dramatically increased in the last couple of years. Take a look at www.videobenchmark.net/high_end_gpus They only use the PassMark test, but it gives you an idea of the relative performance of the cards.

Since you're on a budget, switch to the Price-Peformance chart. My son and I built a computer over the holidays, and he's pretty happy with the GeForce GTX 650 Ti. It's only $130 and its Performance-Price ratio is 20.64. It isn't top of the line hardware, but something in this price range should be a lot better than your current card.

2) You could also try an SSD hard drive. I mentor a high school robotics team, and their older laptops struggled with Inventor. We had to replace the hard drive in one of them, and the change was so dramatic that we upgraded all of them to SSDs. There's some serious sticker shock, but most people seem to be using smaller SSDs for their primary drive and standard drives for the rest of their data.
LorenJ
*Expert Elite*
blair
Posts: 4,034
Registered: ‎11-13-2006
Message 5 of 13 (530 Views)

Re: Inv 2013 uses 100% CPU

05-03-2013 01:33 PM in reply to: LorenJ

It's been so long since I've had to do anything with XP. Next you'll be trying NT4.0

 

  • Copy the line in YOUR “boot.ini” file that reads something like

 

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect 

 

and paste it right below the line. 

Edit the pasted line to add /3GB before /fastdetect to read like multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional (3GB)" /3GB /fastdetect

 

or

 

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional (3GB-2800)" /3GB /userva=2800 /fastdetect

 

  • Save and exit notepad

 

Did you find this reply helpful ? If so please use the Accept as Solution or Kudos button below.

IV2015 up2 PDSU / Sim Mech 2015 /
Win7-64
EVGA X79 - Classified, iCore7 3930k 32Gb Quad-Channel
950Gb (2 x 500Gb Sata III SSD RAID0 Adaptec 6805E Controller)
Nvidia GTX-690 Classified - 335.23
SpacePilot Pro 3.17.7, 6.17., 4.11
*Expert Elite*
blair
Posts: 4,034
Registered: ‎11-13-2006
Message 6 of 13 (507 Views)

Re: Inv 2013 uses 100% CPU

05-04-2013 08:29 AM in reply to: karthur1

Probably the biggest problem with XP, will be that it doesn't take advantage of DX11. If I remember correctly it only runs DX9

 

IV is a real graphics hog.

Did you find this reply helpful ? If so please use the Accept as Solution or Kudos button below.

IV2015 up2 PDSU / Sim Mech 2015 /
Win7-64
EVGA X79 - Classified, iCore7 3930k 32Gb Quad-Channel
950Gb (2 x 500Gb Sata III SSD RAID0 Adaptec 6805E Controller)
Nvidia GTX-690 Classified - 335.23
SpacePilot Pro 3.17.7, 6.17., 4.11
*Expert Elite*
karthur1
Posts: 4,198
Registered: ‎04-27-2005
Message 7 of 13 (460 Views)

Re: Inv 2013 uses 100% CPU

05-07-2013 07:31 AM in reply to: blair

Blair,

My boot.ini looks like this.

 

[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Pro /3GB" /3GB /userva=2800 /fastdetect
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

 

Systems runs good for about 10-20 minutes while working in Inventor.  Making small (really Simple) idws.  Then it begins to slow to a crawl and is unusable.  Reboot and repeat.  Don't think its a heat issue, since rebooting fixes it temporarily.

The 100% CPU usage might not be related to Inventor slowing down, that might be "normal" for 2013 running on a XP 32 bit system.

 

Kirk

*Expert Elite*
mrattray
Posts: 2,481
Registered: ‎09-13-2011
Message 8 of 13 (456 Views)

Re: Inv 2013 uses 100% CPU

05-07-2013 07:43 AM in reply to: blair
Just out of curiosity, since I've never seen it before: what does "/userva=2800 do?
Mike (not Matt) Rattray

*Expert Elite*
karthur1
Posts: 4,198
Registered: ‎04-27-2005
Message 9 of 13 (455 Views)

Re: Inv 2013 uses 100% CPU

05-07-2013 07:51 AM in reply to: mrattray

fine tuning of the memory....

 

http://support.microsoft.com/kb/316739

*Expert Elite*
blair
Posts: 4,034
Registered: ‎11-13-2006
Message 10 of 13 (447 Views)

Re: Inv 2013 uses 100% CPU

05-07-2013 08:10 AM in reply to: karthur1

I might try setting the user variable down to 2200.

 

I might even try downloading the latest mouse drivers and do a complete un-install of the mouse drivers, reboot and install of the latest version drivers.

Did you find this reply helpful ? If so please use the Accept as Solution or Kudos button below.

IV2015 up2 PDSU / Sim Mech 2015 /
Win7-64
EVGA X79 - Classified, iCore7 3930k 32Gb Quad-Channel
950Gb (2 x 500Gb Sata III SSD RAID0 Adaptec 6805E Controller)
Nvidia GTX-690 Classified - 335.23
SpacePilot Pro 3.17.7, 6.17., 4.11
Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.