Inventor General Discussion

Inventor General Discussion

Reply
Valued Contributor
Cnoj
Posts: 93
Registered: ‎11-26-2008
Message 1 of 12 (254 Views)

Inv. 2008 Thumbnails in Win7 Explorer?

254 Views, 11 Replies
08-06-2012 05:53 AM

Is there a way to make this work? I see thumbnails in the Inventor file dialogs but not in Win7 Explorer.

I'm using Win7 Enterprise 64bit and inv 2008 SP3.

 

Also my machine came with a Autodesk32bitExplorerLauncher.bat (below). Anyone know what it's for?

 

Thanks,

jon C.

 

 

Autodesk32bitExplorerLauncher.bat:

@echo off

REG QUERY "HKCU\Software\Microsoft\Internet Explorer\Main" /v "Window Title" 
if %ERRORLEVEL% EQU 0 goto :Restore 

:ECHO Delete
REG ADD "HKCU\Software\Microsoft\Internet Explorer\Main" /v "Window title" /t REG_SZ /d "Autodesk 32-bit" /f

start %windir%\SysWOW64\explorer.exe /separate 

timeout 2

REG DELETE "HKCU\Software\Microsoft\Internet Explorer\Main" /v "Window title" /f
goto :EOF

:Restore
:ECHO Restore
FOR /F "tokens=3* delims=	 " %%a IN ('REG QUERY "HKCU\Software\Microsoft\Internet Explorer\Main" /v "Window Title"') DO set Title=%%b

REG ADD "HKCU\Software\Microsoft\Internet Explorer\Main" /v "Window title" /t REG_SZ /d "Autodesk 32-bit" /f

start %windir%\SysWOW64\explorer.exe /separate 

timeout 2

:echo %Title%
REG ADD "HKCU\Software\Microsoft\Internet Explorer\Main" /v "Window title" /t REG_SZ /d "%Title%" /f


:EOF

 

 

 

*Pro
ampster
Posts: 1,239
Registered: ‎07-26-2005
Message 2 of 12 (239 Views)

Re: Inv. 2008 Thumbnails in Win7 Explorer?

08-06-2012 08:00 AM in reply to: Cnoj

works on Win7/64.  Not sure what that bat file is for.

 

CC parts don't display but user created part files show in thumbnails;

 

thumbnails.png

Valued Contributor
Cnoj
Posts: 93
Registered: ‎11-26-2008
Message 3 of 12 (233 Views)

Re: Inv. 2008 Thumbnails in Win7 Explorer?

08-06-2012 08:13 AM in reply to: ampster

 

Isn't that the 2010 icon in the corner of your thumbnails?

 

In 2008 all I get is:

 

1.gif

*Pro
ampster
Posts: 1,239
Registered: ‎07-26-2005
Message 4 of 12 (224 Views)

Re: Inv. 2008 Thumbnails in Win7 Explorer?

08-06-2012 08:38 AM in reply to: Cnoj

it's the 2011 icon.

 

Have those files in your screenshot been saved to 2008, the version you are using?

 

If they are of an older version, that is one reason the thumbnails won't show.

 

edit, let's check your Win7 folder view settings;

 

Open up Windows Explorer, then click on the "Organize" button in the upper left corner and select "Folder and Search options".

 

On the next window, click on the "View" tab.  On that screen, there should be an option to enable called "Display file icon on thumbnails"

 

Is that enabled?

Valued Contributor
Cnoj
Posts: 93
Registered: ‎11-26-2008
Message 5 of 12 (219 Views)

Re: Inv. 2008 Thumbnails in Win7 Explorer?

08-06-2012 08:45 AM in reply to: ampster

They're all generated in Inv.2008 on either XP 32 bit or Win7 64. I could see thumbnails for these files on my 32bit XP machine..

*Pro
ampster
Posts: 1,239
Registered: ‎07-26-2005
Message 6 of 12 (217 Views)

Re: Inv. 2008 Thumbnails in Win7 Explorer?

08-06-2012 08:47 AM in reply to: Cnoj

I just tried disabling that Folder option I previously mentioned and I could still see thumbnails, so that must not be the correct Win7 setting to enable thumbnails...will keep searching!

Valued Contributor
Cnoj
Posts: 93
Registered: ‎11-26-2008
Message 7 of 12 (214 Views)

Re: Inv. 2008 Thumbnails in Win7 Explorer?

08-06-2012 08:49 AM in reply to: ampster

Yup I have it enabled but it seems to make no difference.

Thanks,

Jon C.

 

*Pro
ampster
Posts: 1,239
Registered: ‎07-26-2005
Message 8 of 12 (210 Views)

Re: Inv. 2008 Thumbnails in Win7 Explorer?

08-06-2012 08:53 AM in reply to: Cnoj

have you tried a simple test of creating a new part on your Win7 pc, then check to see if you see the thumbnail for that part?

 

What does iProperties > Save tab look like for you after starting a new part file?

 

I don't believe those options changed much and you should have a "Save Preview Picture" option enabled there. 

 

 

Valued Contributor
Cnoj
Posts: 93
Registered: ‎11-26-2008
Message 9 of 12 (197 Views)

Re: Inv. 2008 Thumbnails in Win7 Explorer?

08-06-2012 10:23 AM in reply to: ampster

Yup got Save Preview Picture > Active Component Iso View on Save enabled.

 

Another thing I noticed - no iprops access via windows. In XP the properties for an inventor file had an 'iProps' button on the properties tab that let you view/edit custom iProps etc. No such button now.

 

2.gif

*Pro
ampster
Posts: 1,239
Registered: ‎07-26-2005
Message 10 of 12 (192 Views)

Re: Inv. 2008 Thumbnails in Win7 Explorer?

08-06-2012 10:30 AM in reply to: Cnoj

OK, I believe 2008 on 64bit may be the issue here but not certain.

 

I don't remember if 2008 had a problem like this, but on 64 bit systems you didn't have a Pack n Go option from Explorer back then for example.

 

Might want to look into compatibility on 64bit systems with 2008.  There might be some limitations.

 

Sorry but I don't have any other suggestions.

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.