Inventor General Discussion

Inventor General Discussion

Reply
Member
WChargin
Posts: 4
Registered: ‎12-04-2011
Message 1 of 6 (434 Views)
Accepted Solution

Inspect > AutoLimits panel missing

434 Views, 5 Replies
12-29-2011 10:05 PM

Hello,

I was recently looking at the WikiHelp entry on AutoLimits, because it sounded useful but I haven't seen it before. However, upon checking, I noticed that I don't have the AutoLimits panel in my Inspect tab. Instead, I only have the Interference (buttons: Analyze Interference; Activate Contact Solver) and Measure (buttons: Distance, Angle, Loop, Area, Region Properties) panels.

 

Just in case I'm not being clear:

 

 

I am running Autodesk Inventor Professional 2012, student edition, on a HP Pavilion dv2000, with 3GB RAM and an Intel Pentium Dual CPU (1.86GHz). My operating system is Windows 7 Professional 32-bit. I am an administrator.

Aside from this, I have encountered no problems with Inventor, from installation to use. Could someone help me with this?

 

Thanks!

 

WC

Hi WChargin, 

 

For some reason you have to turn on the Autolimits addin, in order to get it to show up on the ribbon. Go to the Tools tab and select the Add-in button and thenk click Autolimits in the add-in list, and then click the Loaded/Unloaded check box at the bottom of the dialog.

 

I'll suggest you look into Constraint Limits also, as they might be what you after for your opener assembly.

 

I hope this helps.
Best of luck to you in all of your Inventor pursuits,
Curtis
http://inventortrenches.blogspot.com

 

 

 

*Expert Elite*
Curtis_Waguespack
Posts: 2,930
Registered: ‎03-08-2006
Message 2 of 6 (424 Views)

Re: Inspect > AutoLimits panel missing

12-30-2011 07:42 AM in reply to: WChargin

Hi WChargin, 

 

For some reason you have to turn on the Autolimits addin, in order to get it to show up on the ribbon. Go to the Tools tab and select the Add-in button and thenk click Autolimits in the add-in list, and then click the Loaded/Unloaded check box at the bottom of the dialog.

 

I'll suggest you look into Constraint Limits also, as they might be what you after for your opener assembly.

 

I hope this helps.
Best of luck to you in all of your Inventor pursuits,
Curtis
http://inventortrenches.blogspot.com

 

 

 



  solution.png  Did you find this reply helpful ? If so please use the Accept as Solution or  Kudos button below.





Member
WChargin
Posts: 4
Registered: ‎12-04-2011
Message 3 of 6 (411 Views)

Re: Inspect > AutoLimits panel missing

12-30-2011 10:19 AM in reply to: Curtis_Waguespack

Thanks very much! That solved my AutoLimits issue.

 

By constraint limits, do you mean the expandable portion of the Assemble > Position > Constrain dialog that contains the options to use as a resting position, minimum, and maximum; or are you talking about something else that I don't know about?

 

Thanks!

 

WC

*Expert Elite*
Curtis_Waguespack
Posts: 2,930
Registered: ‎03-08-2006
Message 4 of 6 (402 Views)

Re: Inspect > AutoLimits panel missing

12-30-2011 10:29 AM in reply to: WChargin

Hi WChargin, 


By constraint limits, do you mean the expandable portion of the Assemble > Position > Constrain dialog that contains the options to use as a resting position, minimum, and maximum; or are you talking about something else that I don't know about?

Correct, that's what I was reffering to. For instance you could set your opener to only open to a maximum angle and only close to a minimum angle, etc. Many people find these to be more helpful than Autolimits for this kind of thing, although Autolimits can useful for other purposes as well.

 

I hope this helps.
Best of luck to you in all of your Inventor pursuits,
Curtis
http://inventortrenches.blogspot.com

 

 

 



  solution.png  Did you find this reply helpful ? If so please use the Accept as Solution or  Kudos button below.





Member
WChargin
Posts: 4
Registered: ‎12-04-2011
Message 5 of 6 (397 Views)

Re: Inspect > AutoLimits panel missing

12-30-2011 10:46 AM in reply to: Curtis_Waguespack

Curtis:

 

Thank you for that advice. I've just been looking at AutoLimits and it doesn't appear that there is a way to specify that the two bodies should simply not collide; using a Distance and setting the minimum to zero doesn't work either. Is there any way to do this?

 

I am now leaning towards what you were mentioning regarding the constraint limits; my only gripe is that I have to use the "Drive Constraint" feature until I get an interference, and then set that as the minimum angle on the arm; because of this, it won't be an exact measurement. However, it definitely works, and there aren't any collisions in the range of motion.

 

EDIT: I'm finding a discrepancy in the collision-detection feature of the Drive Constraint dialog. When I set the constraint to be driven from 67.5 to 67 @ 0.001/step, it stops at 67.379; however, when starting at 67.4, it stops at 67.375. Is there any reason for this?

 

Thanks!

 

WC

*Expert Elite*
Curtis_Waguespack
Posts: 2,930
Registered: ‎03-08-2006
Message 6 of 6 (392 Views)

Re: Inspect > AutoLimits panel missing

12-30-2011 11:00 AM in reply to: WChargin

Hi WChargin,

 

Try using Contact Sets/Solver to find the max / min:

http://inventortrenches.blogspot.com/2011/01/contact-solver.html

Here's an example of using this to find a distance:

http://inventortrenches.blogspot.com/2011/06/assembly-challenge-mating-spherical.html

 

I hope this helps.
Best of luck to you in all of your Inventor pursuits,
Curtis
http://inventortrenches.blogspot.com

 

 

 

 

 



  solution.png  Did you find this reply helpful ? If so please use the Accept as Solution or  Kudos button below.





Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.