Inventor General Discussion

Inventor General Discussion

Reply
Contributor
WernerBeek
Posts: 18
Registered: ‎03-07-2011
Message 1 of 2 (220 Views)

Ilogic rule to read out user parameter of ipart

220 Views, 1 Replies
11-01-2012 05:39 AM

Dear all,

 

I've created a main assembly containing several ipart components. With the following rule I can read the model parameters, but not the user parameters of the iparts:

 

A = Parameter("Part1:1", "d0")

 

If I create a component, insert it in the main assembly and make it an ipart afterwards, the user paremeters can be read out with help of ilogic. But if I insert the same ipart again, the user parameters can not be read out anymore. Model parameters are no problem. 

 

Does anyone have a solution?

 

Thanking you in advance,

 

Werner 

 

*Expert Elite*
mrattray
Posts: 2,517
Registered: ‎09-13-2011
Message 2 of 2 (208 Views)

Re: Ilogic rule to read out user parameter of ipart

11-01-2012 09:37 AM in reply to: WernerBeek

iLogic and iParts don't get along. You'll find many more problems like this if you continue to try to force them to coexist.

Mike (not Matt) Rattray

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are You Going To Be @ AU 2014? Feel free to drop by our AU topic post and share your plans, plug a class that you're teaching, or simply check out who else from the community might be in attendance. Ohh and don't forgot to stop by the Autodesk Help | Learn | Collaborate booths in the Exhibit Hall and meet our community team if you get a chance!