Inventor General Discussion

Inventor General Discussion

Reply
Distinguished Contributor
252 Posts
31 Kudos
Registered: ‎12-14-2008
Post 1 of 5

iLogic Content Center Replace Nuts

1275 Views, 4 Replies
06-07-2012 07:05 AM

I have the example working which will replace Bolts:

ref: http://forums.autodesk.com/t5/Autodesk-Inventor/Changing-C-C-component-Automation/td-p/2736623 

 

but swapping the code to replace nuts is giving me grief. How do you identify the content center paths?

 

ie I have tried:

 

replacer.Replace("nut:1", "Fasteners:Nuts:Hex", "ISO 8675 - M30 x 2DIN EN")
replacer.Replace("nut:1", "Fasteners:Nuts:Hex", "ISO 8675 - M30 x 2") 
replacer.Replace("nut:1", "Fasteners:Nuts:Hex ", "DIN EN 28675 M30 x 2")


ilogic_cc.PNGilogic_cc_nuts.PNG


Thanks MES
Distinguished Contributor
252 Posts
31 Kudos
Registered: ‎12-14-2008
Post 2 of 5

Re: iLogic Content Center Replace Nuts

06-14-2012 04:21 AM in reply to: MarkESmith

I now have this working  - but have failed at the next step - swapping out from a custom content center.

Possible?

Employee
959 Posts
98 Kudos
Registered: ‎02-24-2009
Post 3 of 5

Re: iLogic Content Center Replace Nuts

06-15-2012 02:22 PM in reply to: MarkESmith

Mark,

 I posted a reply at http://forums.autodesk.com/t5/Autodesk-Inventor/Changing-C-C-component-Automation/m-p/3378327, but it sounds like you're past that point.

 The code should work on a custom CC library.  Can you provide some details about the family annd member names in the custom library?  
 Although it's a custom library, are you using the parts as standard (the designer cannot modify an individual part file after he has placed it from the CC)?



Mike Deck
Software Developer
DLS - Mechanical Design
Autodesk, Inc.

Valued Contributor
63 Posts
24 Kudos
Registered: ‎12-20-2012
Post 4 of 5

Re: iLogic Content Center Replace Nuts

12-20-2012 10:23 AM in reply to: MarkESmith

 

I try to do a similar replace from content center but I keep getting an error that content center family is not found.

I have read all related posts and tried many things, im out of ideas.

 

I might do something entirely wrong or I might just have a small typo, but the result is still the same error.


Any help would be great. See attachment

 

Thanks in advance,

 

Arnold

 

Valued Contributor
63 Posts
24 Kudos
Registered: ‎12-20-2012
Post 5 of 5

Re: iLogic Content Center Replace Nuts

12-21-2012 01:39 AM in reply to: MarkESmith

Seems to be nothing more then a typo.

What I did was to add the nut in the content center to favorites. This way you can right click and rename it.

Use this to copy the foldernames and the partname so you dont have any chance of a typo. Though I didnt see any typo, it works now.

 

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are you interested in helping shape the future of the Autodesk Community? To participate in this brief usability study, please click here. Your time and input is greatly appreciated!