Inventor General Discussion

Inventor General Discussion

Distinguished Contributor
141 Posts
14 Kudos
Registered: ‎11-03-2006
Post 1 of 5

Illegal attempt to create identified child transaction...

1981 Views, 4 Replies
08-18-2010 09:07 AM

Several times lately, I have had drawings mysteriously self-corrupt like this:


I save the drawing or check it in and everything seems fine. The next time I check it out, I receive a series of error messages:  "Illegal attempt to create identified child transaction inside an unidentified transaction". Sometimes the drawing opens in the end, but often times it repeatedly crashes and I am unable to access the file at all.


These drawings are usually somewhat complex with many discrete models and parts being referenced by the views. There may be about 100 views over approximately 10 pages. Often these views are of several levels of detail or positional representations of similar assemblies. Sometimes they contain multiple states of an iAssembly. Almost all of the files are driven from Excel and/or derived from other files.


I would like to know which of these items is the likely cause of this errror so that I can resolve this in the future. I note that people have inquired about this error message several times, yet no definitive answer as to its cause has been given by the developers. Can anyone shed some light on this? Is it related to iParts, levels of detail, positional reps, derivations, excel-driven parts, etc?



Inventor 2008



Product Support
578 Posts
47 Kudos
Registered: ‎11-23-2005
Post 2 of 5

Re: Illegal attempt to create identified child transaction...

08-19-2010 05:29 PM in reply to: ad64

This error is probably caused by a defect in 2008 that happens way down deep in the code.
Could be triggered by many different workflows I suppose.


A couple of immediate things that run through my mind:

- is upgrading from 2008 to 2011 a possibility? Reason: we keep improving the code to guard against such messages.

- try to narrow down the dataset (on a backup copy of course) . 
  Reduce to 50 views and 5 pages. If you still see the problem reduce to 25 views on 2 pages etc.
- Remove parts , viewreps , posreps , break derived links etc until you no longer see the error.

- Eliminate the Vault factor. Does this happen outside the Vault environment as well (you mentioned check-in/checkout) ?

- Sometimes copying views or sheets  to a new drawing might give some relief.


I hope this gives you a clue on how to tackle such general error messages. 

Not exactly rocket science but it has helped me in the past to identify where the problem was.



11 Posts
0 Kudos
Registered: ‎11-22-2000
Post 3 of 5

Re: Illegal attempt to create identified child transaction...

04-13-2012 10:16 AM in reply to: ad64

I don't see a resolution to this query since inv 2008?. Has anyone been able to identify why this occurs? I am family of parts programming with variable parts and sub-assemblies using Inv 2012. I get the same error message (Illegal attempt to create identified child transaction...). Seems as though parts nesting is limited and gets iteslf into a recursive loop, maybe? Frustratingly, it seems at the same time, some of the parts lists misbehave. Some fields get left blank (mass calcs) in higher assies but generate OK when the variable iparts are opened on their own - Other parts list fields like part descriptions are fine in their iAssembly authoring tables but when mixed and matched (variable assies), just don't feature in parts lists?. Design variables in MDT and family tables in Pro-e were a breeze. I am forever having to overide part metadata in the Inventor parts lists. Sorry I can't make my clients IP datasets available.


Any Idea why this message....?

illegal attempt to create identified child transaction inside an unidentified transaction



Inv. 2012

Vista 64b

Distinguished Contributor
231 Posts
4 Kudos
Registered: ‎02-03-2009
Post 4 of 5

Re: Illegal attempt to create identified child transaction...

10-11-2012 02:27 AM in reply to: ad64

have this error msg while I want to inset a part to an assy...


inv 2013 bulid 170...

201 Posts
91 Kudos
Registered: ‎03-16-2009
Post 5 of 5

Re: Illegal attempt to create identified child transaction...

02-14-2013 02:12 PM in reply to: ad64

I have an iPart with 384 members in the Vault.

I “Get” a copy of the file out to my local.

I delete the factory and the members and the members folder and any related .dwf’s from Vault.

I make a modification to the file, save, then generate new members.

Then check the file back into Vault using the Inventor add in.


*I’ve used this workflow over 30 times with no problems.*


This time, there is an issue.

I cannot get the file and members back into Vault.

There aren’t any files in the Vault (that I can see) that are preventing me from checking the file in.

The “Enforce Unique File Names” is not checked.

I can check other files into the Vault without issue.


While generating members, I used to get prompted to save every member as it was created.

One thing I did notice is when generating new members on my local, I’m no longer prompted to save each member.

The file opens fine, every member activates, no red crosses, no errors.

If I run the .dwf publisher (Export .dwf) on my local, it takes forever to run and when finished I get the attached errors.


The Design Review software is up to date.

Has anyone seen or heard of this issue?



Senior Designer/Cad Administrator
Inventor 2012, w/SP2
Dell Precision T3500, Intel Xeon CPU
W3680 @3.33GHz, 16.0 GB of RAM
Microsoft Windows 7 Pro, 64 Bit Edition
Version 2009, w/SP1
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Are you interested in helping shape the future of the Autodesk Community? To participate in this brief usability study, please click here. Your time and input is greatly appreciated!