Inventor General Discussion

Inventor General Discussion

Reply
Distinguished Contributor
nstalker
Posts: 212
Registered: ‎03-16-2012
Message 1 of 1 (90 Views)

Help with creating a parametric factory asset

90 Views, 0 Replies
09-25-2013 12:39 PM

Hello,

 

I created this asset and shared it in the factory warehouse.

 

http://factorywarehouse.autodesk.com/Home#/Assets/Details?assetId=9e5ff301-795e-4662-990b-d08ae0b789...

 

It's a small frame on casters that I can change the overall length and width by editing parameters.  It works well for what I need it to do.

 

My next step is to create a Creform frame on top of it that expands with the frame as I edit the Length and Width parameters.  It seemed to be working up to a point.  I had a skeleton on it and it grew with the model.  But then as I added detail and edited the Length and Width parameters the detail started moving out into space and being disconnected from the frame.

 

I thought maybe it was because the frame was not centered on the origin.  So I did a move body and moved the frame to be centered and then started rebuilding the Creform frame on top using the Length and Width parameters to guarantee that it changed proportionate to the frame.  However it still ended up jumping all over the place.

 

Is there any way to update the origin of this frame that I have already created?  I could just start from scratch again but I was hoping there might be some tips and tricks that I was not aware of to help make this work before going back to the drawing board.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.