Inventor General Discussion

Inventor General Discussion

Reply
Active Member
TheNeek
Posts: 9
Registered: ‎06-03-2010
Message 1 of 5 (366 Views)

Harness and Cable Pins Applied to a Library Item

366 Views, 4 Replies
06-03-2010 08:21 AM
Hello All,
I'm a relatively new IV user. I'm on a Pro 2010 seat. I've walked into a rather large part library of connectors for use in our designs. I've started trying to take advantage of the Cable and Harnessing capabilities for routing inside our enclousures. The snag happens when I attempt to add pins to a library connector that I've placed in my assembly as the tutorial suggests. The Place Pin command in the Harness panel is greyed out when I double click the part to edit it.

What do I need to do to be able to place connectors from the library and be able to create harnesses in the same fashion as the tutorial depicts? Thank You.

Nic Foster
*Dennis Jeffrey
Message 2 of 5 (365 Views)

Re: Harness and Cable Pins Applied to a Library Item

06-03-2010 08:32 AM in reply to: TheNeek
The pins need to be placed on the original part BEFORE they are
authored into the CC Library and a Connector.
--
Dennis Jeffrey, Autodesk Inventor Certified Expert

Subscribe to the free "The Creative Inventor Magazine now available at:
http://teknigroup.com/CI-Subscribe-Login.asp
Active Member
TheNeek
Posts: 9
Registered: ‎06-03-2010
Message 3 of 5 (365 Views)

Re: Harness and Cable Pins Applied to a Library Item

06-03-2010 08:47 AM in reply to: TheNeek
Do I need to define the outward direction of the connector before inserting it into the library as well? I had created a new version of the connector in question and did exactly as you were suggesting. The pins went on and were present when I placed the part in my assembly but I was unable to define the outward direction of the connector when doing the Connector Authoring operation. The routing of the finished harness was skewed because the outward direction wasn't defined.

Nic
*Dennis Jeffrey
Message 4 of 5 (365 Views)

Re: Harness and Cable Pins Applied to a Library Item

06-03-2010 09:37 AM in reply to: TheNeek
Can you post the original connector before authoring? If privacy is an
issue, you can send it directly to me at djeffrey@teknigroup.com. I can
probably help you.
--
Dennis Jeffrey, Autodesk Inventor Certified Expert

Subscribe to the free "The Creative Inventor Magazine now available at:
http://teknigroup.com/CI-Subscribe-Login.asp
Active Member
TheNeek
Posts: 9
Registered: ‎06-03-2010
Message 5 of 5 (365 Views)

Re: Harness and Cable Pins Applied to a Library Item

06-03-2010 10:17 AM in reply to: TheNeek
Thanks for the offer Dennis. I answered my own question. Looks like all the harness attributes for the connector need to be defined before being saved into the library. Outward direction included. Discrete wiring to a PCB or any item that is not contained in a library can be done on the fly as the tutorial suggests.

Thanks for the help
Nic
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.