Inventor General Discussion

Inventor General Discussion

Reply
Valued Contributor
mikebelter
Posts: 96
Registered: ‎09-07-2006
Message 11 of 16 (404 Views)

Re: Frame Generator: When Changing Member Type does not update all iProperties

02-21-2011 10:54 AM in reply to: cbenner

I had logged a support request on this to get a direct answer from Autodesk in Oct 2010. They advised that there was no "fix" for it at that time.

Though Chris Benner's solution looks promising and worth a try.

 

Thanks,

Mike

*Expert Elite*
cbenner
Posts: 3,219
Registered: ‎04-06-2010
Message 12 of 16 (397 Views)

Re: Frame Generator: When Changing Member Type does not update all iProperties

02-21-2011 11:31 AM in reply to: mikebelter

We have done some research into this on our end, and I am sad to report that the same thing is happening here.  We have the "Filename" column mapped to Project. Description in the content center library, and when you place a steel member, the Description comes through as expected.  But if we go in later to change size on that member using the Frame generator's "Edit With.." command, the description does not update.

 

This sounds to me like a very reproduceable problem, since so many of us have been burned by this.  I would politely ask Autodesk to PLEASE look into this further.

ChrisB

ADSK_Expert_Elite_Icon_S_Color_Blk.png

Please use Mark Solutions!.Accept as Solution &Give Kudos!Kudos to further enhance the value of these forums. Thank you! :smileyhappy:

http://cbennertipstricks.blogspot.com/


   

*Expert Elite*
cbenner
Posts: 3,219
Registered: ‎04-06-2010
Message 13 of 16 (390 Views)

Re: Frame Generator: When Changing Member Type does not update all iProperties

02-21-2011 12:59 PM in reply to: cbenner

More info:

 

I've been messing with this problem all afternoon.  I found that if you change the steel shape altogether, (ie channel to angle), the description column updates with the new part.  But simply changing sizes within a profile family it does not.  I have tried manually entering text, manually deleting the description text, nothing makes it work.  All other iproperties that are pulled into Frame Generator through the CC family table update as expected when a part is edited or the size changed.  Part Number, Stock Number, etc.

 

Sorry, I can't figure this one out.  AD, I leave this one up to you.

ChrisB

ADSK_Expert_Elite_Icon_S_Color_Blk.png

Please use Mark Solutions!.Accept as Solution &Give Kudos!Kudos to further enhance the value of these forums. Thank you! :smileyhappy:

http://cbennertipstricks.blogspot.com/


   

Valued Mentor
jeanchile
Posts: 724
Registered: ‎11-10-2009
Message 14 of 16 (376 Views)

Re: Frame Generator: When Changing Member Type does not update all iProperties

02-21-2011 08:11 PM in reply to: cbenner

This is a bummer. I can't make anything work either. Sounds like we've exhausted all of the possibilities. There are so many posts on this board about frame generator being a joke and I didn't understand why. Most of them were old and I figured the issues had been fixed but I guess not. I am starting to see their reasoning. Yet another unfinished tool from AD in the toolbox I guess.

Inventor Professional 2013 (SP-2.3), Product Design Suite Ultimate
Desktop: Intel Core i7 3.4GHz, 16.0 GB RAM, Windows 7 Ultimate SP-1, 64-bit OS, (2) GeForce GTX 580 (331.81), Space Pilot Pro (3.16.1)
Laptop: Intel Core i7 3.9GHz, 16.0 GB RAM, Windows 7 Pro SP-1, 64-bit OS, GeForce GTX 780 (331.81), SpaceNavigator (3.17.7)
Distinguished Contributor
mbodnar
Posts: 159
Registered: ‎08-02-2006
Message 15 of 16 (288 Views)

Re: Frame Generator: When Changing Member Type does not update all iProperties

03-24-2011 08:18 PM in reply to: jeanchile

Hi

 

I am experiencing the same issue described by others on this topic and only happens on the column Description, looks like a bug to me. I have found that if you delete the FG member, then place it again, the new correct Description appears so short term solution is dont use Edit with Frame Generator.

 

It's a shame because if you have 2D notes and dimensions associated with these members, deleting them will probably delete those items as well. Makes sense for the Edit with FG to be fixed and working as it should. Also deleting and re-insertin the FG components will take slightly longer than editing.

 

Max B

Active Contributor
buffs_star
Posts: 43
Registered: ‎11-26-2003
Message 16 of 16 (94 Views)

Re: Frame Generator: When Changing Member Type does not update all iProperties

09-26-2013 06:53 PM in reply to: mikebelter

As i type this i can say we have just upgraded from inv 2010 to 2014 and to my surprise (actually lack of surprise) this is still an issue.

 

Changing the Member size does not update the Description of the part! . This has been a problem for such a long time, can it please be fixed??  , Oh by the way, if it actually has been fixed, please let me know where the patch is? I just installed Sp1 and its not in that one. !!

 

Beyond frustrated over this, its very disapointing :smileysad:

 

Anne

Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.