Inventor General Discussion

Inventor General Discussion

Reply
Contributor
12 Posts
0 Kudos
Registered: ‎04-23-2009
Post 1 of 13

Feature Recognition 2012 not working

929 Views, 12 Replies
11-02-2011 05:02 AM

This is issue in Autodesk Inventor Professional 2012. After installing Feature Recognition x64 bit 2012, its installing successfully. But its not showing in Add-in manager and is not working. So kindly suggest me in this regard.

 

Regards,

Prasanth Pakalapati

Product Support
291 Posts
12 Kudos
Registered: ‎10-29-2008
Post 2 of 13

Re: Feature Recognition 2012 not working

11-03-2011 07:56 AM in reply to: prasanthpakalapati

You may be better off posting this to the Labs email site. But in reviewing this I did notice that there are different versions of the feature recognition tool. I loaded the 2012 version and it shows in my add-ins. Another thing would be to do the installation as Local Administrator or run as Administrator

*Expert Elite*
870 Posts
129 Kudos
Registered: ‎12-04-2003
Post 3 of 13

Re: Feature Recognition 2012 not working

11-03-2011 08:11 AM in reply to: prasanthpakalapati

Hi.

Have you tried the feature recognition that already inside Autodesk Fusion?

Maria Manuela Pinho
Application Specialist
Cadtech / Asidek - Autodesk Gold Partner
Autodesk Inventor Professional 2015 | Lenovo W520
*Expert Elite*
28,632 Posts
2,129 Kudos
Registered: ‎04-20-2006
Post 4 of 13

Re: Feature Recognition 2012 not working

11-03-2011 09:13 AM in reply to: prasanthpakalapati

I just installed on 2 32-bit machines.
On one it works - on the other - nothing?

Please mark this response as "Accept as Solution" if it answers your question.
-----------------------------------------------------------------------------------------
Autodesk Inventor 2015 Certified Professional
Autodesk AutoCAD 2013 Certified Professional
Certified SolidWorks Professional
Inventor Professional 2015-SP1 64-bit
http://www.autodesk.com/edcommunity
http://home.pct.edu/~jmather/content/DSG322/inventor_surface_tutorials.htm
Valued Contributor
65 Posts
7 Kudos
Registered: ‎10-14-2008
Post 5 of 13

Re: Feature Recognition 2012 not working

12-08-2011 08:24 AM in reply to: JDMather

Hey Guys,

I think I got it to work after spending a good 3 hours on it! its simple, how stupid I was not think about it sooner, all you need to do is manually register the dll file which is located under inventor 2012\bin\featurerecognition.dll through regsvr32.exe command. how? ok, start menu, run, punch in cmd and enter, then navigate to c:\program files\autodesk\inventor 2012\bin\ and then type regsvr32 featurerecognition.dll. then it should work. make sure inventor is not running when you do this.

 

trust it helps

Sincerely

Ali

Warm Regards
New Member
1 Posts
0 Kudos
Registered: ‎06-24-2011
Post 6 of 13

Re: Feature Recognition 2012 not working

03-09-2012 02:55 AM in reply to: 3DAli

@3DAli:

 

You are a real life saver! Manually registering the dll works like a charm. Many thanks!

Best Regards,

 

Maurice

ALUMATZEEMAN

Valued Contributor
65 Posts
7 Kudos
Registered: ‎10-14-2008
Post 7 of 13

Re: Feature Recognition 2012 not working

03-11-2012 04:30 PM in reply to: info

Youre very welcome Maurice, I'm glad it helped :smileywink:

Cheers

Ali

Warm Regards
Active Member
8 Posts
0 Kudos
Registered: ‎05-16-2011
Post 8 of 13

Re: Feature Recognition 2012 not working

10-17-2012 11:25 AM in reply to: prasanthpakalapati

I have manually register the .DLL file and it shows up in the Add-in manager, but it does not show up under any of the tabs. How do I access the feature? Please help

*Expert Elite*
28,632 Posts
2,129 Kudos
Registered: ‎04-20-2006
Post 9 of 13

Re: Feature Recognition 2012 not working

10-17-2012 11:57 AM in reply to: DPLOWMAN5757

I don't see any solid features in your screen capture - only a 3D sketch?

 

Expand the feature tree here

Expand.png

Please mark this response as "Accept as Solution" if it answers your question.
-----------------------------------------------------------------------------------------
Autodesk Inventor 2015 Certified Professional
Autodesk AutoCAD 2013 Certified Professional
Certified SolidWorks Professional
Inventor Professional 2015-SP1 64-bit
http://www.autodesk.com/edcommunity
http://home.pct.edu/~jmather/content/DSG322/inventor_surface_tutorials.htm
Active Member
8 Posts
0 Kudos
Registered: ‎05-16-2011
Post 10 of 13

Re: Feature Recognition 2012 not working

10-17-2012 12:05 PM in reply to: JDMather

My problem is that I was sent a *IGS file, which comes in as wires, but I would like to convert it into a solid *.IPT

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are you interested in helping shape the future of the Autodesk Community? To participate in this brief usability study, please click here. Your time and input is greatly appreciated!