Inventor General Discussion

Reply
Distinguished Contributor
shastu
Posts: 1,814
Registered: ‎12-10-2003
Message 1 of 9 (252 Views)

Extra parts in BOM

252 Views, 8 Replies
01-15-2013 09:37 AM

Open SKS.iam which is suppose to be empty, but for some reason asks for the 14020-111.iam file.  Once it opens go to the BOM and you will see 24 of the same part in the BOM.  If you derive the SKS.iam you will see those 24 parts listed and you will even see them.  Yet when you go back to the base SKS.iam they are not visible in the browser or the windows graphic area.  What is going on?  IV 2012 sp2

*Expert Elite*
Cadmanto
Posts: 3,325
Registered: ‎12-07-2011
Message 2 of 9 (236 Views)

Re: Extra parts in BOM

01-15-2013 11:38 AM in reply to: shastu

I didn't open your file (no time), but is it possible you have something called "Virtual Parts" in this assembly?

Best Regards,
Scott McFadden
Inventor Professional 2014
(Colossians 3:23-25)

Distinguished Contributor
shastu
Posts: 1,814
Registered: ‎12-10-2003
Message 3 of 9 (234 Views)

Re: Extra parts in BOM

01-15-2013 11:40 AM in reply to: Cadmanto

Don't know.  I am not familiar with Virtual Parts.  How do I find out?

Distinguished Contributor
shastu
Posts: 1,814
Registered: ‎12-10-2003
Message 4 of 9 (230 Views)

Re: Extra parts in BOM

01-15-2013 11:52 AM in reply to: shastu

Aren't virtual parts just in your parts list?  Then no this is not coming from a Virual Part.

*Expert Elite*
Cadmanto
Posts: 3,325
Registered: ‎12-07-2011
Message 5 of 9 (222 Views)

Re: Extra parts in BOM

01-15-2013 12:04 PM in reply to: shastu

I honestly don't know.  I gave this answer based on my knowledge of Solidworks virtual parts.

I have worked with those, but the virtual parts in Inventor I have not.  I know in Solidworks they are parts

that are hidden outside of the assembly file (i.e. local or network drive).  They only show up in the assembly tree within

the session.

What I would suggest is look at the link I gave you and see if the components you are having issues with show up in the browser as virtual parts.  Maybe chech the properties of these components within this assembly and see if the reveals anything.

Best Regards,
Scott McFadden
Inventor Professional 2014
(Colossians 3:23-25)

Contributor
Kerdric81
Posts: 13
Registered: ‎11-15-2007
Message 6 of 9 (208 Views)

Re: Extra parts in BOM

01-15-2013 02:53 PM in reply to: shastu

Check the parameters in SKS.iam for any reference or linked parameters to 14020-111.iam. If there are, delete them if possible and see if that helps. I couldn't check because the .zip contains only 2 .iam files with no .ipt files. Even if SKS.iam is suppose to be empty if there a link to 14020-111.iam you'd need the part files in 14020-111 to open the SKS.iam file without gettting missing link errors. (confused yet? :smileytongue:

 

If your browser shows nothing in it then you don't have any virtual components. (Virtual components are kinda like "embedded" parts in an assembly that don't link to an external file like an .ipt or .iam. They are typically used for parts that  are needed in assemblies but can necessarily be modeled. Such as oil, grease, loc-tite, etc.)

 

Hope this helps,

 

~Derrck

*Expert Elite*
blair
Posts: 4,230
Registered: ‎11-13-2006
Message 7 of 9 (192 Views)

Re: Extra parts in BOM

01-15-2013 09:29 PM in reply to: Kerdric81

It asks for file "064466 x 4.5.ipt", looks like this was used for something else as there was a Parameter #59 in the parameter box.

 

I just created a new file that it was asking for, installed it in the drawing when updated the links (RMB) on the SKS.IAM in the top of the assembly view box. Directed it's search to the location of the required file. Allowed it to place in the IAM and then deleted the file and everything is fine.

 

I am on IV2013 so this file is not usable to you being the newer version.

Did you find this reply helpful ? If so please use the Accept as Solution or Kudos button below.

IV2015 SP1 PDSU / Sim Mech 2015 r1 /
Win7-64
EVGA X79 - Classified, iCore7 3930k 32Gb Quad-Channel
950Gb (2 x 500Gb Sata III SSD RAID0 Adaptec 6805E Controller)
Nvidia GTX-690 Classified - 340.52
SpacePilot Pro 3.17.7, 6.17., 4.11
Delta Tau Chi ΔΤΧ
Distinguished Contributor
shastu
Posts: 1,814
Registered: ‎12-10-2003
Message 8 of 9 (165 Views)

Re: Extra parts in BOM

01-16-2013 06:13 AM in reply to: blair

I have attached the ipt file.  When you say that everything is fine, are you saying that when you go to the BOM from the SKS.iam file, it is empty?  Or are there still 24 parts?  I want to remove all of those from the assembly but can't figure out how because they do not show up in the assembly.  If you derive that assembly then you can see them but still can't delete them from there.

Distinguished Contributor
shastu
Posts: 1,814
Registered: ‎12-10-2003
Message 9 of 9 (162 Views)

Re: Extra parts in BOM

01-16-2013 06:16 AM in reply to: shastu

Here,  I thought maybe a screenshot would help as well.  In the BOM there are a QTY of 24 parts but in the browser those parts do not show up.  I am wanting to delete them from the BOM>

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.