Inventor General Discussion

Inventor General Discussion

Reply
Contributor
killbox
Posts: 20
Registered: ‎01-26-2013
Message 1 of 17 (908 Views)
Accepted Solution

Edits are not allowed on this file

908 Views, 16 Replies
01-31-2013 08:34 PM

I'm using Inventor Pro 2013 as a single user (no vault).  Please see the attached error.  I was placing parts and I think I pulled one outside the project folder??  I got something about changing directories and I accepted it.  That may be what happened but I'm not sure.  I also noticed that in the projects box my project says (read only).

 

How do I get out of this?

No you don't need a library path. The reason for Libraries is to make the parts read-only. If you are working on a project and design a number of parts for that project. Another project comes along and you realize that you can use some of the parts from the first project, it would then be wise to add the folder/directory in which the first project parts reside as a directory. This still allows you to use the parts but not accidentally edit the parts.

*Expert Elite*
blair
Posts: 4,217
Registered: ‎11-13-2006
Message 2 of 17 (888 Views)

Re: Edits are not allowed on this file

01-31-2013 10:22 PM in reply to: killbox

Parts that are not in the Work Directory of the Project file and are in Libraries are write protected. If you wish to edit this file, either place it in the Work Directory as defined in the Project file or create another Project file that is used explicity to edit Library parts as this directory will now be the Work directory of the Project file

Did you find this reply helpful ? If so please use the Accept as Solution or Kudos button below.

IV2015 SP1 PDSU / Sim Mech 2015 r1 /
Win7-64
EVGA X79 - Classified, iCore7 3930k 32Gb Quad-Channel
950Gb (2 x 500Gb Sata III SSD RAID0 Adaptec 6805E Controller)
Nvidia GTX-690 Classified - 340.52
SpacePilot Pro 3.17.7, 6.17., 4.11
Delta Tau Chi ΔΤΧ
*Pro
sbixler
Posts: 1,929
Registered: ‎09-15-2003
Message 3 of 17 (870 Views)

Re: Edits are not allowed on this file

02-01-2013 04:01 AM in reply to: killbox

Your project may be read-only for two reasons that I can think of: the Windows read-only file attribute is set, or you have files open in Inventor.  Active project files are editable only when there are no files open.  (Note: for this particular purpose, you have to close all open files; undo opening a file is not the same thing in this case).

Sam B
Inventor 2012 Certified Professional

Please click "Accept as Solution" if this response answers your question.
-------------------------------------------------------------------------------------
Inventor Professional 2013 SP1.1 Update 1
Windows XP Pro 32-bit, SP3
HP EliteBook 8730w; 4 GB RAM; Core™ 2 Duo T9400 2.53 GHz; Quadro FX2700M
SpaceExplorer/SpaceNavigator NB, driver 3.7.18
still waiting for a foreshortened radius dimensioning tool in Drawing Manager

Contributor
killbox
Posts: 20
Registered: ‎01-26-2013
Message 4 of 17 (852 Views)

Re: Edits are not allowed on this file

02-01-2013 07:59 AM in reply to: sbixler

Still lost on this.  I understand that all the parts need to be in one location.  How would I know what parts are open?  Inventor has basically locked me out of my own file.  I can't do anything to it other than look at it.  I figured if a part was in the wrong location it would say part X is missing.  I could go find it or close it if I knew what it was.  This is crazy.

 

I have attached the project log.  Is there something there that would help figure this out?  Is there a way to reset the entire file? 

*Pro
sbixler
Posts: 1,929
Registered: ‎09-15-2003
Message 5 of 17 (847 Views)

Re: Edits are not allowed on this file

02-01-2013 08:10 AM in reply to: killbox

In your project, click the + sign next to Libraries.  Any folder in that list, while this project is active, is read-only for Inventor.  So, according to the error message you are receiving, the file you are trying to edit is in one of those folders.  As Blair pointed out, you either have to move the file out of the folder, or change the designation of the folder as a Library.  To change the designation of the folder, either edit your project and remove it from the Libraries list, or change to a different project that doesn't have it marked as a library.

 

The problem is not with your file.  It's just that you are not yet familiar with how projects work in Inventor and what they can do for you.  Your file is in a protected location, so you can't edit it, which is what libraries are for.  But this is all controlled by the project file.

Sam B
Inventor 2012 Certified Professional

Please click "Accept as Solution" if this response answers your question.
-------------------------------------------------------------------------------------
Inventor Professional 2013 SP1.1 Update 1
Windows XP Pro 32-bit, SP3
HP EliteBook 8730w; 4 GB RAM; Core™ 2 Duo T9400 2.53 GHz; Quadro FX2700M
SpaceExplorer/SpaceNavigator NB, driver 3.7.18
still waiting for a foreshortened radius dimensioning tool in Drawing Manager

Contributor
killbox
Posts: 20
Registered: ‎01-26-2013
Message 6 of 17 (834 Views)

Re: Edits are not allowed on this file

02-01-2013 09:27 AM in reply to: sbixler

I've attached a picture of my files and folders.  I have done a "save as" in the past.  The original file was called "frame_skel" then "frame_skel_error".  It is now named "cnc_table"  but I don't see a folder for that.  It this the problem?  Also, the "frame_skel_error" folder is empty.  Not sure why it's there.

 

Is it a bad idea to do a "save as"?  I do this from time to time to be able to go back to a old version.  At this point could I just save this assembly in another folder and start fresh?

*Pro
sbixler
Posts: 1,929
Registered: ‎09-15-2003
Message 7 of 17 (820 Views)

Re: Edits are not allowed on this file

02-01-2013 10:12 AM in reply to: killbox

This doesn't appear to be a Library issue-- in fact your Libraries both show red (not found).  But I see you have another project called Autoloader-- are you using Vault?  If so, there might be something in your setup there, but I have no experience with Vault, so can't help.

 

But, one more thing to check in the project file: Content Center files.  Look in the Folder Options-- if it gives a folder path, what is it?  If it says [Default], what is the folder path in Application Options > File > Default Content Center files?  The reason I'm asking is because this location is treated the same as a Library-- uneditable.

Sam B
Inventor 2012 Certified Professional

Please click "Accept as Solution" if this response answers your question.
-------------------------------------------------------------------------------------
Inventor Professional 2013 SP1.1 Update 1
Windows XP Pro 32-bit, SP3
HP EliteBook 8730w; 4 GB RAM; Core™ 2 Duo T9400 2.53 GHz; Quadro FX2700M
SpaceExplorer/SpaceNavigator NB, driver 3.7.18
still waiting for a foreshortened radius dimensioning tool in Drawing Manager

*Expert Elite*
mrattray
Posts: 2,507
Registered: ‎09-13-2011
Message 8 of 17 (817 Views)

Re: Edits are not allowed on this file

02-01-2013 10:19 AM in reply to: killbox

Are we sure none of the files got marked as read-only in Windows?

Mike (not Matt) Rattray

*Expert Elite*
blair
Posts: 4,217
Registered: ‎11-13-2006
Message 9 of 17 (808 Views)

Re: Edits are not allowed on this file

02-01-2013 10:32 AM in reply to: killbox

Inventor keeps old versions in the "Old Versions" inside each work directory with a version number inserted between the file name and extension name.

Did you find this reply helpful ? If so please use the Accept as Solution or Kudos button below.

IV2015 SP1 PDSU / Sim Mech 2015 r1 /
Win7-64
EVGA X79 - Classified, iCore7 3930k 32Gb Quad-Channel
950Gb (2 x 500Gb Sata III SSD RAID0 Adaptec 6805E Controller)
Nvidia GTX-690 Classified - 340.52
SpacePilot Pro 3.17.7, 6.17., 4.11
Delta Tau Chi ΔΤΧ
*Pro
sbixler
Posts: 1,929
Registered: ‎09-15-2003
Message 10 of 17 (797 Views)

Re: Edits are not allowed on this file

02-01-2013 10:45 AM in reply to: killbox

How about this: try editing your project file (close all files first) and remove the two Library paths.  They show red, indicating (I think) that they are not found or are otherwise invalid.  But one of them has the same name as the folder you are working in, so perhaps Inventor has it tagged as an uneditable.

Sam B
Inventor 2012 Certified Professional

Please click "Accept as Solution" if this response answers your question.
-------------------------------------------------------------------------------------
Inventor Professional 2013 SP1.1 Update 1
Windows XP Pro 32-bit, SP3
HP EliteBook 8730w; 4 GB RAM; Core™ 2 Duo T9400 2.53 GHz; Quadro FX2700M
SpaceExplorer/SpaceNavigator NB, driver 3.7.18
still waiting for a foreshortened radius dimensioning tool in Drawing Manager

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.