Inventor General Discussion

Inventor General Discussion

Reply
Distinguished Contributor
brent.e.barbour
Posts: 132
Registered: ‎10-22-2003
Message 1 of 6 (372 Views)

Editing Inventor library parts stored in Vault

372 Views, 5 Replies
09-27-2006 09:04 AM
What’s the best strategy for editing Inventor library parts stored in Vault. I’ve created a separate project just for library parts in the past when multi-user mode was still an option. Is there a preferred way to do it in the vault now?
*Rich Willis \(Autodesk\)
Message 2 of 6 (372 Views)

Re: Editing Inventor library parts stored in Vault

11-06-2006 03:22 PM in reply to: brent.e.barbour
Go to Start/All Programs/Autodesk/Autodesk Data Management/Autodesk Vault
Manager and login as Administrator. RMB on Libraries and select Create
Library. Enter a Library name and click OK. Now go to your project file in
Inventor and in the lower right corner, select the Configure Content Center
Libraries. In this dialog, select Add Library. In the Add Library dialog,
you should see your newly created Library name. Select it and click OK.
Notice this new library is Read/Write enabled. Click OK again. Now in
Inventor go to Tools/Content Center Editor. Notice everything is grayed
because all content is READ ONLY. RMB on the family you wish to be able to
edit and select Copy To and in the flyout select the new library. In the
Library View pulldown, select your library. you will now have a list of
your editable library parts.

Hope this helps.

--
Rich Willis (Autodesk)


wrote in message news:5342648@discussion.autodesk.com...
What's the best strategy for editing Inventor library parts stored in Vault.
I've created a separate project just for library parts in the past when
multi-user mode was still an option. Is there a preferred way to do it in
the vault now?
Distinguished Contributor
brent.e.barbour
Posts: 132
Registered: ‎10-22-2003
Message 3 of 6 (372 Views)

Re: Editing Inventor library parts stored in Vault

11-07-2006 07:16 AM in reply to: brent.e.barbour
I was able to follow you up to where I click "Add Library" in the "Configure Content Center" dialog box. I get an error message that reads "Unable to retrieve library information from specified server." I'm confused. I'm logged into the vault as administrator in Vault Explorer and Inventor. I have the project file checked out. I have two Libraries in the Vault; the original one I created way back when I first started transferring everything over to the vault, and a new one per your instruction to see if that makes a difference. Where do I go from here?


Thanks,
Brent
Distinguished Contributor
pkquat
Posts: 2,530
Registered: ‎02-03-2004
Message 4 of 6 (372 Views)

Re: Editing Inventor library parts stored in Vault

11-07-2006 07:48 AM in reply to: brent.e.barbour
Since you are still looking at this, you should probably look at these threads and others on Content Center (CC)

http://discussion.autodesk.com/thread.jspa?threadID=517250

http://discussion.autodesk.com/thread.jspa?threadID=514248

There are many here who shy away from CC.

We use iParts. Needless to say iParts and Vault are another headache in themselves.

To make changes with iParts, you need to create a non-Vault Project (Library-Edit) that directly accessed the library folders as a workspace.

When adding Vault to the mix, you need to check out the parent in Vault., switch to the Library-Edit Project, and update the parent, then create or use an existing dummy assembly to update all the children. Switch back to the Vault project, open that assembly, check out all the children, make sure they have all updated properly, then check in all the children and parent.

There are a few posts in the Vault discussion group about this. One or two have some good general information papers on Vault and Libraries which were MUCH better than help and documentation that came with Vault 4.

Pete
*Rich Willis \(Autodesk\)
Message 5 of 6 (372 Views)

Re: Editing Inventor library parts stored in Vault

11-07-2006 02:33 PM in reply to: brent.e.barbour
Brent,
Try closing out of the Vault Explorer. Make sure your project file is
checked out, then go to the project file and try to Configure Content Center
again.

--
Rich Willis (Autodesk)


wrote in message news:5387605@discussion.autodesk.com...
I was able to follow you up to where I click "Add Library" in the "Configure
Content Center" dialog box. I get an error message that reads "Unable to
retrieve library information from specified server." I'm confused. I'm
logged into the vault as administrator in Vault Explorer and Inventor. I
have the project file checked out. I have two Libraries in the Vault; the
original one I created way back when I first started transferring everything
over to the vault, and a new one per your instruction to see if that makes a
difference. Where do I go from here?


Thanks,
Brent
Distinguished Contributor
brent.e.barbour
Posts: 132
Registered: ‎10-22-2003
Message 6 of 6 (372 Views)

Re: Editing Inventor library parts stored in Vault

11-08-2006 07:32 AM in reply to: brent.e.barbour
I rebooted my computer and opened Inventor only without opening Vault Explorer. I logged into the Data Management Server as Administrator. I verified the project file was checked out to me. I opened the project window. Then I opened the "Configure Content Center" dialog box. When I click "Add Library," I still get the same error "Unable to
retrieve library information from specified server." I'm running Inv 11, SP2. Do you have any more suggestions?
Announcements
Are you familiar with the Autodesk Expert Elites? The Expert Elite program is made up of customers that help other customers by sharing knowledge and exemplifying an engaging style of collaboration. To learn more, please visit our Expert Elite website.
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.