Inventor General Discussion

Inventor General Discussion

Reply
Contributor
Ross33
Posts: 18
Registered: ‎06-23-2011
Message 1 of 13 (3,634 Views)

Drawings will not update with part

3634 Views, 12 Replies
10-03-2011 04:25 PM

I am having some issues concerning updating drawings. When a part (.IPT) is placed in a drawing, everything is fine (ie. the views represented in the drawing are up-to-date). Yet, when I make a change to the part (something as small as a dimensional change) it does not translate through to the drawing. This is also the case for iProperties.

 

I have been playing around for a while now, but have had no luck. The part is also an iPart, but this shouldn't matter.

 

If nayone knows why this is happening I'd love to here.

 

Thanks,

Ross.

*Expert Elite*
JDMather
Posts: 28,254
Registered: ‎04-20-2006
Message 2 of 13 (3,632 Views)

Re: Drawings will not update with part

10-03-2011 04:34 PM in reply to: Ross33

Attach files here.

Please mark this response as "Accept as Solution" if it answers your question.
-----------------------------------------------------------------------------------------
Autodesk Inventor 2015 Certified Professional
Autodesk AutoCAD 2013 Certified Professional
Certified SolidWorks Professional
Inventor Professional 2015-SP1 64-bit
http://www.autodesk.com/edcommunity
http://home.pct.edu/~jmather/content/DSG322/inventor_surface_tutorials.htm
*Expert Elite*
blair
Posts: 4,491
Registered: ‎11-13-2006
Message 3 of 13 (3,613 Views)

Re: Drawings will not update with part

10-03-2011 10:30 PM in reply to: Ross33

Is your drawing set to defer updates?

Did you find this reply helpful ? If so please use the Accept as Solution or Kudos button below.

IV2015 SP1 PDSU / Sim Mech 2015 r1 /
Win7-64
EVGA X79 - Classified, iCore7 3930k 32Gb Quad-Channel
950Gb (2 x 500Gb Sata III SSD RAID0 Adaptec 6805E Controller)
Nvidia GTX-690 Classified - 344.75
SpacePilot Pro 10.2.0 / 17.2.0.11011 / 4.17
Delta Tau Chi ΔΤΧ
Contributor
Ross33
Posts: 18
Registered: ‎06-23-2011
Message 4 of 13 (3,609 Views)

Re: Drawings will not update with part

10-03-2011 11:31 PM in reply to: blair

I also thought 'Defer Updates' may have been the issue, but it is not checked.

Active Contributor
drlamb
Posts: 48
Registered: ‎11-24-2009
Message 5 of 13 (3,596 Views)

Re: Drawings will not update with part

10-04-2011 04:57 AM in reply to: Ross33

ake sure your drawing view is set to associative.

Donald L.

Inventor Product Design Suite Premium 2014
Windows 7 Professional - 64 bit
HP h8-1380t - i7-3820 @ 3.6 GHz
10 Gb
AMD Radeon HD7950 3Gb
*Expert Elite*
mcgyvr
Posts: 7,248
Registered: ‎12-01-2004
Message 6 of 13 (3,586 Views)

Re: Drawings will not update with part

10-04-2011 05:32 AM in reply to: drlamb

Since its an ipart try a rebuild all in the ipart factory. Autodesk knows about this bug but doesn't seem to want to fix it.

Did you find this reply helpful ? If so please use the Accept as Solution or Kudos button below.

-------------------------------------------------------------------------------------
2015 Product Design Suite Ultimate
Windows 7 64 bit
Core i7 4820k processor (OC'd to 4.4Ghz), Nvidia GTX 770, 16G RAM


Contributor
Ross33
Posts: 18
Registered: ‎06-23-2011
Message 7 of 13 (3,561 Views)

Re: Drawings will not update with part

10-04-2011 03:42 PM in reply to: drlamb

I don't seem to have the option to 'set to associative'.

My 'drawing view' is not the same as shown in your image.

 

Also, I have tried updating all iParts within the family, but this has not helped.

*Expert Elite*
JDMather
Posts: 28,254
Registered: ‎04-20-2006
Message 8 of 13 (3,556 Views)

Re: Drawings will not update with part

10-04-2011 03:47 PM in reply to: Ross33

Ross33 wrote:

I don't seem to have the option to 'set to associative'.

My 'drawing view' is not the same as shown in your image.

 


 

I don't see where you ever stated what version of Inventor you are using?
Attach the files here.

 

Please mark this response as "Accept as Solution" if it answers your question.
-----------------------------------------------------------------------------------------
Autodesk Inventor 2015 Certified Professional
Autodesk AutoCAD 2013 Certified Professional
Certified SolidWorks Professional
Inventor Professional 2015-SP1 64-bit
http://www.autodesk.com/edcommunity
http://home.pct.edu/~jmather/content/DSG322/inventor_surface_tutorials.htm
Contributor
Ross33
Posts: 18
Registered: ‎06-23-2011
Message 9 of 13 (3,549 Views)

Re: Drawings will not update with part

10-04-2011 04:14 PM in reply to: JDMather

My apologies. I am using Inventor 2010.

*Expert Elite*
mcgyvr
Posts: 7,248
Registered: ‎12-01-2004
Message 10 of 13 (3,523 Views)

Re: Drawings will not update with part

10-05-2011 07:02 AM in reply to: Ross33

Ross33 wrote:

I don't seem to have the option to 'set to associative'.

My 'drawing view' is not the same as shown in your image.

 

Also, I have tried updating all iParts within the family, but this has not helped.


Not updating.. Rebuild all (its on the "manage" tab in the "update" section)

With all iparts I now have an ilogic rule to rebuild all before save. It works around this issue since Autodesk won't fix it.

A similar thing happens when you add design view reps to iassemblies.. They won't show up in the drawing edit view dialog until you rebuild all in the iassy.

Did you find this reply helpful ? If so please use the Accept as Solution or Kudos button below.

-------------------------------------------------------------------------------------
2015 Product Design Suite Ultimate
Windows 7 64 bit
Core i7 4820k processor (OC'd to 4.4Ghz), Nvidia GTX 770, 16G RAM


Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.