Inventor General Discussion

Inventor General Discussion

Reply
Contributor
aaron.seifert
Posts: 23
Registered: ‎08-04-2009
Message 1 of 11 (1,117 Views)

Decals in Assemblies

1117 Views, 10 Replies
08-06-2012 09:36 AM

Autodesk Wiki Help says this: "Decals may be stocked and have part numbers. If this is a requirement, consider creating the decal in its own part file. You can then insert it into an assembly and use assembly constraints to position it."  Now this is possible but you can not wrap or face the decal in the assembly mode, let say on a piece of pipe.  The only way to wrap of face is modifying a part, adding the decal, but then you don't get a part number in a BOM because its not a separate part. Does anyone have a solution?

*Expert Elite*
Curtis_Waguespack
Posts: 3,002
Registered: ‎03-08-2006
Message 2 of 11 (1,110 Views)

Re: Decals in Assemblies

08-06-2012 10:03 AM in reply to: aaron.seifert

Hi aaron.seifert,

 

I prefer to handle this with an iPart factory. Attached is a simple example. The wrap diameter is set when placing the part into an assembly.

 

I hope this helps.
Best of luck to you in all of your Inventor pursuits,
Curtis
http://inventortrenches.blogspot.com



  solution.png  Did you find this reply helpful ? If so please use the Accept as Solution or  Kudos button below.





Contributor
CNewman
Posts: 11
Registered: ‎05-22-2012
Message 3 of 11 (1,022 Views)

Re: Decals in Assemblies

10-17-2012 08:04 AM in reply to: Curtis_Waguespack

Hi Curtis,

 

I realise this is an old(ish) post but I have used your method to create a label (in an ipart) however when I add it into the assembly the graphics don't actually show the label. Is there any way to get this to show?

 

Thanks,

 

Chris

Autodesk Product Design Suite 2013
Win 7 Professional 32bit
Intel(R) Xeon(R) W3565 @ 3.2GHz QC
4.0 GB Ram
1GB Nvidia Quadro 2000
*Expert Elite*
Curtis_Waguespack
Posts: 3,002
Registered: ‎03-08-2006
Message 4 of 11 (1,008 Views)

Re: Decals in Assemblies

10-17-2012 08:46 AM in reply to: CNewman

Hi CNewman,

 

My apologies for the misinformation.

 

My focus when creating this post must have been on the changing of the diameter and getting the part number in the BOM, more so than the image.

 

The image will not show in the iPart member files as you've noticed, because iParts are essentially derived parts, and the  derived part tools do not support image decals.

 

Honestly, I use a variety of workarounds to get the results we need for this when showing an image is needed, but I doubt any of them are too practical. For the most part we use this iPart approach for numbered labels where the text and logo are extruded features, and it works well. Even when we use an image decal, our focus is on getting the correct part number of the label in the BOM.

 

I hope this helps.
Best of luck to you in all of your Inventor pursuits,
Curtis
http://inventortrenches.blogspot.com



  solution.png  Did you find this reply helpful ? If so please use the Accept as Solution or  Kudos button below.





Contributor
CNewman
Posts: 11
Registered: ‎05-22-2012
Message 5 of 11 (977 Views)

Re: Decals in Assemblies

10-18-2012 12:42 AM in reply to: Curtis_Waguespack

Thanks Curtis,

 

I half expected as much as there seems to be a fair bit you cannot show/use when using iParts. I'm pretty new to Inventor (as a seasoned ProEngineer user) so it's all a bit of a learning curve for me at the moment but we're getting there.

 

Appreciate your help though.

 

Regards, Chris

Autodesk Product Design Suite 2013
Win 7 Professional 32bit
Intel(R) Xeon(R) W3565 @ 3.2GHz QC
4.0 GB Ram
1GB Nvidia Quadro 2000
*Expert Elite*
sam_m
Posts: 638
Registered: ‎11-05-2003
Message 6 of 11 (970 Views)

Re: Decals in Assemblies

10-18-2012 01:48 AM in reply to: CNewman

instead of using iParts could you get the same result by using the export (and linked) parameters?

 

presumably the parent pipe's diameter is a value in its parameter table, if so then set it to export.

 

for the decal, create a new file and goto the parameter table and "link" pointing to the parent ipt and select the exported value (has a v small green arrow over the x in the collumn).  Use this as the inner diameter of a curved label and extrude the label's dimensions and decal the image wrapped to that.

 

now have 2 parts (for the BOM) linked without iparts.  Or have I missed something?

----------
Please mark this response as "Accept as Solution" if it answers your question...
but please understand that the solution may not be the answer you're wanting to hear...

If you have found any post to be helpful, even if it's not a direct solution, then please provide that author kudos - spread that love :smileyvery-happy:

Lithium - helping nntp users with mania, depression and headaches
Contributor
CNewman
Posts: 11
Registered: ‎05-22-2012
Message 7 of 11 (933 Views)

Re: Decals in Assemblies

10-19-2012 05:14 AM in reply to: sam_m

Thanks for your suggestion, i'll have to have a play with this and see if I can't find something that will work for us.

Autodesk Product Design Suite 2013
Win 7 Professional 32bit
Intel(R) Xeon(R) W3565 @ 3.2GHz QC
4.0 GB Ram
1GB Nvidia Quadro 2000
Member
Bob.Shearer
Posts: 5
Registered: ‎04-18-2013
Message 8 of 11 (784 Views)

Re: Decals in Assemblies

04-18-2013 06:06 AM in reply to: aaron.seifert

I thought that you could only place a decal on a part, not assembly? How can you place it into an assembly?

 

*Expert Elite*
mcgyvr
Posts: 7,248
Registered: ‎12-01-2004
Message 9 of 11 (778 Views)

Re: Decals in Assemblies

04-18-2013 06:13 AM in reply to: Bob.Shearer

Bob.Shearer wrote:

I thought that you could only place a decal on a part, not assembly? How can you place it into an assembly?

 




You can simply create a new part...extrude a surface the same size as the decal, attach a decal image to it and save that as a part..then place that part into any assembly.

Did you find this reply helpful ? If so please use the Accept as Solution or Kudos button below.

-------------------------------------------------------------------------------------
2015 Product Design Suite Ultimate
Windows 7 64 bit
Core i7 4820k processor (OC'd to 4.4Ghz), Nvidia GTX 770, 16G RAM


Member
Bob.Shearer
Posts: 5
Registered: ‎04-18-2013
Message 10 of 11 (758 Views)

Re: Decals in Assemblies

04-18-2013 08:05 AM in reply to: mcgyvr

I am not sure I follow you. In the assemblies I am refering to are stencils that need to show up in the drawing for electrical designations. If I make an extruded surface and create a new part, I am not sure how I can get that to show

in the assembly.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.