Inventor General Discussion

Reply
Distinguished Contributor
mmiller1
Posts: 368
Registered: ‎12-03-2003
Message 1 of 6 (69 Views)

Custom iPart Problem

69 Views, 5 Replies
11-18-2002 11:37 PM
Hi Group,

I need to make a custom iPart. I know how to use iParts but I am having trouble with this one. When
I place this custom iPart in my assembly it comes in as "Part3.ipt" which is not the correct name. I
need to name this a part number like 7-55545-002 instead of "Part3.ipt". How can I get the Custom
iPart factory to ask me to "name" the part. I have already made the filename a "key" in the table
but it does not prompt me. What should I do?

Thanks,
*Dotson, Sean
Message 2 of 6 (69 Views)

Re: Custom iPart Problem

11-18-2002 11:51 PM in reply to: mmiller1
AFAIK with custom iParts you cannot specify a
filename.  It will always ask you and will default o the next default part
name (e.g. part1, part2 etc..)

--
Sean Dotson, PE

href="http://www.sdotson.com">http://www.sdotson.com

...sleep is for the
weak..
-----------------------------------------


style="PADDING-RIGHT: 0px; PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #000000 2px solid; MARGIN-RIGHT: 0px">
Hi
Group,

I need to make a custom iPart. I know how to use iParts but I am having
trouble with this one. When
I place this custom iPart in my assembly it
comes in as "Part3.ipt" which is not the correct name. I
need to name this
a part number like 7-55545-002 instead of "Part3.ipt". How can I get the
Custom
iPart factory to ask me to "name" the part. I have already made the
filename a "key" in the table
but it does not prompt me. What should I do?

Thanks,

*Germer, Ole
Message 3 of 6 (69 Views)

Re: Custom iPart Problem

11-18-2002 11:54 PM in reply to: mmiller1
the way to do it is to add filename in the last
window of the table and add filename

now go to the excel sheet and change the filename
to filename<filename></filename>

that should fix it -- of course you will have to
add the appropriate info in that column

 


Sean has some good tutorials on the
subject

 


 

 

style="PADDING-RIGHT: 0px; PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #000000 2px solid; MARGIN-RIGHT: 0px">
Hi
Group,

I need to make a custom iPart. I know how to use iParts but I am having
trouble with this one. When
I place this custom iPart in my assembly it
comes in as "Part3.ipt" which is not the correct name. I
need to name this
a part number like 7-55545-002 instead of "Part3.ipt". How can I get the
Custom
iPart factory to ask me to "name" the part. I have already made the
filename a "key" in the table
but it does not prompt me. What should I do?

Thanks,

*Dotson, Sean
Message 4 of 6 (69 Views)

Re:

11-19-2002 12:04 AM in reply to: mmiller1
Ole, this works for standard iParts but unless I'm
missing something you cannot specify a filename with Custom iparts (where one
parameter is left to be specified by the user) e.g. one of the structural
channel iparts..


--
Sean Dotson, PE

href="http://www.sdotson.com">http://www.sdotson.com

...sleep is for the
weak..
-----------------------------------------


style="PADDING-RIGHT: 0px; PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #000000 2px solid; MARGIN-RIGHT: 0px">

the way to do it is to add filename in the last
window of the table and add filename

now go to the excel sheet and change the filename
to filename<filename></filename>

that should fix it -- of course you will have to
add the appropriate info in that column

 


Sean has some good tutorials on the
subject

 


 

 

style="PADDING-RIGHT: 0px; PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #000000 2px solid; MARGIN-RIGHT: 0px">
Hi
Group,

I need to make a custom iPart. I know how to use iParts but I am having
trouble with this one. When
I place this custom iPart in my assembly it
comes in as "Part3.ipt" which is not the correct name. I
need to name
this a part number like 7-55545-002 instead of "Part3.ipt". How can I get
the Custom
iPart factory to ask me to "name" the part. I have already
made the filename a "key" in the table
but it does not prompt me. What
should I do?

Thanks,

*Keller, Kent
Message 5 of 6 (69 Views)

Re: Custom iPart Problem

11-19-2002 12:55 AM in reply to: mmiller1
Just to add .... when you place the part in the dialog notice there is a Browse button.
Simply click on it, give your part a name and make sure it is pointed to the right
directory.

--
Kent
Member of the Autodesk Discussion Forum Moderator Program


"mmiller" wrote in message news:f124db8.-1@WebX.maYIadrTaRb...
> Hi Group,
> I need to make a custom iPart. I know how to use iParts but I am having trouble with
this one. When
> I place this custom iPart in my assembly it comes in as "Part3.ipt" which is not the
correct name. I
> need to name this a part number like 7-55545-002 instead of "Part3.ipt". How can I get
the Custom
> iPart factory to ask me to "name" the part. I have already made the filename a "key" in
the table
> but it does not prompt me. What should I do?
>
> Thanks,
>
*Maas, Karl
Message 6 of 6 (69 Views)

Re:

11-19-2002 09:55 PM in reply to: mmiller1
Thanks Kent, I somehow overlooked that and that was one of my biggest beefs
about Custom iParts. Now if I can remember to do that instead of clicking
through so fast.

--
K


"Kent Keller" wrote in message
news:44F9F0B518B94757B27647963AC0BAD2@in.WebX.maYIadrTaRb...
> Just to add .... when you place the part in the dialog notice there is a
Browse button.
> Simply click on it, give your part a name and make sure it is pointed to
the right
> directory.
>
> --
> Kent
> Member of the Autodesk Discussion Forum Moderator Program
>
>
> "mmiller" wrote in message
news:f124db8.-1@WebX.maYIadrTaRb...
> > Hi Group,
> > I need to make a custom iPart. I know how to use iParts but I am having
trouble with
> this one. When
> > I place this custom iPart in my assembly it comes in as "Part3.ipt"
which is not the
> correct name. I
> > need to name this a part number like 7-55545-002 instead of "Part3.ipt".
How can I get
> the Custom
> > iPart factory to ask me to "name" the part. I have already made the
filename a "key" in
> the table
> > but it does not prompt me. What should I do?
> >
> > Thanks,
> >
>
>
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.