Inventor General Discussion

Inventor General Discussion

Reply
Member
4 Posts
0 Kudos
Registered: ‎06-29-2011
Post 1 of 3

Changing iFeature instances in parts after updating table driven iFeature

147 Views, 2 Replies
10-02-2012 03:05 PM

Hi,

 

I noticed some errors in certain table entries in an iFeature of mine after I had already started creating parts using it. I've updated the table and when I add new instances of the feature to my part they work fine, but the existing instances of it stay the same size. Is there any way to force the existing instances to update?

 

The iFeature in question is a sketch and I'm using Inventor 2012, if either of those is relevant.

 

Thanks!

*Expert Elite*
3,386 Posts
1,278 Kudos
Registered: ‎12-07-2011
Post 2 of 3

Re: Changing iFeature instances in parts after updating table driven iFeature

10-03-2012 06:38 AM in reply to: gerry.salinas

Did you try using the rebuild command?

rebuild.JPG

Also if you are using these iparts in assemblies you might want to regenerate the iparts.

Best Regards,
Scott McFadden
Inventor Professional 2014
(Colossians 3:23-25)

Member
4 Posts
0 Kudos
Registered: ‎06-29-2011
Post 3 of 3

Re: Changing iFeature instances in parts after updating table driven iFeature

10-03-2012 11:00 AM in reply to: Cadmanto

Yes, rebuild doesn't seem to help.

Is any part with an iFeature automatically an iPart? My parts just have slots in them based on a sketch which is an iFeature.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Are you interested in helping shape the future of the Autodesk Community? To participate in this brief usability study, please click here. Your time and input is greatly appreciated!