Inventor General Discussion

Inventor General Discussion

Reply
Mentor
BarryZA
Posts: 186
Registered: ‎08-27-2012
Message 1 of 8 (285 Views)
Accepted Solution

BOM all levels greyed out

285 Views, 7 Replies
11-27-2013 03:30 AM

First I do this:

 

BOM1.png

 

then I open a new drawing, put down my assembly and get this:

 

BOM2.png

 

They say a picture says a thousand words, and after countless re-tries I'll let them do the talking. That way there's no swearing involved :cathappy:

No, it's not new.
You do not "do this", it's something that gets done for you.

But maybe i'm not clear enough or i'm missing something...

So for clarity:
1. in the assembly open the Bill of Materials.
2. check if the Structured tab is enabled.
(like barry's first image)

If it's enabled like that, when you place a Parts list on the drawing the option for selecting "all levels" will be greyed out.

To see what i meant by my quote do the following:

1. in the assembly open the Bill of Materials and make sure the Structured and the Parts only tabs are disabled. (no lists shown)
2. go to the idw and place a parts list, you should now have the option to select which kind of BOM view you want.

Hope this is more clear...
*Pro
jletcher
Posts: 1,976
Registered: ‎05-18-2011
Message 2 of 8 (277 Views)

Re: BOM all levels greyed out

11-27-2013 03:57 AM in reply to: BarryZA

Do you have any balloons on the assembly?

 

 If you do you will have to delete them then you will have control again.


Please mark this response as "Accept as Solution" if it answers your question.

James Letcher
2012 Factory Design Suite ( will not load 2013)
What happen to my Inventor :-(
*Expert Elite*
-niels-
Posts: 1,579
Registered: ‎06-20-2006
Message 3 of 8 (272 Views)

Re: BOM all levels greyed out

11-27-2013 04:09 AM in reply to: BarryZA
For as far as i can see everything is in order.
If you set "all levels" in the BOM then the part list will take the settings from the model.

The only time when you can select "all levels" when placing a parts list is if you haven't activated it in the model yet.

Any changes after placement/activation need to be done in the BOM anyway, so your workflow seems fine to me.

Using IV2014 Pro SP2 - upd.1, Win7-64bit
*Pro
jletcher
Posts: 1,976
Registered: ‎05-18-2011
Message 4 of 8 (267 Views)

Re: BOM all levels greyed out

11-27-2013 04:45 AM in reply to: -niels-

The only time when you can select "all levels" when placing a parts list is if you haven't activated it in the model yet.

 

  Never had to do this before is this new in 2014?


Please mark this response as "Accept as Solution" if it answers your question.

James Letcher
2012 Factory Design Suite ( will not load 2013)
What happen to my Inventor :-(
Mentor
BarryZA
Posts: 186
Registered: ‎08-27-2012
Message 5 of 8 (266 Views)

Re: BOM all levels greyed out

11-27-2013 04:46 AM in reply to: -niels-

I used a clean drawing, no balloons, no nothing.

 

I can only imagine that something has slipid in somewhere. I'll play around with another assembly this evening..

*Expert Elite*
-niels-
Posts: 1,579
Registered: ‎06-20-2006
Message 6 of 8 (258 Views)

Re: BOM all levels greyed out

11-27-2013 05:07 AM in reply to: jletcher
No, it's not new.
You do not "do this", it's something that gets done for you.

But maybe i'm not clear enough or i'm missing something...

So for clarity:
1. in the assembly open the Bill of Materials.
2. check if the Structured tab is enabled.
(like barry's first image)

If it's enabled like that, when you place a Parts list on the drawing the option for selecting "all levels" will be greyed out.

To see what i meant by my quote do the following:

1. in the assembly open the Bill of Materials and make sure the Structured and the Parts only tabs are disabled. (no lists shown)
2. go to the idw and place a parts list, you should now have the option to select which kind of BOM view you want.

Hope this is more clear...

Using IV2014 Pro SP2 - upd.1, Win7-64bit
Mentor
BarryZA
Posts: 186
Registered: ‎08-27-2012
Message 7 of 8 (251 Views)

Re: BOM all levels greyed out

11-27-2013 05:24 AM in reply to: -niels-

DONE!

 

Now I can RMB on the parts list edit parts list and "+" the sub-assembly(ies) I want to.

 

Thank-you Niels.

*Expert Elite*
-niels-
Posts: 1,579
Registered: ‎06-20-2006
Message 8 of 8 (249 Views)

Re: BOM all levels greyed out

11-27-2013 05:33 AM in reply to: BarryZA
Glad you got it sorted.

I'm kinda left with the feeling i didn't understand your initial problem, but that's alright.

Just remember that you can always go back to the Bill of Materials in the model and change the properties from there.

Using IV2014 Pro SP2 - upd.1, Win7-64bit
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.