Inventor General Discussion

Inventor General Discussion

Reply
Active Contributor
Nik_Barbour
Posts: 34
Registered: ‎04-10-2013
Message 1 of 7 (610 Views)
Accepted Solution

'associative' setting when placing views memory state

610 Views, 6 Replies
02-28-2014 04:30 AM

Hi all, quick question for you...

 

What controls the default (or memorised) state for the 'associative' setting when placing views?

 

Reason for asking is, for approximately 3 days now, each time I close and restart Inventor 2014 Pro, it forgets that my preference when placing views on an idw, is to place them associative=ticked.

The memory function is OK whilst Inventor is running, but close Inventor and re-start always results in associative=unticked.

I've checked the options button on the open gui after selecting file, and it is set as it always has been (for 'design view rep' associative=ticked and the pulldown set to 'last active'. But it seems to ignore this and at first start up always has associative=unticked.

 

Roughly about the same time this started happening, I made a change to our 'Application options'. Strangely though - resurecting the old Application options seems to have fixed this amnesia on start up issue, but nowhere within the application options can I find anything related to 'associative=what' as default option.

 

Just wondered if anyone had encountered this, or knew what controls the memory state for this option, ie is it 'app options' 'the core inventor program' 'the individual model or assy file'.

 

Thanks in advance.

I just checked the code and we do not save that setting anywhere. Because that dialog is not destroyed everytime you use it it remembers the last value until you quit Inventor.

 

If we had such an option it would be in the Drawings Tab of the App options.

 

If we add View Styles some day it would be in there I imagine.

 

Employee
steven.dennis
Posts: 132
Registered: ‎10-23-2007
Message 2 of 7 (588 Views)

Re: 'associative' setting when placing views memory state

02-28-2014 10:03 AM in reply to: Nik_Barbour

I just checked the code and we do not save that setting anywhere. Because that dialog is not destroyed everytime you use it it remembers the last value until you quit Inventor.

 

If we had such an option it would be in the Drawings Tab of the App options.

 

If we add View Styles some day it would be in there I imagine.

 



Steve Dennis
Sr. Principal Engineer
Inventor
Autodesk, Inc.

Active Contributor
Nik_Barbour
Posts: 34
Registered: ‎04-10-2013
Message 3 of 7 (571 Views)

Re: 'associative' setting when placing views memory state

03-03-2014 12:26 AM in reply to: steven.dennis

Thanks for the reply - now that we have restored a previous 'imported application options' its behaving as expected, and actually remembers the state on quit even after exit of Inventor.

 

Must have been a bad exported file - it was edited using an xml editor to remove username, so it could more easily be distributed amongst the engineering dept here, but this is something we have done many times previously.

 

Thanks again.

Contributor
AndyWallace
Posts: 14
Registered: ‎05-17-2013
Message 4 of 7 (508 Views)

Re: 'associative' setting when placing views memory state

04-03-2014 07:58 AM in reply to: Nik_Barbour
Please uncheck as "solved". This issue came up in my drawing recently and it took me a while to solve it. There's also an Ideastation post on this. http://forums.autodesk.com/t5/ideas/v2/ideapage/blog-id/v1232/article-id/3994 Andy
Andy Wallace
Autodesk Inventor 2014 (1 year)
previously Solidworks (6 years)
Employee
steven.dennis
Posts: 132
Registered: ‎10-23-2007
Message 5 of 7 (504 Views)

Re: 'associative' setting when placing views memory state

04-03-2014 08:03 AM in reply to: AndyWallace
I guess between reading the idea station post and this again I'm confused. What exactly is the problem? What exactly is your proposed solution?


Steve Dennis
Sr. Principal Engineer
Inventor
Autodesk, Inc.

Contributor
AndyWallace
Posts: 14
Registered: ‎05-17-2013
Message 6 of 7 (494 Views)

Re: 'associative' setting when placing views memory state

04-03-2014 08:44 AM in reply to: steven.dennis
John's post was in the Ideastation, not mine. However jtylerbc's post has this interesting note: "Over the last few releases we can check it and it sticks when we restart inventor until you run into a file that has it unchecked, then your new default is unchecked." I tried creating a new drawing and setting associativity and LODs up to replicate this but I couldn't make it happen for me. I think that's unexpected behavior. It would be good if Inventor had an application options, drawing preferences, setting for associative views default. Andy
Andy Wallace
Autodesk Inventor 2014 (1 year)
previously Solidworks (6 years)
Employee
steven.dennis
Posts: 132
Registered: ‎10-23-2007
Message 7 of 7 (490 Views)

Re: 'associative' setting when placing views memory state

04-03-2014 09:48 AM in reply to: AndyWallace
Well the better fix for that is the introduction of a View Style that has all those settings. We have kicked that around before too. Thanks


Steve Dennis
Sr. Principal Engineer
Inventor
Autodesk, Inc.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.