Inventor General Discussion

Inventor General Discussion

Reply
Distinguished Contributor
DRoam
Posts: 134
Registered: ‎01-03-2013
Message 1 of 8 (1,101 Views)
Accepted Solution

Assemblies and drawings not updating

1101 Views, 7 Replies
01-09-2013 02:49 PM

I've searched all over google and this forum for a solution to this problem and can't find one.

 

My issue is that whenever I edit a sub-assembly or a part within an assembly, whether it's from within the assembly by right clicking and choosing "edit" or by opening the sub-assembly/part and editing it separetely, once I return to the top assembly, it does not update constraints to reflect the changes. Say I constrain the top of a part to be flush with something in the assembly. Then I edit the part and make it shorter. Once I return to the assembly, the part has shortened but it is no longer flush as it was meant to be. It is lower with respect to the plane it should be flush to. If I double-click the "flush" constraint and then click the check mark, it's like it reminds Inventor the constraint is there and the part hops up where it should be.

 

Is there any way I can click an "update" button or something so Inventor automatically checks for part changes and re-constrains everything after I make changes to sub-assemblies or parts? I found a "Refresh" button and added it to my Quick Access Toolbar, but it does absolutely nothing.

 

I often have the same issue with sheets in my .idw files; they do not update once I edit a .ipn or another view in the sheet. Is there a similar solution for this instance as well?

 

Thanks for any help you can provide.

Should do it by itself but try Manage -> Rebuild All.

Mentor
RobJV
Posts: 574
Registered: ‎07-14-2004
Message 2 of 8 (1,092 Views)

Re: Assemblies and drawings not updating

01-09-2013 03:22 PM in reply to: DRoam

Should do it by itself but try Manage -> Rebuild All.

*Expert Elite*
LT.Rusty
Posts: 852
Registered: ‎10-23-2012
Message 3 of 8 (1,090 Views)

Re: Assemblies and drawings not updating

01-09-2013 03:23 PM in reply to: DRoam

Try hitting rebuild all and / or update.


___________________________________________________________

Product Design Suite Ultimate 2013, 2014, 2015

Workstation: i7-4770k / ASUS Z87-Pro / 16GB / 250 GB SSD / 1 TB HDD / 3 TB USB3 HDD / Radeon R9-270X 4GB
Laptop: Toshiba Satellite P755-S5269 (i7-2630QM / 8 GB / 250 GB SSD / 750 GB HDD / GT540M)

*Expert Elite*
Curtis_Waguespack
Posts: 3,002
Registered: ‎03-08-2006
Message 4 of 8 (1,089 Views)

Re: Assemblies and drawings not updating

01-09-2013 03:25 PM in reply to: DRoam

Hi DRoam,

 

A couple of things come to mind.

 

Do you have a lot of adaptive parts in the assembly?

 

Also check this setting:

Tools tab > Application Options > Assembly tab > Defer Update option (turn this off if it's on)

 

I hope this helps.
Best of luck to you in all of your Inventor pursuits,
Curtis
http://inventortrenches.blogspot.com

 



  solution.png  Did you find this reply helpful ? If so please use the Accept as Solution or  Kudos button below.





Distinguished Contributor
DRoam
Posts: 134
Registered: ‎01-03-2013
Message 5 of 8 (1,054 Views)

Re: Assemblies and drawings not updating

01-10-2013 10:40 AM in reply to: RobJV

I haven't been able to test it because the issue hasn't re-occured yet, but it appears this will work, thanks!

Distinguished Contributor
DRoam
Posts: 134
Registered: ‎01-03-2013
Message 6 of 8 (1,051 Views)

Re: Assemblies and drawings not updating

01-10-2013 10:44 AM in reply to: DRoam

Thanks all for the replies. @Curtis, I don't have very many adaptive parts in the assembly. Just many, many constraints. Also that option was turned off, thanks for the info though.

Contributor
neil.hamilton
Posts: 29
Registered: ‎04-22-2013
Message 7 of 8 (805 Views)

Re: Assemblies and drawings not updating

07-03-2013 12:56 PM in reply to: DRoam

Hello! Try this, it seemed to work.

On the drawing view rt click>edit view>level of detail> toggle this a couple times. This seemd to make the permanent model browser lightning bolts go away.

"If wishes were horses,
we'd all be eating steak!"
Active Contributor
BevB
Posts: 30
Registered: ‎04-25-2005
Message 8 of 8 (742 Views)

Re: Assemblies and drawings not updating

08-21-2013 02:34 PM in reply to: DRoam

I am having the same problems with my drawings.  I create the view from an ipn and it does not update any changes that I have made in the presentation.  I've tried updating the drawing by clickimg on the Update button and it still does not update. This is not isolated to just one drawing, it will happen intermittently.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Announcements
Do you have 60 seconds to spare? The Autodesk Community Team is revamping our site ranking system and we want your feedback! Please click here to launch the 5 question survey. As always your input is greatly appreciated.