Inventor General Discussion

Reply
Board Manager
ChrisMitchell01
Posts: 418
Registered: ‎09-16-2005
Message 51 of 94 (699 Views)

Re: 2013 Materials editor

12-19-2012 04:24 PM in reply to: ing.frison

You can send the xml files to me at chris.mitchell@autodesk.com - I'll see what I can find out about this.

 

-Chris



Chris Mitchell
Inventor Customer Engagement Team
Autodesk, Inc.

Valued Contributor
ing.frison
Posts: 63
Registered: ‎09-16-2011
Message 52 of 94 (671 Views)

Re: 2013 Materials editor

12-22-2012 05:15 AM in reply to: ChrisMitchell01

Hi Chris!

 

as promised I sent you our 2012 Colors.xml and Materials.xml I assume textures would give you some additional unnecessary stress, so I supplied you also a copy without textures styles (the *_noMaps.xml files).

I hope you'll have some more luck than me...

 

Any news from Cecy Chen?

Marry Christmas!!

MaX

Massimo Frison
CAD R&D // IT Admin · AVA-Huep GmbH u. Co. KG · www.ava-huep.de
Valued Contributor
ing.frison
Posts: 63
Registered: ‎09-16-2011
Message 53 of 94 (627 Views)

Re: 2013 Materials editor

01-02-2013 04:16 PM in reply to: ChrisMitchell01

...I forgot to mention: the crashes begun after installing SP1.1 (I never installed SP1, and with pure Inv2013 things were working fine)

Massimo Frison
CAD R&D // IT Admin · AVA-Huep GmbH u. Co. KG · www.ava-huep.de
Board Manager
ChrisMitchell01
Posts: 418
Registered: ‎09-16-2005
Message 54 of 94 (596 Views)

Re: 2013 Materials editor

01-07-2013 02:39 PM in reply to: ing.frison

Max,

 

Many Thanks for sending all the info - we've identified the cause of the issue & are working on a fix for this for an upcoming update. I'll let you know as things progress.

 

Thanks,

Chris



Chris Mitchell
Inventor Customer Engagement Team
Autodesk, Inc.

Valued Contributor
ing.frison
Posts: 63
Registered: ‎09-16-2011
Message 55 of 94 (557 Views)

Re: 2013 Materials editor

01-14-2013 02:47 AM in reply to: ChrisMitchell01

Hi Chris!

 

any news on this upcoming update?

Can I ask, how did you name this issue?

 

Thanks,

Massimo

Massimo Frison
CAD R&D // IT Admin · AVA-Huep GmbH u. Co. KG · www.ava-huep.de
Board Manager
ChrisMitchell01
Posts: 418
Registered: ‎09-16-2005
Message 56 of 94 (532 Views)

Re: 2013 Materials editor

01-16-2013 02:06 PM in reply to: ing.frison

Hi Massimo.

 

A fix for the problems you reported is currently being tested; it's planned for release within the next 2-3 weeks. It will be incorporated in to "SP1.1 update2". The issue was related to some illegal characters in your xml files which were not being handled appropriately during the migration to adsklib & subsequently causing problems in the material/appearance browser.

 

Thanks,
Chris



Chris Mitchell
Inventor Customer Engagement Team
Autodesk, Inc.

*Pro
sbixler
Posts: 1,934
Registered: ‎09-15-2003
Message 57 of 94 (521 Views)

Re: 2013 Materials editor

01-17-2013 03:46 AM in reply to: ChrisMitchell01

Chris, can you expand a bit on the illegal characters?  I've had the Material & Appearance editors bark at me for illegal characters in the names, such as parentheses.  What characters are illegal, and why?

Sam B
Inventor 2012 Certified Professional

Please click "Accept as Solution" if this response answers your question.
-------------------------------------------------------------------------------------
Inventor Professional 2013 SP1.1 Update 1
Windows XP Pro 32-bit, SP3
HP EliteBook 8730w; 4 GB RAM; Core™ 2 Duo T9400 2.53 GHz; Quadro FX2700M
SpaceExplorer/SpaceNavigator NB, driver 3.7.18
still waiting for a foreshortened radius dimensioning tool in Drawing Manager

Valued Contributor
ing.frison
Posts: 63
Registered: ‎09-16-2011
Message 58 of 94 (515 Views)

Re: 2013 Materials editor

01-17-2013 05:02 AM in reply to: sbixler

From my side the illegal characters were coming from inventor standard libraries, thus the problem was not "some illegal characters in our xml files" but "some illegal characters in autodesk standard xml files". But maybe these are not the illegal characters that Chris is talking about... :smileyhappy:

 

Each item has a multilanguage description like:

 

<Style InternalName="1:Wood_cherry&#xA;" EditFlag="0" Density="0.5" YoungsModulus="10.3" PoissonsRatio="0.392" YieldStrength="49" UltimateTensileStrength="3.9" ThermalConductivity="0.12" LinearExpansion="4.5" SpecificHeat="1.2" WeldmentMaterial="0" ExternalMaterialId="2:MATERIAL:MI_InventorSustainability:F5BAD8E7-A593-4851-944B-C9EE2740032B:6E6E40AC-4081-41D9-9050-0F7267D138A8:0">
<SubStyle Type="ColorStyle" Language="1033" Collection="Colors">Wood (Cherry)</SubStyle>
<Name Language="1028" Description="">木材 (櫻桃木)</Name>
<Name Language="1029" Description="">Dřevo (třešeň)</Name>
<Name Language="1031" Description="">Holz (Kirschbaum)</Name>
<Name Language="1033" Description="">wood (cherry)</Name>
<Name Language="1036" Description="">Bois (cerisier)</Name>
<Name Language="1038" Description="">Fa (cseresznye)</Name>
<Name Language="1040" Description="">legno (ciliegio)</Name>
<Name Language="1041" Description="">Wood (Cherry)</Name>
<Name Language="1042" Description="">나무(체리)</Name>
<Name Language="1045" Description="">Drewno (wiśnia)</Name>
<Name Language="1046" Description="">Madeira (Cerejeira)</Name>
<Name Language="1049" Description="">Дерево (вишня)</Name>
<Name Language="2052" Description="">木材(樱桃木)</Name>
<Name Language="3082" Description="">Madera (cerezo)</Name>
</Style>

 

The same happens for the colors.xml

 

But actually the xml files were perfectly coherent with what specified in the xml definition (the first line of the file):

<?xml version="1.0" encoding="utf-16"?>

as the xml file opened without any problem in any browser.

 

Keep in mind that Autodesk is not new to do things a little bit "artistic", for example:

  1. if you don't have a carriage return ( &#xA; ) after the material internal name in the materials.xml file, updating of standard components will fail :smileysurprised:
  2. styles pointing to other styles (for example when you specify the text style of a table style, but also when you must choose a color for a material) are pointing NOT to the attribute Style@InternalName of the text style (as any decent database architect would do), but to the item Name of that style with the specific attribute Name@Language that you must specify in the referenced style. That's why the xml element

<SubStyle Type="ColorStyle" Language="1033" Collection="Colors">Wood (Cherry)</SubStyle>

up here is so composed (it's a little bit tricky, but it's like that... amazing) :smileylol:

 

Nevertheless we learnt to live with it, and everything was working fine... so far.

I didn't have any other illegal characters.

 

And i still prefer the xml architecture

Massimo Frison
CAD R&D // IT Admin · AVA-Huep GmbH u. Co. KG · www.ava-huep.de
Valued Contributor
ing.frison
Posts: 63
Registered: ‎09-16-2011
Message 59 of 94 (490 Views)

Re: 2013 Materials editor

01-28-2013 08:01 AM in reply to: ChrisMitchell01

Hi Chris!

 

any news on this SP1 update2 release?

I still didn't see nothing on the website.

Massimo Frison
CAD R&D // IT Admin · AVA-Huep GmbH u. Co. KG · www.ava-huep.de
Board Manager
ChrisMitchell01
Posts: 418
Registered: ‎09-16-2005
Message 60 of 94 (482 Views)

Re: 2013 Materials editor

01-28-2013 11:13 AM in reply to: ing.frison

The current status of 2013 SP1.1 Update2 shows that it should be released around Feb 5th, (subject to outcome of on-going testing).


Thanks,
Chris



Chris Mitchell
Inventor Customer Engagement Team
Autodesk, Inc.

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post
Need installation help?

Start with some of our most frequented solutions or visit the Installation and Licensing Forum to get help installing your software.